summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--main/cups/APKBUILD18
-rw-r--r--main/cups/cups-httpAddrLength.patch13
2 files changed, 7 insertions, 24 deletions
diff --git a/main/cups/APKBUILD b/main/cups/APKBUILD
index 000d188f1..3cc4a6886 100644
--- a/main/cups/APKBUILD
+++ b/main/cups/APKBUILD
@@ -1,6 +1,6 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=cups
-pkgver=1.7.4
+pkgver=1.7.5
pkgrel=0
pkgdesc="The CUPS Printing System"
url="http://www.cups.org/"
@@ -19,7 +19,6 @@ source="http://www.cups.org/software/$pkgver/cups-$pkgver-source.tar.bz2
$pkgname.logrotate
cupsd.initd
cups-no-export-ssllibs.patch
- cups-httpAddrLength.patch
"
_builddir="$srcdir"/$pkgname-$pkgver
@@ -118,18 +117,15 @@ client() {
usr/sbin/reject
}
-md5sums="1a2295c2b2d2f422db2e50f40ed2fb99 cups-1.7.4-source.tar.bz2
+md5sums="5d893edc2957005f78e2b2423fdace2e cups-1.7.5-source.tar.bz2
f861b18f4446c43918c8643dcbbd7f6d cups.logrotate
1154ed66fdcfa0523f929a369079f43c cupsd.initd
-3ba9e3410df1dc3015463d615ef91b3b cups-no-export-ssllibs.patch
-61d3cc673ee74016e76fc8ae88e2aa1f cups-httpAddrLength.patch"
-sha256sums="358fc7f22395a9ba07efcfc0d34a057ab5e9182b6e3297f71263a6b68fb41378 cups-1.7.4-source.tar.bz2
+3ba9e3410df1dc3015463d615ef91b3b cups-no-export-ssllibs.patch"
+sha256sums="18cb4c6847dbaaaa05c8b35af787f19dd5c7686970b46548e72c711c6f26bd02 cups-1.7.5-source.tar.bz2
b3308353504bc1cc0d5203ad3609bc98639ad9655b52e8ec8257286877532796 cups.logrotate
3ea71f13cf925736847ca44aa0f1a9ed944fb3d303c34af923140b20fd587e2b cupsd.initd
-ff3eb0782af0405f5dafe89e04b1b4ea7a49afc5496860d724343bd04f375832 cups-no-export-ssllibs.patch
-6996a13f77d559e8566666764435c71c4dcf7d9af9aeed48f3c70f4f177a046a cups-httpAddrLength.patch"
-sha512sums="af86076cbaa008e2c4b9a144d2999a0f1a77d801a256fd4021d4d830bb59322542181e58b54b8b36d929215e1c0db1e3f79cf58a448df64361baf46c05f84d65 cups-1.7.4-source.tar.bz2
+ff3eb0782af0405f5dafe89e04b1b4ea7a49afc5496860d724343bd04f375832 cups-no-export-ssllibs.patch"
+sha512sums="fe446b3d904539d744d3fa24f3ced2549ef9dfea8c805f1602eb71d03e19c2f06edaacf51f148e8216207af0c901f7d956c855f49b13b01112b01c9c45b75b9d cups-1.7.5-source.tar.bz2
162fe69ee46962f7ce07a9a2a75154682088895c4749c9bcfc54bb2aa861f48d7d1a8e3223f78a197319a3a405626ffe996615f6eb23168afcefabab343d5be0 cups.logrotate
3c5f4017cb1faf3e63551db53da4cb8305601adf65358bc53e982c5a0dfdd2b455a8ce735760ae3cc5ef81cdfa2a3cfe4be4107d1858d7ab9d91b4b97d3bc73b cupsd.initd
-7a8cd9ac33b0dd4627c72df4275db8ccd7cf8e201bce3833719b42f532f526bb347b842e3ea1ef0d61855b5c6e1088b5d20b68942f2c2c0acf504d8d9728efd3 cups-no-export-ssllibs.patch
-210a0c5f445e2e116a8935142f6a067ffaa2a12f7a0f8ca6e3dd3da6adce4ce75e4953fca8ee4a6eda79a6338b027bc0a6afa65e17f2158abed4de2907565d52 cups-httpAddrLength.patch"
+7a8cd9ac33b0dd4627c72df4275db8ccd7cf8e201bce3833719b42f532f526bb347b842e3ea1ef0d61855b5c6e1088b5d20b68942f2c2c0acf504d8d9728efd3 cups-no-export-ssllibs.patch"
diff --git a/main/cups/cups-httpAddrLength.patch b/main/cups/cups-httpAddrLength.patch
deleted file mode 100644
index aea8bb409..000000000
--- a/main/cups/cups-httpAddrLength.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-diff --git a/backend/lpd.c b/backend/lpd.c
-index 48d1a5f..0a1bd1e 100644
---- a/backend/lpd.c
-+++ b/backend/lpd.c
-@@ -1269,7 +1269,7 @@ rresvport_af(int *port, /* IO - Port number to bind to */
- * Try binding the port to the socket; return if all is OK...
- */
-
-- if (!bind(fd, (struct sockaddr *)&addr, httpAddrSize(&addr)))
-+ if (!bind(fd, (struct sockaddr *)&addr, httpAddrLength(&addr)))
- return (fd);
-
- /*