summaryrefslogtreecommitdiffstats
path: root/main/ntop/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/ntop/APKBUILD')
-rw-r--r--main/ntop/APKBUILD10
1 files changed, 8 insertions, 2 deletions
diff --git a/main/ntop/APKBUILD b/main/ntop/APKBUILD
index 9ab728c76..30fbef84c 100644
--- a/main/ntop/APKBUILD
+++ b/main/ntop/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Leonardo Arena <rnalrd@alpinelinux.org>
pkgname=ntop
pkgver=5.0.1
-pkgrel=2
+pkgrel=3
pkgdesc="Network traffic probe"
url="http://www.ntop.org"
arch="all"
@@ -16,6 +16,7 @@ makedepends="autoconf automake freetype-dev gdbm-dev geoip-dev
install="$pkgname.pre-install"
subpackages="$pkgname-dev $pkgname-doc"
source="http://sourceforge.net/projects/$pkgname/files/$pkgname/Stable/$pkgname-$pkgver.tar.gz
+ automake.patch
ntop.initd
ntop.confd
ntop-update-geoip-db"
@@ -24,7 +25,11 @@ _builddir="$srcdir"/$pkgname-$pkgver
prepare() {
cd "$_builddir"
- return 0
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
}
build() {
@@ -53,6 +58,7 @@ package() {
}
md5sums="01710b6925a8a5ffe1a41b8b512ebd69 ntop-5.0.1.tar.gz
+86eeacb33ececc416e66fc4260518f05 automake.patch
7fd4edf07305e0f52867256c946a5747 ntop.initd
1303915a8435560acf27748ea0cea484 ntop.confd
080de490aeed421775e6f2472d86cb94 ntop-update-geoip-db"