summaryrefslogtreecommitdiffstats
path: root/APKBUILD-svn.proto
diff options
context:
space:
mode:
Diffstat (limited to 'APKBUILD-svn.proto')
-rw-r--r--APKBUILD-svn.proto46
1 files changed, 0 insertions, 46 deletions
diff --git a/APKBUILD-svn.proto b/APKBUILD-svn.proto
deleted file mode 100644
index 63fbbb1..0000000
--- a/APKBUILD-svn.proto
+++ /dev/null
@@ -1,46 +0,0 @@
-# This is an example PKGBUILD file. Use this as a start to creating your own,
-# and remove these comments.
-# NOTE: Please fill out the license field for your package! If it is unknown,
-# then please put 'unknown'.
-
-# Contributor: Your Name <youremail@domain.com>
-pkgname=NAME-svn
-pkgver=VERSION
-pkgrel=0
-pkgdesc=""
-url=""
-license="GPL"
-depends=""
-makedepends=""
-install=
-source="$pkgname-$pkgver.tar.gz"
-
-_svntrunk=SVNURL
-_svnmod=MODENAME
-
-build() {
- cd "$srcdir"
-
- if [ -d $_svnmod/.svn ]; then
- (cd $_svnmod && svn up -r $pkgver) || return 1
- else
- svn co $_svntrunk --config-dir ./ -r $pkgver $_svnmod \
- || return 1
- fi
-
- msg "Starting make..."
-
- rm -r "$srcdir/$_svnmod-build"
- cp -r "$srcdir/$_svnmod" "$srcdir/$_svnmod-build"
- cd "$srcdir/$_svnmod-build"
-
- #
- # BUILD
- #
- ./autogen.sh
- ./configure --prefix=/usr
- make || return 1
- make DESTDIR="$pkgdir/" install
-}
-
-md5sums="" # generate with 'abuild checksum'