summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeonardo Arena <rnalrd@gmail.com>2011-03-09 07:48:09 +0000
committerLeonardo Arena <rnalrd@gmail.com>2011-03-09 07:48:09 +0000
commit241aca7fed12bd798da561149efb597677cede45 (patch)
treeae05acd8dae8fd0282d1beafc5ad87e551f3e520
parent37d37dd4170b71b3e2fb4e5178e4f1149c2858ca (diff)
downloadaports-241aca7fed12bd798da561149efb597677cede45.tar.bz2
aports-241aca7fed12bd798da561149efb597677cede45.tar.xz
main/heimdal: fixes #520
-rw-r--r--main/heimdal/APKBUILD7
1 files changed, 4 insertions, 3 deletions
diff --git a/main/heimdal/APKBUILD b/main/heimdal/APKBUILD
index c667bc51..8b0505b1 100644
--- a/main/heimdal/APKBUILD
+++ b/main/heimdal/APKBUILD
@@ -2,13 +2,13 @@
# Contributor: Natanael Copa <ncopa@alpinelinux.org>
pkgname=heimdal
pkgver=1.3.3
-pkgrel=1
+pkgrel=2
pkgdesc="An implementation of Kerberos 5"
url="http://www.h5l.org/"
license="BSD"
depends=
makedepends="gawk readline-dev e2fsprogs-dev>=1.41.9-r2 sqlite-dev autoconf automake
- libtool pkgconfig"
+ libtool pkgconfig db-dev"
install=
subpackages="$pkgname-doc $pkgname-dev $pkgname-ftp $pkgname-telnet \
$pkgname-su $pkgname-rsh $pkgname-rcp $pkgname-pagsh $pkgname-kf"
@@ -53,10 +53,11 @@ prepare() {
build() {
cd "$srcdir/$pkgname-$pkgver"
export LDFLAGS="${LDFLAGS} -Wl,--as-needed"
+ export LIBS="-ldb"
./configure --prefix=/usr \
--enable-shared=yes --without-x \
- --disable-berkeley-db \
+ --with-berkeley-db \
--with-readline-lib=/usr/lib \
--with-readline-include=/usr/include/readline \
--with-openssl=/usr