summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2011-03-07 13:14:37 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2011-03-07 13:17:10 +0000
commit3f32504885104e22136d768852e72173e38158b9 (patch)
tree21bd395fd611f2f97230b230b84043c6c17be0c1
parentfda7515b207dc57226071816cb80ab886d7699a3 (diff)
downloadaports-3f32504885104e22136d768852e72173e38158b9.tar.bz2
aports-3f32504885104e22136d768852e72173e38158b9.tar.xz
main/mkinitfs: make sure patches are applied and add virtio support
- fix / beeing world writeable when tmpfs - include virtio driver support fixes #518
-rw-r--r--main/mkinitfs/0001-included-virtio-kernel-modules.patch25
-rw-r--r--main/mkinitfs/APKBUILD23
2 files changed, 41 insertions, 7 deletions
diff --git a/main/mkinitfs/0001-included-virtio-kernel-modules.patch b/main/mkinitfs/0001-included-virtio-kernel-modules.patch
new file mode 100644
index 00000000..daf42d41
--- /dev/null
+++ b/main/mkinitfs/0001-included-virtio-kernel-modules.patch
@@ -0,0 +1,25 @@
+From a9940ddcba6f77f9a7b2fdaa1c3f921899cb0b1c Mon Sep 17 00:00:00 2001
+From: Natanael Copa <ncopa@alpinelinux.org>
+Date: Mon, 7 Mar 2011 13:06:54 +0000
+Subject: [PATCH] included virtio kernel modules
+
+see http://redmine.alpinelinux.org/issues/518
+---
+ Makefile | 1 +
+ 1 files changed, 1 insertions(+), 0 deletions(-)
+
+diff --git a/Makefile b/Makefile
+index 6389d04..31916d9 100644
+--- a/Makefile
++++ b/Makefile
+@@ -26,6 +26,7 @@ CONF_FILES := mkinitfs.conf \
+ modules.d/scsi \
+ modules.d/ubifs \
+ modules.d/usb \
++ modules.d/virtio \
+ modules.d/xfs \
+ files.d/bootchart \
+ files.d/base \
+--
+1.7.4.1
+
diff --git a/main/mkinitfs/APKBUILD b/main/mkinitfs/APKBUILD
index 38a2821b..840e88aa 100644
--- a/main/mkinitfs/APKBUILD
+++ b/main/mkinitfs/APKBUILD
@@ -1,25 +1,33 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=mkinitfs
pkgver=2.1.2
-pkgrel=1
+pkgrel=2
pkgdesc="Tool to generate initramfs images for Alpine"
url=http://git.alpinelinux.org/cgit/mkinitfs
depends="busybox apk-tools>=2.0"
triggers="$pkgname.trigger:/usr/share/kernel/*"
source="http://git.alpinelinux.org/cgit/$pkgname/snapshot/$pkgname-$pkgver.tar.bz2
0001-init-make-readonly-for-world-when-tmpfs.patch
+ 0001-included-virtio-kernel-modules.patch
eglibc.patch
"
license="GPL-2"
prepare() {
cd "$srcdir"/$pkgname-$pkgver
-
- # If we are using eglibc we need to include eglibc libs
- # instead of uclibc libs.
- if [ "$ALPINE_LIBC" = "eglibc" ]; then
- patch -p1 -i "$srcdir"/eglibc.patch || return 1
- fi
+ for i in $source; do
+ case $i in
+ eglibc.patch)
+ # If we are using eglibc we need to include eglibc libs
+ # instead of uclibc libs.
+ if [ "$ALPINE_LIBC" = "eglibc" ]; then
+ patch -p1 -i "$srcdir"/eglibc.patch || return 1
+ fi
+ ;;
+ *.patch)
+ msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
}
build() {
@@ -33,4 +41,5 @@ package() {
}
md5sums="e35426eb23b379a648500a353031e719 mkinitfs-2.1.2.tar.bz2
e38e2f5c2b22b2789b5bc03aacba4d2d 0001-init-make-readonly-for-world-when-tmpfs.patch
+15f6a307d607272d61f5a9c86aa0d2e5 0001-included-virtio-kernel-modules.patch
e59c2f7de496fe430b07e32fd812ebe0 eglibc.patch"