summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2011-03-23 15:26:18 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2011-03-23 15:26:18 +0000
commit8a6e2803a04f457c70a7cc404f55dd6fff593975 (patch)
treecceae144a8d97782434b325f6202fd5d4ccc04fe
parentb7f213e7b27708f141f0b151e67fb4c24accfac2 (diff)
downloadaports-8a6e2803a04f457c70a7cc404f55dd6fff593975.tar.bz2
aports-8a6e2803a04f457c70a7cc404f55dd6fff593975.tar.xz
main/freeswitch: update to 1.0.7_p20110323
(cherry picked from commit 601269c1a43a8f3859713bb1564a7e28c5f5dc0d) Conflicts: main/freeswitch/APKBUILD
-rw-r--r--main/freeswitch/APKBUILD17
1 files changed, 10 insertions, 7 deletions
diff --git a/main/freeswitch/APKBUILD b/main/freeswitch/APKBUILD
index f4281ee2..4d88b3f6 100644
--- a/main/freeswitch/APKBUILD
+++ b/main/freeswitch/APKBUILD
@@ -1,7 +1,9 @@
# Contributor: Michael Mason <ms13sp@gmail.com>
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=freeswitch
-pkgver=1.0.7
+pkgver=1.0.7_p20110323
+_ver=${pkgver%_p*}
+_snapshot=${pkgver#*_p}
pkgrel=0
pkgdesc="A communications platform written in C from the ground up"
url="http://www.freeswitch.org"
@@ -11,13 +13,14 @@ makedepends="curl-dev unixodbc-dev zlib-dev openssl-dev ncurses-dev
autoconf automake libtool libpri-dev bash"
install="$pkgname.pre-install $pkgname.post-install $pkgname.pre-upgrade"
subpackages="$pkgname-dev $pkgname-flite $pkgname-sample-config:conf"
-source="http://latest.freeswitch.org/freeswitch-$pkgver.tar.gz
+#source="http://latest.freeswitch.org/freeswitch-$pkgver.tar.gz
+source="http://distfiles.alpinelinux.org/distfiles/freeswitch-$pkgver.tar.gz
modules.conf
freeswitch.confd
freeswitch.initd
"
-_builddir="$srcdir/$pkgname-$pkgver"
+_builddir="$srcdir/$pkgname-$_ver"
prepare() {
cd "$_builddir"
@@ -25,7 +28,7 @@ prepare() {
}
build() {
- cd "$_builddir"
+ cd "$_builddir"
# i think our max cmd len is 32768
# by specifying it here we save our selves from some CPU cycles
@@ -55,7 +58,7 @@ build() {
make -j1 all || return 1
}
package(){
- cd "$srcdir/$pkgname-$pkgver"
+ cd "$_builddir"
make -j1 DESTDIR="$pkgdir" install || return 1
# we need to do some moving/cleanup to allow some... kind of FHS
mkdir -p "$pkgdir"/var/run/freeswitch
@@ -103,7 +106,7 @@ conf() {
mkdir -p "$pkgdir"/etc/freeswitch/scripts
}
-md5sums="0a685b4cdd2466da28695fc09b8fc11e freeswitch-1.0.7.tar.gz
-f2549767e058ec57b159b80b54446421 modules.conf
+md5sums="ecca23d810c8ec1853c87c7fdc603bc5 freeswitch-1.0.7_p20110323.tar.gz
+a3383f46dc62ec1fa00eab584d7ee472 modules.conf
c608cca8ad773acebf201f581438c7e7 freeswitch.confd
aa358c9ca0d8b93fabb6a36a5ed4c469 freeswitch.initd"