summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2011-03-22 16:09:21 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2011-03-23 15:52:33 +0000
commit8bf83b8142b9b0c55b50f1e1011c574b47ce935b (patch)
tree8c65a7bc91df81ae05e0bc2bd17abd07e0c9ba90
parent5094d96e587fb2b76f55b5930f6de97258605aa8 (diff)
downloadaports-8bf83b8142b9b0c55b50f1e1011c574b47ce935b.tar.bz2
aports-8bf83b8142b9b0c55b50f1e1011c574b47ce935b.tar.xz
main/lua: upgrade to 5.1.4_p3
(cherry picked from commit acdd8885dd810ddcea0f0dc77b9cb34e66c97709)
-rw-r--r--main/lua/APKBUILD16
1 files changed, 9 insertions, 7 deletions
diff --git a/main/lua/APKBUILD b/main/lua/APKBUILD
index 5a3613ea..c30a6c7e 100644
--- a/main/lua/APKBUILD
+++ b/main/lua/APKBUILD
@@ -1,22 +1,24 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=lua
-pkgver=5.1.4
-pkgrel=6
+pkgver=5.1.4_p3
+_ver=${pkgver%_p*}
+pkgrel=0
pkgdesc="A powerful light-weight programming language designed for extending applications."
url="http://www.lua.org/"
license="MIT"
depends=
makedepends="readline-dev libtool"
subpackages="$pkgname-dev $pkgname-doc"
-source="http://www.$pkgname.org/ftp/$pkgname-$pkgver.tar.gz
- http://www.lua.org/ftp/patch-lua-5.1.4-2
+source="http://www.$pkgname.org/ftp/$pkgname-$_ver.tar.gz
+ http://www.lua.org/ftp/patch-lua-5.1.4-${pkgver#*_p}
lua-5.1-make.patch
lua-5.1-module_paths.patch
"
+_builddir="$srcdir"/lua-$_ver
build ()
{
- cd "$srcdir"/$pkgname-$pkgver
+ cd "$_builddir"
for i in $source; do
case $i in
patch*|*.patch)
@@ -42,7 +44,7 @@ build ()
}
package() {
- cd "$srcdir/$pkgname-$pkgver"
+ cd "$_builddir"
make INSTALL_TOP="$pkgdir"/usr INSTALL_LIB="$pkgdir"/usr/lib \
V=$pkgver gentoo_install || return 1
@@ -51,6 +53,6 @@ package() {
install -D -m 644 doc/luac.1 "$pkgdir"/usr/share/man/man1/luac.1
}
md5sums="d0870f2de55d59c1c8419f36e8fac150 lua-5.1.4.tar.gz
-1239310e0c4a581c7831e596f95cc6cd patch-lua-5.1.4-2
+998ef7886183f61d3a5ca891a9ce6a79 patch-lua-5.1.4-3
0145ff6036eb6bfdab427dc8f0c3f3c0 lua-5.1-make.patch
e60ef15deefb72a5930c498f1184aced lua-5.1-module_paths.patch"