summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2011-04-11 11:53:34 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2011-04-11 11:53:34 +0000
commitbf661e49d5d19eae50242031ef85b752fe541132 (patch)
treed71ad116700b250c19542b44990d507ced03ee33
parentc452528a37a334dba4beaf8f3595f69556187d47 (diff)
downloadaports-bf661e49d5d19eae50242031ef85b752fe541132.tar.bz2
aports-bf661e49d5d19eae50242031ef85b752fe541132.tar.xz
main/abuild: fix buildrepo
-rw-r--r--main/abuild/0001-buildrepo-fix-purging-of-old-packages.patch2
-rw-r--r--main/abuild/0002-buildrepo-fix-previous-commit.patch36
-rw-r--r--main/abuild/APKBUILD6
3 files changed, 41 insertions, 3 deletions
diff --git a/main/abuild/0001-buildrepo-fix-purging-of-old-packages.patch b/main/abuild/0001-buildrepo-fix-purging-of-old-packages.patch
index d12fafb5..402535c0 100644
--- a/main/abuild/0001-buildrepo-fix-purging-of-old-packages.patch
+++ b/main/abuild/0001-buildrepo-fix-purging-of-old-packages.patch
@@ -1,7 +1,7 @@
From 54ca2cb82aafc43e77dff1bacb80ed25a55f6ae7 Mon Sep 17 00:00:00 2001
From: Natanael Copa <ncopa@alpinelinux.org>
Date: Thu, 7 Apr 2011 14:34:51 +0000
-Subject: [PATCH] buildrepo: fix purging of old packages
+Subject: [PATCH 1/2] buildrepo: fix purging of old packages
---
buildrepo.in | 2 +-
diff --git a/main/abuild/0002-buildrepo-fix-previous-commit.patch b/main/abuild/0002-buildrepo-fix-previous-commit.patch
new file mode 100644
index 00000000..522b005f
--- /dev/null
+++ b/main/abuild/0002-buildrepo-fix-previous-commit.patch
@@ -0,0 +1,36 @@
+From 18beb69377c4e4809c572cb287e8879d51bebedc Mon Sep 17 00:00:00 2001
+From: Natanael Copa <ncopa@alpinelinux.org>
+Date: Mon, 11 Apr 2011 11:51:39 +0000
+Subject: [PATCH 2/2] buildrepo: fix previous commit
+
+---
+ buildrepo.in | 6 +++---
+ 1 files changed, 3 insertions(+), 3 deletions(-)
+
+diff --git a/buildrepo.in b/buildrepo.in
+index 405e500..79954da 100755
+--- a/buildrepo.in
++++ b/buildrepo.in
+@@ -61,8 +61,8 @@ build() {
+ pkgs=$(abuild listpkg)
+ if all_exist $pkgs; then
+ echo ">>> Copying " $pkgs
+- cp -p -l $pkgs "$repodir/$repo/$CARCH"/ 2>/dev/null \
+- || cp -p $pkgs "$repodir/$repo/$CARCH"/ \
++ cp -p -l $pkgs "$repodir/$repo/$arch"/ 2>/dev/null \
++ || cp -p $pkgs "$repodir/$repo/$arch"/ \
+ || needbuild="$needbuild $i"
+ else
+ needbuild="$needbuild $i"
+@@ -81,7 +81,7 @@ build() {
+ if [ -n "$dopurge" ]; then
+ local tmp=$(mktemp /tmp/$program-XXXXXX)
+ local purgefiles
+- cd "$repodir/$repo/$CARCH" || return 1
++ cd "$repodir/$repo/$arch" || return 1
+ trap 'rm -f "$tmp"; exit 1' INT
+ ( listpackages "$1") >$tmp
+ purge=$(ls *.apk 2>/dev/null | grep -v -w -f $tmp)
+--
+1.7.4.4
+
diff --git a/main/abuild/APKBUILD b/main/abuild/APKBUILD
index 1848c689..17b2915b 100644
--- a/main/abuild/APKBUILD
+++ b/main/abuild/APKBUILD
@@ -2,10 +2,11 @@
pkgdesc="Script to build Alpine Packages"
pkgname=abuild
pkgver=2.9.1
-pkgrel=1
+pkgrel=2
url=http://git.alpinelinux.org/cgit/abuild/
source="http://git.alpinelinux.org/cgit/abuild.git/snapshot/abuild-$pkgver.tar.bz2
0001-buildrepo-fix-purging-of-old-packages.patch
+ 0002-buildrepo-fix-previous-commit.patch
"
depends="fakeroot file sudo pax-utils openssl apk-tools>=2.0.7-r1"
makedepends="openssl-dev pkgconfig"
@@ -39,4 +40,5 @@ package() {
}
md5sums="e6c418567cd95eacc1278850dc88ee00 abuild-2.9.1.tar.bz2
-951500370d6b06195aac633699aa88f5 0001-buildrepo-fix-purging-of-old-packages.patch"
+6ad9a80d107beda61e30b33f4fb35a35 0001-buildrepo-fix-purging-of-old-packages.patch
+0da412b51c7f177a140fff08c76a9270 0002-buildrepo-fix-previous-commit.patch"