summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--thunderbird/0001-disable-features-headers.patch15
-rw-r--r--thunderbird/0002-musl-uses-off64_t.patch13
-rw-r--r--thunderbird/APKBUILD147
3 files changed, 0 insertions, 175 deletions
diff --git a/thunderbird/0001-disable-features-headers.patch b/thunderbird/0001-disable-features-headers.patch
deleted file mode 100644
index 46ebd8d..0000000
--- a/thunderbird/0001-disable-features-headers.patch
+++ /dev/null
@@ -1,15 +0,0 @@
-Taking a hint from William Pitcock's firefox APKBUILD
-features.h causes problems when pulling in system headers - we don't need it
-
-diff --git a/mozilla/config/system-headers b/mozilla/config/system-headers
-index 403fa8d..182e928 100644
---- a/mozilla/config/system-headers
-+++ b/mozilla/config/system-headers
-@@ -420,7 +420,6 @@ execinfo.h
- extras.h
- fabdef.h
- fcntl.h
--features.h
- fibdef.h
- File.h
- filehdr.h
diff --git a/thunderbird/0002-musl-uses-off64_t.patch b/thunderbird/0002-musl-uses-off64_t.patch
deleted file mode 100644
index 5a67783..0000000
--- a/thunderbird/0002-musl-uses-off64_t.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-diff --git a/mozilla/toolkit/crashreporter/google-breakpad/src/third_party/lss/linux_syscall_support.h b/mozilla/toolkit/crashreporter/google-breakpad/src/third_party/lss/linux_syscall_support.h
-index 1827749..b67d3a9 100644
---- a/mozilla/toolkit/crashreporter/google-breakpad/src/third_party/lss/linux_syscall_support.h
-+++ b/mozilla/toolkit/crashreporter/google-breakpad/src/third_party/lss/linux_syscall_support.h
-@@ -2814,7 +2814,7 @@ struct kernel_statfs {
- LSS_INLINE _syscall6(void*, mmap, void*, s,
- size_t, l, int, p,
- int, f, int, d,
-- __off64_t, o)
-+ off64_t, o)
-
- LSS_INLINE _syscall4(int, newfstatat, int, d,
- const char *, p,
diff --git a/thunderbird/APKBUILD b/thunderbird/APKBUILD
deleted file mode 100644
index 9d72c58..0000000
--- a/thunderbird/APKBUILD
+++ /dev/null
@@ -1,147 +0,0 @@
-# Maintainer: Nathan Angelacos <nangel@alpinelinux.org>
-pkgname=thunderbird
-pkgver=45.6.0
-pkgrel=0
-pkgdesc="Standalone mail and news reader from mozilla.org"
-arch=all
-license='GPL'
-url="https://www.mozilla.org/thunderbird/"
-# depends=('gtk+2.0-dev' 'mozilla-common' 'libxt' 'startup-notification' 'mime-types'
-# 'dbus-glib' 'alsa-lib' 'libvpx' 'libevent' 'nss' 'hunspell'
-# 'sqlite' 'ttf-font' 'icu')
-makedepends="
- alsa-lib-dev
- gconf-dev
- gtk+2.0-dev
- hunspell-dev
- icu-dev
- libevent-dev
- libjpeg-turbo-dev
- libnotify-dev
- libogg-dev
- libtheora-dev
- libvorbis-dev
- libvpx-dev
- libxt-dev
- libxcomposite-dev
- mesa-dev
- nspr-dev
- nss-dev
- sqlite-dev
- startup-notification-dev
- bsd-compat-headers
- zip
- unzip
- python2
- yasm
- mesa
- imake
- "
-source="https://ftp.mozilla.org/pub/mozilla.org/thunderbird/releases/$pkgver/source/thunderbird-$pkgver.source.tar.xz \
- 0001-disable-features-headers.patch
- 0002-musl-uses-off64_t.patch
- fix-fortify-system-wrappers.patch
- fix-seccomp-bpf.patch
- fix-stack-overflow.patch
- mallinfo.patch
- musl-pthread-setname.patch
- "
-
-builddir="$srcdir"/$pkgname-$pkgver
-
-prepare() {
-
- default_prepare || return 1
- # cd $pkgname-$pkgver
-
- #cp ../mozconfig .mozconfig
- #mkdir "$srcdir/path"
- #ln -s /usr/bin/python2 "$srcdir/path/python"
-}
-
-build() {
- cd "$builddir"
-
- export SHELL=/bin/sh
- export BUILD_OFFICIAL=1
- export MOZILLA_OFFICIAL=1
- export USE_SHORT_LIBNAME=1
- # gcc 6
- export CXXFLAGS="-fno-delete-null-pointer-checks -fno-schedule-insns2"
-
- # set rpath so linker finds the libs
- export LDFLAGS="$LDFLAGS -Wl,-rpath,${_mozappdir}"
-
- ./configure \
- --prefix=/usr \
- \
- --disable-crashreporter \
- --disable-elf-hack \
- --disable-install-strip \
- --disable-jemalloc \
- --disable-profiling \
- --disable-pulseaudio \
- --disable-strip \
- --disable-tests \
- --disable-updater \
- --disable-gstreamer \
- \
- --enable-default-toolkit=cairo-gtk3 \
- --enable-gio \
- --enable-gold=no \
- --enable-official-branding \
- --enable-optimize="$CFLAGS" \
- --enable-pie \
- --enable-startup-notification \
- --enable-system-ffi \
- --enable-system-hunspell \
- --enable-system-sqlite \
- \
- --with-pthreads \
- --with-system-bz2 \
- --with-system-icu \
- --with-system-jpeg \
- --with-system-libevent \
- --with-system-libvpx \
- --with-system-nspr \
- --with-system-nss \
- --with-system-pixman \
- --with-system-png \
- --with-system-zlib \
- || return 1
- make || return 1
-}
-
-package() {
- cd "$builddir"
- make DESTDIR="${pkgdir}" INSTALL_SDK= install || return 1
-
- # Replace duplicate binary with symlink
- # https://bugzilla.mozilla.org/show_bug.cgi?id=658850
- ln -sf thunderbird "$pkgdir/usr/lib/thunderbird/thunderbird-bin"
-}
-
-md5sums="efb6b195c9c27a654ba115d7eda4362e thunderbird-45.6.0.source.tar.xz
-ce2ab32e20ecc90f751a24d323165909 0001-disable-features-headers.patch
-2cd4ef50f8fd27c1109fa4296ed5b246 0002-musl-uses-off64_t.patch
-9aba3811121f113fe547947591802d2b fix-fortify-system-wrappers.patch
-aed3b88014fbfbe73db79851e52ca7fa fix-seccomp-bpf.patch
-0538d10d2a14576c5aad6048c942a42c fix-stack-overflow.patch
-0db0cce8350d59a91ae2c4f0400f7146 mallinfo.patch
-44b6255ed6a0bffb8848e549afa642f3 musl-pthread-setname.patch"
-sha256sums="c32c74d69c4a2f79f120f44965525fc8197bbd39a9dac85027b2d9f74e04d8dc thunderbird-45.6.0.source.tar.xz
-b4fd1f7990032f29bd8480ecdf5e14d11cb206aec0e67ddf132aa5c66355c1bf 0001-disable-features-headers.patch
-7fe6bdefd980d2ff1b5346398d615784c74de7ac5c70953d7ab14e4e72c88f96 0002-musl-uses-off64_t.patch
-cd19195cb4c316ad9f7d377cd8581218c888863b1bc4d112c97f48a4425fb946 fix-fortify-system-wrappers.patch
-517d95225b3323c373c11da6ab867deb76ffdb0b50c1762bdd893abd9b39d4c9 fix-seccomp-bpf.patch
-e568adf5d43220b831fd538b4387c14c046efc1bdab4257467fbfd86ee5830aa fix-stack-overflow.patch
-2f564fa5f347f3c7f20d589ef273f000ca9c9aeca2c6ad0fb5b15bfc715d8b81 mallinfo.patch
-e0e85f0448fda03e1d29fbf71e094824f2a0ce538c6bf44e09545402f81e7f96 musl-pthread-setname.patch"
-sha512sums="1f4579ac37b8ab98c91fe2e3e6742ba1b005ca9346d23f467d19e6af45eb457cab749bf91ed2a79f2058bd66f54da661da3ea5d5786f8c4b472d8a2a6c34db4b thunderbird-45.6.0.source.tar.xz
-a418461fdcb4ec79a73a8254267c76bc148bd165b692e49ce261303bc622fa2716462a574f80041da777554adc017d9410983959c469ca5ac6f667a5c859f804 0001-disable-features-headers.patch
-4373b24c026602da6ab5a56fba3affa30b68e18e5e52374773c9f91276e397365ec03a538075f3f4882a074412175d33c647d718c6a874ba41043ecffd72ac61 0002-musl-uses-off64_t.patch
-2a967e4619fd89a046bd40be7fdcef646fcb1eba5e47afc96aa1d59c25bcc8747cb07baee6c11f3b803db0981aced181534b806778e4d21e74958f5f4d74c784 fix-fortify-system-wrappers.patch
-70863b985427b9653ce5e28d6064f078fb6d4ccf43dd1b68e72f97f44868fc0ce063161c39a4e77a0a1a207b7365d5dc7a7ca5e68c726825eba814f2b93e2f5d fix-seccomp-bpf.patch
-c815131b04e25162d8b32e75e58c3f670492996a41a0cc27a72432ed37fb3a5488a6eb474c2a1bf455d3546cde3b6871b46bcdbef8e2f37d1133c40819aa6f11 fix-stack-overflow.patch
-bdcd1b402d2ec94957ba5d08cbad7b1a7f59c251c311be9095208491a05abb05a956c79f27908e1f26b54a3679387b2f33a51e945b650671ad85c0a2d59a5a29 mallinfo.patch
-3f535b1e4e9a5a0506ef6f6d9427a84fae1efa3c8e8d6b25b21046d2d04c132bde1a7a98e415067e5c542f699d89249b8cc3d925e0be4e96db498037429691ef musl-pthread-setname.patch"