summaryrefslogtreecommitdiffstats
path: root/test/repo2/test-a/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'test/repo2/test-a/APKBUILD')
-rw-r--r--test/repo2/test-a/APKBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/test/repo2/test-a/APKBUILD b/test/repo2/test-a/APKBUILD
new file mode 100644
index 0000000..693cf61
--- /dev/null
+++ b/test/repo2/test-a/APKBUILD
@@ -0,0 +1,33 @@
+# Contributor:
+# Maintainer:
+pkgname=test-a
+pkgver=1.1
+pkgrel=0
+pkgdesc="Package A for apk-tools testsuite"
+url="http://alpinelinux.org"
+license="GPL"
+depends=
+makedepends=
+install=
+subpackages=
+source=""
+
+_builddir="$srcdir"/$pkgname-$pkgver
+prepare() {
+ mkdir -p "$_builddir"
+}
+
+build() {
+ cd "$_builddir"
+ cat > $pkgname << __EOF__
+#!/bin/sh
+echo "hello from $pkgname-$pkgver"
+__EOF__
+}
+
+package() {
+ cd "$_builddir"
+ install -Dm755 $pkgname "$pkgdir"/usr/bin/$pkgname
+}
+
+md5sums="" #generate with 'abuild checksum'