summaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile14
1 files changed, 14 insertions, 0 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..f1f231a
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,14 @@
+
+CC ?= gcc
+LD ?= gcc
+
+CFLAGS ?= -Werror -Wall -g -DDEBUG
+LDFLAGS ?=
+
+aports-cache-objs := aports-cache.o
+
+%.o: %.c
+ $(CC) $(CFLAGS) $(CFLAGS_$(notdir $@)) -c -o $@ $<
+
+aports-cache: aports-cache.o
+ $(CC) $(LDFLAGS) -o $@ $(LIBS_$(notdir $@)) $<