aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2018-06-12 09:28:40 +0200
committerNatanael Copa <ncopa@alpinelinux.org>2018-06-12 09:32:15 +0200
commitc5ade44ba222c613b02db33e0ca6082d320aaf30 (patch)
tree3b88e6a1b8790db9aafe9d704ad6966433eedbe0 /Makefile
downloadaports-ghpr-c5ade44ba222c613b02db33e0ca6082d320aaf30.tar.bz2
aports-ghpr-c5ade44ba222c613b02db33e0ca6082d320aaf30.tar.xz
initial import
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile13
1 files changed, 13 insertions, 0 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..16822da
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,13 @@
+
+prog = aports-ghpr
+prefix = /usr/local
+bindir = $(prefix)/bin
+
+$(prog): $(prog).go
+ go build -v $^
+
+install: $(prog)
+ install -Dm755 $(prog) $(DESTDIR)$(bindir)/$(prog)
+
+clean:
+ rm -f $(prog)