summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2010-03-17 09:08:35 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2010-03-17 09:08:35 +0000
commit2602bb92b08edc43b811f50487b9bd573e2c757f (patch)
tree86a68164784a4ab1c21106312b941a94d3e9cb7e
parent159aad5d8b44a5aa6f9ef98a4eefbb6e7692207b (diff)
downloadaports-2602bb92b08edc43b811f50487b9bd573e2c757f.tar.bz2
aports-2602bb92b08edc43b811f50487b9bd573e2c757f.tar.xz
testing/daemontools: removed from stable branch
-rw-r--r--testing/daemontools/0.76-errno.patch11
-rw-r--r--testing/daemontools/0.76-warnings.patch74
-rw-r--r--testing/daemontools/APKBUILD48
-rw-r--r--testing/daemontools/svscan.initd33
4 files changed, 0 insertions, 166 deletions
diff --git a/testing/daemontools/0.76-errno.patch b/testing/daemontools/0.76-errno.patch
deleted file mode 100644
index 3af157c4..00000000
--- a/testing/daemontools/0.76-errno.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/error.h 2001-07-12 11:49:49.000000000 -0500
-+++ src/error.h 2003-02-26 02:14:06.000000000 -0600
-@@ -3,7 +3,7 @@
- #ifndef ERROR_H
- #define ERROR_H
-
--extern int errno;
-+#include <errno.h>
-
- extern int error_intr;
- extern int error_nomem;
diff --git a/testing/daemontools/0.76-warnings.patch b/testing/daemontools/0.76-warnings.patch
deleted file mode 100644
index f558bb18..00000000
--- a/testing/daemontools/0.76-warnings.patch
+++ /dev/null
@@ -1,74 +0,0 @@
-Fixup misc warnings
-
-Patch by RiverRat
-
-http://bugs.gentoo.org/124487
-
---- src/chkshsgr.c
-+++ src/chkshsgr.c
-@@ -1,10 +1,13 @@
- /* Public domain. */
-
-+#include <sys/types.h>
-+#include <stdlib.h>
-+#include <grp.h>
- #include <unistd.h>
-
- int main()
- {
-- short x[4];
-+ gid_t x[4];
-
- x[0] = x[1] = 0;
- if (getgroups(1,x) == 0) if (setgroups(1,x) == -1) _exit(1);
---- src/matchtest.c
-+++ src/matchtest.c
-@@ -1,3 +1,4 @@
-+#include <unistd.h>
- #include "match.h"
- #include "buffer.h"
- #include "str.h"
---- src/multilog.c
-+++ src/multilog.c
-@@ -1,3 +1,4 @@
-+#include <stdio.h>
- #include <unistd.h>
- #include <sys/types.h>
- #include <sys/stat.h>
---- src/prot.c
-+++ src/prot.c
-@@ -1,5 +1,8 @@
- /* Public domain. */
-
-+#include <sys/types.h>
-+#include <unistd.h>
-+#include <grp.h>
- #include "hasshsgr.h"
- #include "prot.h"
-
---- src/seek_set.c
-+++ src/seek_set.c
-@@ -1,6 +1,7 @@
- /* Public domain. */
-
- #include <sys/types.h>
-+#include <unistd.h>
- #include "seek.h"
-
- #define SET 0 /* sigh */
---- src/supervise.c
-+++ src/supervise.c
-@@ -1,3 +1,4 @@
-+#include <stdio.h>
- #include <unistd.h>
- #include <sys/types.h>
- #include <sys/stat.h>
---- src/pathexec_run.c
-+++ src/pathexec_run.c
-@@ -1,5 +1,6 @@
- /* Public domain. */
-
-+#include <unistd.h>
- #include "error.h"
- #include "stralloc.h"
- #include "str.h"
diff --git a/testing/daemontools/APKBUILD b/testing/daemontools/APKBUILD
deleted file mode 100644
index 98bf9952..00000000
--- a/testing/daemontools/APKBUILD
+++ /dev/null
@@ -1,48 +0,0 @@
-# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
-pkgname=daemontools
-pkgver=0.76
-pkgrel=0
-pkgdesc="Collection of tools for managing UNIX services"
-url="http://cr.yp.to/daemontools.html"
-license="public-domain"
-depends=
-# The makefile need GNU cat for 'cat -v'
-makedepends="coreutils"
-
-source="http://cr.yp.to/daemontools/$pkgname-$pkgver.tar.gz
- 0.76-errno.patch
- 0.76-warnings.patch
- svscan.initd
- "
-
-_builddir="$srcdir"/admin/$pkgname-$pkgver/src
-
-prepare() {
- cd "$_builddir"
- for i in "$srcdir"/*.patch; do
- msg "Applying $i"
- patch -p1 -i $i || return 1
- done
-}
-
-build() {
- cd "$_builddir"
- echo "${CC:-"gcc"} ${CFLAGS}" > conf-cc
- echo "${CC:-"gcc"} ${LDFLAGS}" > conf-ld
- touch > home
- make PATH="/usr/bin:/bin" || return 1
-}
-
-package() {
- cd "$_builddir"
- mkdir -p "$pkgdir"/usr/bin "$pkgdir"/service
- for f in $(cat ../package/commands); do
- cp $f "$pkgdir"/usr/bin/$f
- done
- install -Dm755 "$srcdir"/svscan.initd "$pkgdir"/etc/init.d/svscan
-}
-
-md5sums="1871af2453d6e464034968a0fbcb2bfc daemontools-0.76.tar.gz
-c75438b1c3b9d9f67691bd10cf3c8e52 0.76-errno.patch
-ad68177f50bfffb6a1cbf8c668de6a55 0.76-warnings.patch
-c6e4ace205400be062d3ba82315cbcd1 svscan.initd"
diff --git a/testing/daemontools/svscan.initd b/testing/daemontools/svscan.initd
deleted file mode 100644
index bf7af28f..00000000
--- a/testing/daemontools/svscan.initd
+++ /dev/null
@@ -1,33 +0,0 @@
-#!/sbin/runscript
-# Copyright 1999-2004 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-process/daemontools/files/svscan.init-0.76-r7,v 1.1 2008/12/07 06:59:37 robbat2 Exp $
-
-depend() {
- use net
- before ntpd ntp-client spamd apache apache2
- after firewall
-}
-
-start() {
- ebegin "Starting service scan"
- setsid start-stop-daemon --start --exec /usr/bin/svscan \
- --background --make-pidfile \
- --pidfile /var/run/svscan.pid -- /service
- eend $?
-}
-
-stop() {
- ebegin "Stopping service scan"
- start-stop-daemon --stop --exec /usr/bin/svscan \
- --pidfile /var/run/svscan.pid
- eend $?
-
- ebegin "Stopping service scan services"
- svc -dx /service/* 2>/dev/null
- eend $?
-
- ebegin "Stopping service scan logging"
- svc -dx /service/*/log 2>/dev/null
- eend $?
-}