summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2010-03-17 09:08:37 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2010-03-17 09:08:37 +0000
commit43e5a3e2f33791651752db83c734cc2d39e2e86e (patch)
treeb076ff8a2fe6e0f3370c6f794cae1ff16ef52e8d
parente31aca632e200605ece79effbfa723cbae4c47af (diff)
downloadaports-43e5a3e2f33791651752db83c734cc2d39e2e86e.tar.bz2
aports-43e5a3e2f33791651752db83c734cc2d39e2e86e.tar.xz
testing/pllua: removed from stable branch
-rw-r--r--testing/pllua/APKBUILD36
-rw-r--r--testing/pllua/pllua-01-0.3.1-include.patch14
2 files changed, 0 insertions, 50 deletions
diff --git a/testing/pllua/APKBUILD b/testing/pllua/APKBUILD
deleted file mode 100644
index 09ef17f5..00000000
--- a/testing/pllua/APKBUILD
+++ /dev/null
@@ -1,36 +0,0 @@
-# Contributor: Michael Mason <ms13sp@gmail.com>
-# Maintainer: Michael Mason <ms13sp@gmail.com>
-pkgname=pllua
-pkgver=0.3.1
-pkgrel=0
-pkgdesc="Procedural language for PostgreSQL using Lua"
-url="http://pgfoundry.org/projects/pllua"
-license="GPL"
-depends="postgresql"
-makedepends="postgresql-dev lua-dev ccache"
-install=
-subpackages=""
-source="http://pgfoundry.org/frs/download.php/1722/$pkgname-$pkgver.tar.gz
- pllua-01-0.3.1-include.patch"
-
-# append extra dependencies to -dev subpackage
-# remove if not used.
-# depends_dev="somepackage-dev"
-
-build() {
- cd "$srcdir"/$pkgname-$pkgver
- for i in "$srcdir"/*.patch; do
- msg "Applying ${i}"
- patch -p1 -i $i || return 1
- done
-
- make || return 1
- make DESTDIR="$pkgdir" install
-
- # remove the 2 lines below (and this) if there is no init.d script
- # install -m755 -D "$srcdir"/$pkgname.initd "$pkgdir"/etc/init.d/$pkgname
- # install -m644 -D "$srcdir"/$pkgname.confd "$pkgdir"/etc/conf.d/$pkgname
-}
-
-md5sums="e57385bdf2d533ac73cd02401795cea8 pllua-0.3.1.tar.gz
-a47387e64b7dba8d58237c7dad0e2d61 pllua-01-0.3.1-include.patch"
diff --git a/testing/pllua/pllua-01-0.3.1-include.patch b/testing/pllua/pllua-01-0.3.1-include.patch
deleted file mode 100644
index afbf8a98..00000000
--- a/testing/pllua/pllua-01-0.3.1-include.patch
+++ /dev/null
@@ -1,14 +0,0 @@
-#most of fix from here http://postgis.refractions.net/pipermail/postgis-devel/2009-February/004879.html
---- pllua-0.3.1/plluaapi.c.orig Thu Sep 17 15:34:07 2009
-+++ pllua-0.3.1/plluaapi.c Thu Sep 17 15:34:18 2009
-@@ -7,6 +7,10 @@
-
- #include "pllua.h"
- #include "rowstamp.h"
-+#include "utils/guc.h"
-+extern Datum textout (PG_FUNCTION_ARGS);
-+extern Datum bpcharout(PG_FUNCTION_ARGS);
-+extern Datum varcharout(PG_FUNCTION_ARGS);
-
- /* extended function info */
- typedef struct luaP_Info {