summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2010-03-17 09:08:35 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2010-03-17 09:08:35 +0000
commit4c21267fa2868876f69e7e89b5544b774f251d0a (patch)
tree96c46d070dfb1d617cb72b9c747aa31b251491a5
parent320c49aa1a840c3eadeb2bc388fae0fbca4b72e0 (diff)
downloadaports-4c21267fa2868876f69e7e89b5544b774f251d0a.tar.bz2
aports-4c21267fa2868876f69e7e89b5544b774f251d0a.tar.xz
testing/cherokee: removed from stable branch
-rw-r--r--testing/cherokee/APKBUILD38
-rw-r--r--testing/cherokee/cherokee.confd10
-rwxr-xr-xtesting/cherokee/cherokee.initd41
3 files changed, 0 insertions, 89 deletions
diff --git a/testing/cherokee/APKBUILD b/testing/cherokee/APKBUILD
deleted file mode 100644
index 47a7d43a..00000000
--- a/testing/cherokee/APKBUILD
+++ /dev/null
@@ -1,38 +0,0 @@
-# Contributor: Mika Havela <mika.havela@gmail.com>
-# Maintainer: Mika Havela <mika.havela@gmail.com>
-pkgname=cherokee
-pkgver=0.99.41
-pkgrel=0
-pkgdesc="A very fast, flexible and easy to configure Web Server"
-url="http://www.cherokee-project.com/"
-license="GPL2"
-depends="pcre rrdtool"
-makedepends="openssl-dev gettext-dev ffmpeg-dev"
-install=
-subpackages="$pkgname-dev $pkgname-doc"
-source="http://www.cherokee-project.com/download/0.99/${pkgver}/${pkgname}-${pkgver}.tar.gz
- cherokee.initd
- cherokee.confd
- "
-
-_builddir="$srcdir"/$pkgname-$pkgver
-build() {
- cd "$_builddir"
- ./configure --prefix=/usr \
- --localstatedir=/var \
- --sysconfdir=/etc \
- --with-wwwroot=/var/www
- make || return 1
-}
-
-package() {
- cd "$_builddir"
- make DESTDIR="$pkgdir" install
-
- install -m755 -D "$srcdir"/$pkgname.initd "$pkgdir"/etc/init.d/$pkgname
- install -m644 -D "$srcdir"/$pkgname.confd "$pkgdir"/etc/conf.d/$pkgname
-}
-
-md5sums="388affc0636aca802ec46cea4ebb8d08 cherokee-0.99.41.tar.gz
-4180dbb6701f928054079aa1e3bd5ebc cherokee.initd
-bd6a840f72c630ce1eaabe058097584f cherokee.confd"
diff --git a/testing/cherokee/cherokee.confd b/testing/cherokee/cherokee.confd
deleted file mode 100644
index 8f719df3..00000000
--- a/testing/cherokee/cherokee.confd
+++ /dev/null
@@ -1,10 +0,0 @@
-# Sample conf.d file for alpine linux
-
-#
-# Specify daemon $OPTS here.
-#
-
-OPTS="-d"
-DAEMON_USER="root"
-DAEMON_GROUP="root"
-
diff --git a/testing/cherokee/cherokee.initd b/testing/cherokee/cherokee.initd
deleted file mode 100755
index 6aed337b..00000000
--- a/testing/cherokee/cherokee.initd
+++ /dev/null
@@ -1,41 +0,0 @@
-#!/sbin/runscript
-
-# Cherokee init.d file for alpine linux.
-
-NAME=cherokee
-DAEMON=/usr/sbin/$NAME
-DAEMON_USER=${DAEMON_USER:-root}
-DAEMON_GROUP=${DAEMON_GROUP:-root}
-
-depend() {
- need net
-}
-
-start() {
- ebegin "Starting ${NAME}"
- start-stop-daemon --start --quiet \
- --pidfile /var/run/${NAME}.pid \
- --chuid ${DAEMON_USER}:${DAEMON_GROUP} \
- --exec ${DAEMON} -- ${OPTS}
- eend $?
-}
-
-stop() {
- ebegin "Stopping ${NAME}"
- start-stop-daemon --stop --quiet \
- --exec ${DAEMON} \
- --pidfile /var/run/${NAME}.pid
- eend $?
-}
-
-reload() {
- ebegin "Reloading ${NAME}"
- if ! service_started "${NAME}" ; then
- eend 1 "${NAME} is not started"
- return 1
- fi
- start-stop-daemon --stop --oknodo --signal HUP \
- --exec ${DAEMON} --pidfile /var/run/${NAME}.pid
- eend $?
-}
-