summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichael Mason <ms13sp@gmail.com>2009-03-18 12:50:59 +0000
committerMichael Mason <ms13sp@gmail.com>2009-03-18 12:50:59 +0000
commit829a8c02bd6f68d346831806f4d41a0e143cbb33 (patch)
treeaf6fd79d7b0edbda3d06f826adcd02c09550df54
parent4879cf45790e52c14e3191e49055cde05a473c38 (diff)
parent726860e8484051831ca52c28a922fbad5444d766 (diff)
downloadaports-829a8c02bd6f68d346831806f4d41a0e143cbb33.tar.bz2
aports-829a8c02bd6f68d346831806f4d41a0e143cbb33.tar.xz
Merge branch 'master' of git://dev.alpinelinux.org/aports
-rw-r--r--extra/aumix/APKBUILD38
-rw-r--r--extra/espeak/APKBUILD42
-rw-r--r--extra/espeak/espeak-1.40.02-uclibc++.patch21
-rw-r--r--extra/gperf/APKBUILD21
-rw-r--r--extra/mpg123/APKBUILD25
-rw-r--r--extra/subversion/APKBUILD8
-rw-r--r--extra/subversion/subversion.pre-install (renamed from extra/subversion/subversion.install)0
-rw-r--r--x11/xcb-utils/APKBUILD20
8 files changed, 171 insertions, 4 deletions
diff --git a/extra/aumix/APKBUILD b/extra/aumix/APKBUILD
new file mode 100644
index 00000000..034613b7
--- /dev/null
+++ b/extra/aumix/APKBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=aumix
+pkgver=2.8
+pkgrel=0
+pkgdesc="A color text mode sound mixer"
+url="http://www.jpj.net/~trevor/aumix.html"
+license="GPL"
+depends="uclibc ncurses ncurses-terminfo"
+makedepends="ncurses-dev"
+source="http://jpj.net/~trevor/aumix/aumix-$pkgver.tar.bz2
+ aumix-2.8-mute.patch
+ aumix-2.8-nohome.patch
+ aumix-2.8-save_load.patch
+ aumix.initd
+ "
+
+build() {
+ cd "$srcdir"/aumix-$pkgver
+ for i in ../*.patch; do
+ msg "Applying $i..."
+ patch -p1 < $i || return 1
+ done
+
+ ./configure --prefix=/usr \
+ --mandir=/usr/share/man \
+ --without-gtk1 \
+ --without-gtk \
+ --disable-nls
+
+ make || return 1
+ make DESTDIR="$pkgdir" install || return 1
+ install -Dm755 "$srcdir"/$pkgname.initd "$pkgdir"/etc/init.d/aumix
+}
+md5sums="dc3fc7209752207c23e7c94ab886b340 aumix-2.8.tar.bz2
+3611c0372870a0ad67630231fe576e32 aumix-2.8-mute.patch
+6c8d691beb495257d8309e58c127acd2 aumix-2.8-nohome.patch
+113377f0f69925467a5a5b633a78160c aumix-2.8-save_load.patch
+affaa735ad9b65a540842994caba18fd aumix.initd"
diff --git a/extra/espeak/APKBUILD b/extra/espeak/APKBUILD
new file mode 100644
index 00000000..bf005e00
--- /dev/null
+++ b/extra/espeak/APKBUILD
@@ -0,0 +1,42 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=espeak
+pkgver=1.40.02
+pkgrel=0
+pkgdesc="Speech synthesizer for English and other languages"
+url="http://espeak.sourceforge.net/"
+license="GPL-3"
+subpackages="$pkgname-dev"
+depends="uclibc uclibc++"
+makedepends="uclibc++-dev"
+source="http://downloads.sourceforge.net/$pkgname/$pkgname-$pkgver-source.zip
+ $pkgname-$pkgver-uclibc++.patch"
+
+build() {
+ local s="$srcdir"/$pkgname-$pkgver-source
+ cd "$s"
+ for i in ../*.patch; do
+ msg "Applying $i..."
+ patch -p1 < $i || return 1
+ done
+
+ export CXX=g++-uc
+
+ cd src
+ make CXXFLAGS="${CXXFLAGS}" AUDIO=none all || return 1
+
+ msg "Fixing byte order of phoneme data files"
+ cd "$s"/platforms/big_endian
+ make
+ ./espeak-phoneme-data "$s"/espeak-data
+ cp -f phondata phonindex phontab "$s"/espeak-data
+
+ cd "$s"/src
+ make DESTDIR="$pkgdir" AUDIO=none install || return 1
+
+ cd "$s"
+ install -d "$pkgdir"/usr/share/espeak-data
+ cp -r dictsource "$pkgdir"/usr/share/espeak-data
+}
+
+md5sums="708954b44c526e8174df8b88a6382738 espeak-1.40.02-source.zip
+c13bb95088c5777b4d3e5ea10ca37517 espeak-1.40.02-uclibc++.patch"
diff --git a/extra/espeak/espeak-1.40.02-uclibc++.patch b/extra/espeak/espeak-1.40.02-uclibc++.patch
new file mode 100644
index 00000000..68992205
--- /dev/null
+++ b/extra/espeak/espeak-1.40.02-uclibc++.patch
@@ -0,0 +1,21 @@
+--- espeak-1.40.02-source.orig/src/Makefile 2008-12-26 10:11:49 +0000
++++ espeak-1.40.02-source/src/Makefile 2008-12-26 10:27:48 +0000
+@@ -60,15 +60,15 @@
+
+ SRCS1=$(speak_SOURCES)
+ OBJS1=$(patsubst %.cpp,%.o,$(SRCS1))
+-LIBS1=-lstdc++ $(LIB_AUDIO) -lpthread $(EXTRA_LIBS)
++LIBS1=-lm $(LIB_AUDIO) -lpthread $(EXTRA_LIBS)
+
+ SRCS2=$(libespeak_SOURCES)
+ OBJS2=$(patsubst %.cpp,x_%.o,$(SRCS2))
+-LIBS2=-lstdc++ $(LIB_AUDIO) -lpthread
++LIBS2=-lm $(LIB_AUDIO) -lpthread
+
+ SRCS3 = espeak.cpp
+ OBJS3=$(patsubst %.cpp,%.o,$(SRCS3))
+-LIBS3=-lstdc++ -L . -lespeak
++LIBS3=-L . -lespeak -lpthread
+
+ CXXFLAGS=-O2
+
diff --git a/extra/gperf/APKBUILD b/extra/gperf/APKBUILD
new file mode 100644
index 00000000..5e0509d8
--- /dev/null
+++ b/extra/gperf/APKBUILD
@@ -0,0 +1,21 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=gperf
+pkgver=3.0.3
+pkgrel=0
+pkgdesc="Perfect hash function generator."
+url="http://www.gnu.org/software/gperf/"
+license="GPL"
+subpackages="$pkgname-doc"
+depends="uclibc libgcc uclibc++"
+makedepends="uclibc++-dev"
+source="ftp://ftp.gnu.org/gnu/$pkgname/$pkgname-$pkgver.tar.gz"
+
+build ()
+{
+ cd "$srcdir"/$pkgname-$pkgver
+ export CXX=g++-uc
+ ./configure --prefix=/usr
+ make || return 1
+ make DESTDIR="$pkgdir" install
+}
+md5sums="cc20e58975a38075440423c8fb85fd00 gperf-3.0.3.tar.gz"
diff --git a/extra/mpg123/APKBUILD b/extra/mpg123/APKBUILD
new file mode 100644
index 00000000..46e6668d
--- /dev/null
+++ b/extra/mpg123/APKBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=mpg123
+pkgver=1.6.4
+pkgrel=0
+pkgdesc="A console based real time MPEG Audio Player for Layer 1, 2 and 3"
+url="http://sourceforge.net/projects/mpg123"
+license="GPL2 LGPL2"
+subpackages="$pkgname-dev $pkgname-doc"
+depends="uclibc alsa-lib libltdl"
+makedepends="pkgconfig libtool alsa-lib-dev"
+source="http://downloads.sourceforge.net/sourceforge/$pkgname/$pkgname-$pkgver.tar.bz2"
+
+build() {
+ cd "$srcdir"/$pkgname-$pkgver
+ ./configure --prefix=/usr \
+ --disable-dependency-tracking \
+ --with-ipv6 \
+ --with-pic \
+ --with-optimization=0 \
+ --with-cpu=i386_fpu \
+ --with-audio="alsa oss" || return 1
+ make || return 1
+ make DESTDIR="$pkgdir" install || return 1
+}
+md5sums="a111bcb82628e602abd9a5860928e870 mpg123-1.6.4.tar.bz2"
diff --git a/extra/subversion/APKBUILD b/extra/subversion/APKBUILD
index 4cbcc527..f98719c4 100644
--- a/extra/subversion/APKBUILD
+++ b/extra/subversion/APKBUILD
@@ -1,6 +1,6 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=subversion
-pkgver=1.5.5
+pkgver=1.5.6
pkgrel=0
pkgdesc="Replacement for CVS, another versioning system (svn)"
url="http://subversion.tigris.org/"
@@ -8,7 +8,7 @@ license="apache bsd"
depends="apr apr-util expat neon openssl uclibc zlib"
makedepends="apr-dev apr-util-dev expat-dev neon-dev openssl-dev zlib-dev
e2fsprogs-dev libuuid"
-install="$pkgname.install"
+install="$pkgname.pre-install"
subpackages="$pkgname-dev $pkgname-doc"
source="http://svn.collab.net/tarballs/$pkgname-$pkgver.tar.gz
svnserve.confd
@@ -32,7 +32,7 @@ build() {
install -Dm755 "$srcdir"/svnserve.initd "$pkgdir"/etc/init.d/svnserve
install -Dm644 "$srcdir"/svnserve.confd "$pkgdir"/etc/conf.d/svnserve
}
-md5sums="532c7d49b3cd33d712289a5ef03b7749 subversion-1.5.5.tar.gz
+md5sums="ad81e54058e64b5d399d3eda5f8bfcd1 subversion-1.5.6.tar.gz
d084a7558053784886bc858b94fa9186 svnserve.confd
06cf9328f63a935654971052a2c3594a svnserve.initd
-517b0819f3544df9dbee1f90f4289f34 subversion.install"
+bfd0d890c07830f1a6010891dd25fa5c subversion.pre-install"
diff --git a/extra/subversion/subversion.install b/extra/subversion/subversion.pre-install
index b61563cc..b61563cc 100644
--- a/extra/subversion/subversion.install
+++ b/extra/subversion/subversion.pre-install
diff --git a/x11/xcb-utils/APKBUILD b/x11/xcb-utils/APKBUILD
new file mode 100644
index 00000000..22b454df
--- /dev/null
+++ b/x11/xcb-utils/APKBUILD
@@ -0,0 +1,20 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=xcb-util
+pkgver=0.3.3
+pkgrel=0
+pkgdesc="Utility libraries for XC Binding"
+url="http://xcb.freedesktop.org"
+license="GPL"
+subpackages="$pkgname-dev"
+depends="libxcb uclibc"
+makedepends="libxcb-dev gperf pkgconfig"
+source="http://xcb.freedesktop.org/dist/$pkgname-$pkgver.tar.bz2"
+
+depend_dev="libxcb-dev"
+build() {
+ cd "$srcdir"/$pkgname-$pkgver
+ ./configure --prefix=/usr --disable-static || return 1
+ make || return 1
+ make DESTDIR="$pkgdir" install || return 1
+}
+md5sums="b1b16c5c1fcf7a6facb346c262cd3513 xcb-util-0.3.3.tar.bz2"