summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2010-05-28 10:03:14 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2010-05-28 10:03:14 +0000
commit4a8dfc4f8927c4b3672a7051f94ecccdcd6c1ac9 (patch)
tree8c9617302b06bc6e3278360d54a0ce7e145ed556
parentcd53af38950f1f9147729f4d1d38618e47c01d10 (diff)
downloadaports-4a8dfc4f8927c4b3672a7051f94ecccdcd6c1ac9.tar.bz2
aports-4a8dfc4f8927c4b3672a7051f94ecccdcd6c1ac9.tar.xz
testing/geh: new aport
a simple commandline image viewer written in C/Gtk+ https://projects.pekdon.net/projects/geh
-rw-r--r--testing/geh/APKBUILD44
1 files changed, 44 insertions, 0 deletions
diff --git a/testing/geh/APKBUILD b/testing/geh/APKBUILD
new file mode 100644
index 00000000..4f768bda
--- /dev/null
+++ b/testing/geh/APKBUILD
@@ -0,0 +1,44 @@
+# Contributor:
+# Maintainer:
+pkgname=geh
+pkgver=0.2.0
+pkgrel=0
+pkgdesc="a simple commandline image viewer written in C/Gtk+"
+url="https://projects.pekdon.net/projects/geh"
+license="GPL"
+depends=
+makedepends="gtk+-dev intltool"
+install=
+subpackages="$pkgname-doc"
+source="http://projects.pekdon.net/projects/geh/files/geh-$pkgver.tar.gz"
+
+# append extra dependencies to -dev subpackage
+# remove if not used.
+# depends_dev="somepackage-dev"
+
+_builddir="$srcdir"/$pkgname-$pkgver
+
+prepare() {
+ cd "$_builddir"
+ # apply patches here
+}
+
+build() {
+ cd "$_builddir"
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install
+
+ # remove the 2 lines below (and this) if there is no init.d script
+ # install -m755 -D "$srcdir"/$pkgname.initd "$pkgdir"/etc/init.d/$pkgname
+ # install -m644 -D "$srcdir"/$pkgname.confd "$pkgdir"/etc/conf.d/$pkgname
+}
+
+md5sums="2349b774e7f0c288061fcfc8c296f20d geh-0.2.0.tar.gz"