summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2009-05-17 11:54:15 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2009-05-17 11:54:15 +0000
commitbceef1f335c5c389a4be19b08f799bc4367c303e (patch)
tree13ccdf304928c47b8811ac24e98fc80bf8689d0b
parent28e80cae09ef6795534887360cded93dcffe026a (diff)
downloadaports-bceef1f335c5c389a4be19b08f799bc4367c303e.tar.bz2
aports-bceef1f335c5c389a4be19b08f799bc4367c303e.tar.xz
core/uclibc: fix ppoll
fixes broken ppoll that made udev go nuts
-rw-r--r--core/uclibc/APKBUILD4
-rw-r--r--core/uclibc/ppoll.patch59
2 files changed, 62 insertions, 1 deletions
diff --git a/core/uclibc/APKBUILD b/core/uclibc/APKBUILD
index 836dff1b..67baa282 100644
--- a/core/uclibc/APKBUILD
+++ b/core/uclibc/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=uclibc
pkgver=0.9.30.1
-pkgrel=5
+pkgrel=6
pkgdesc="C library for developing embedded Linux systems"
url=http://uclibc.org
license="LGPL-2"
@@ -14,6 +14,7 @@ source="http://uclibc.org/downloads/$_mynamever.tar.bz2
$pkgname-0.9.30.1-resolv.patch
uclibc-0.9.30.1-pthread_getattr_np.patch
0001-ldd-segfault-fix.patch
+ ppoll.patch
uclibcconfig
"
@@ -48,4 +49,5 @@ md5sums="1a4b84e5536ad8170563ffa88c34679c uClibc-0.9.30.1.tar.bz2
ea91460617601b6e084ead66bc3948f5 uclibc-0.9.30.1-resolv.patch
cf80c0d44a41e02f389be427ee615d61 uclibc-0.9.30.1-pthread_getattr_np.patch
4079b20c763727863bc53408e4988434 0001-ldd-segfault-fix.patch
+60738298e377295d359768a09adac0bb ppoll.patch
a4512d5594f1b450ffbf2ff9eda6263b uclibcconfig"
diff --git a/core/uclibc/ppoll.patch b/core/uclibc/ppoll.patch
new file mode 100644
index 00000000..e73733e2
--- /dev/null
+++ b/core/uclibc/ppoll.patch
@@ -0,0 +1,59 @@
+commit f82635e74a7e174f71f955eaa4f5dc788e596cc0
+Author: Denis Vlasenko <vda.linux@googlemail.com>
+Date: Wed Jan 28 23:42:01 2009 +0000
+
+ fix ppoll. we forgot to pass 5th parameter to the syscall
+
+diff --git a/libc/sysdeps/linux/common/ppoll.c b/libc/sysdeps/linux/common/ppoll.c
+index edcb1dc..d550ae8 100644
+--- a/libc/sysdeps/linux/common/ppoll.c
++++ b/libc/sysdeps/linux/common/ppoll.c
+@@ -17,6 +17,7 @@
+ Software Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA
+ 02111-1307 USA. */
+
++#include <signal.h>
+ #include <sys/syscall.h>
+ #include <sys/poll.h>
+
+@@ -26,24 +27,26 @@
+
+ # define __NR___libc_ppoll __NR_ppoll
+ static __always_inline
+-_syscall4(int, __libc_ppoll, struct pollfd *, fds,
+- nfds_t, nfds, const struct timespec *, timeout,
+- const __sigset_t *, sigmask)
++_syscall5(int, __libc_ppoll,
++ struct pollfd *, fds,
++ nfds_t, nfds,
++ const struct timespec *, timeout,
++ const __sigset_t *, sigmask,
++ size_t, sigsetsize)
+
+ int
+-ppoll (struct pollfd *fds, nfds_t nfds, const struct timespec *timeout,
++ppoll(struct pollfd *fds, nfds_t nfds, const struct timespec *timeout,
+ const __sigset_t *sigmask)
+ {
+- /* The Linux kernel can in some situations update the timeout value.
+- We do not want that so use a local variable. */
+- struct timespec tval;
+- if (timeout != NULL)
+- {
+- tval = *timeout;
+- timeout = &tval;
+- }
+-
+- return __libc_ppoll(fds, nfds, timeout, sigmask);
++ /* The Linux kernel can in some situations update the timeout value.
++ We do not want that so use a local variable. */
++ struct timespec tval;
++ if (timeout != NULL) {
++ tval = *timeout;
++ timeout = &tval;
++ }
++
++ return __libc_ppoll(fds, nfds, timeout, sigmask, _NSIG / 8);
+ }
+ libc_hidden_def(ppoll)
+