summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2009-06-04 18:18:51 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2009-06-04 18:18:51 +0000
commit0b1389177fa783bc1cb028ded8f0aa64d32d6370 (patch)
tree1fbf35ac595b1067a9b65d6f0b1e7fb5bb4dbb3f
parent25d7d59ce4e13362edac1517344dad895be10ac4 (diff)
downloadaports-0b1389177fa783bc1cb028ded8f0aa64d32d6370.tar.bz2
aports-0b1389177fa783bc1cb028ded8f0aa64d32d6370.tar.xz
core/abuild: upgrade to 1.15.2
-rw-r--r--core/abuild/APKBUILD9
-rw-r--r--core/abuild/buildrepo.patch50
2 files changed, 3 insertions, 56 deletions
diff --git a/core/abuild/APKBUILD b/core/abuild/APKBUILD
index 059fb297..0c8cf770 100644
--- a/core/abuild/APKBUILD
+++ b/core/abuild/APKBUILD
@@ -1,22 +1,19 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgdesc="Script to build Alpine Packages"
pkgname=abuild
-pkgver=1.15.1
-pkgrel=1
+pkgver=1.15.2
+pkgrel=0
url=http://git.alpinelinux.org/cgit/abuild/
source="http://git.alpinelinux.org/cgit/abuild/snapshot/abuild-$pkgver.tar.bz2
- buildrepo.patch
"
depends="fakeroot file sudo"
license=GPL-2
build() {
cd "$srcdir/$pkgname-$pkgver"
- patch -p1 < ../buildrepo.patch || return 1
make install DESTDIR="$pkgdir"
install -m 644 abuild.conf "$pkgdir"/etc/abuild.conf
}
-md5sums="ad7db0b6112bed7418a8aef97f20aed5 abuild-1.15.1.tar.bz2
-465280f43fd69fa0949bc8f1ce67ab39 buildrepo.patch"
+md5sums="dd03e8e79b3b4fa9bc17a9acc1b4e520 abuild-1.15.2.tar.bz2"
diff --git a/core/abuild/buildrepo.patch b/core/abuild/buildrepo.patch
deleted file mode 100644
index 4c647d87..00000000
--- a/core/abuild/buildrepo.patch
+++ /dev/null
@@ -1,50 +0,0 @@
-commit 896c436e140a4888c59135c7a2238e2ec4861632
-Author: Natanael Copa <ncopa@alpinelinux.org>
-Date: Thu Jun 4 12:22:48 2009 +0000
-
- buildrepo: check if all files exist before try copy anything
-
- seems like copy removes destination if source does not exist so
- we ended up with a buildrepo that removed all packages
-
-diff --git a/buildrepo.in b/buildrepo.in
-index 5b4133d..2be50e1 100755
---- a/buildrepo.in
-+++ b/buildrepo.in
-@@ -28,6 +28,14 @@ listpackages() {
- done
- }
-
-+all_exist() {
-+ while [ $# -gt 0 ]; do
-+ [ -e "$1" ] || return 1
-+ shift 1
-+ done
-+ return 0
-+}
-+
- build() {
- local repo="$1" i indexupdate needbuild
-
-@@ -47,15 +55,18 @@ build() {
- continue
- fi
-
-+ indexupdate="$indexupdate $i"
-+
- # try link or copy the files if they are in the ports dir
- pkgs=$(abuild listpkg)
-- if cp -p -l $pkgs "$repodir/$repo"/ 2>/dev/null \
-- || cp -p $pkgs "$repodir/$repo"/ 2>/dev/null; then
-+ if all_exist $pkgs; then
- echo ">>> Copying " $pkgs
-+ cp -p -l $pkgs "$repodir/$repo"/ 2>/dev/null \
-+ || cp -p $pkgs "$repodir/$repo"/ \
-+ || needbuild="$needbuild $i"
- else
- needbuild="$needbuild $i"
- fi
-- indexupdate="$indexupdate $i"
- done
-
- # build the postponed packages if any