summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichael Mason <ms13sp@gmail.com>2009-06-04 22:04:59 +0000
committerMichael Mason <ms13sp@gmail.com>2009-06-04 22:04:59 +0000
commitc9c66a92816ed8efef5e89b2d99bb0ba60c71a86 (patch)
tree1cd0c1c970a294e086f8fd2ecf8c5c859fa552fe
parentbe106f356ad5e840fdb6abacf54486d774932cf1 (diff)
parent8d4894ea67fa81692ff9db98b7f586b7e4b0208b (diff)
downloadaports-c9c66a92816ed8efef5e89b2d99bb0ba60c71a86.tar.bz2
aports-c9c66a92816ed8efef5e89b2d99bb0ba60c71a86.tar.xz
Merge branch 'master' of git://git.alpinelinux.org/aports
-rw-r--r--core/abuild/APKBUILD9
-rw-r--r--core/abuild/buildrepo.patch50
-rw-r--r--core/e2fsprogs/APKBUILD8
3 files changed, 7 insertions, 60 deletions
diff --git a/core/abuild/APKBUILD b/core/abuild/APKBUILD
index 059fb297..c68050df 100644
--- a/core/abuild/APKBUILD
+++ b/core/abuild/APKBUILD
@@ -1,22 +1,19 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgdesc="Script to build Alpine Packages"
pkgname=abuild
-pkgver=1.15.1
+pkgver=1.15.2
pkgrel=1
url=http://git.alpinelinux.org/cgit/abuild/
source="http://git.alpinelinux.org/cgit/abuild/snapshot/abuild-$pkgver.tar.bz2
- buildrepo.patch
"
-depends="fakeroot file sudo"
+depends="fakeroot file sudo pax-utils"
license=GPL-2
build() {
cd "$srcdir/$pkgname-$pkgver"
- patch -p1 < ../buildrepo.patch || return 1
make install DESTDIR="$pkgdir"
install -m 644 abuild.conf "$pkgdir"/etc/abuild.conf
}
-md5sums="ad7db0b6112bed7418a8aef97f20aed5 abuild-1.15.1.tar.bz2
-465280f43fd69fa0949bc8f1ce67ab39 buildrepo.patch"
+md5sums="dd03e8e79b3b4fa9bc17a9acc1b4e520 abuild-1.15.2.tar.bz2"
diff --git a/core/abuild/buildrepo.patch b/core/abuild/buildrepo.patch
deleted file mode 100644
index 4c647d87..00000000
--- a/core/abuild/buildrepo.patch
+++ /dev/null
@@ -1,50 +0,0 @@
-commit 896c436e140a4888c59135c7a2238e2ec4861632
-Author: Natanael Copa <ncopa@alpinelinux.org>
-Date: Thu Jun 4 12:22:48 2009 +0000
-
- buildrepo: check if all files exist before try copy anything
-
- seems like copy removes destination if source does not exist so
- we ended up with a buildrepo that removed all packages
-
-diff --git a/buildrepo.in b/buildrepo.in
-index 5b4133d..2be50e1 100755
---- a/buildrepo.in
-+++ b/buildrepo.in
-@@ -28,6 +28,14 @@ listpackages() {
- done
- }
-
-+all_exist() {
-+ while [ $# -gt 0 ]; do
-+ [ -e "$1" ] || return 1
-+ shift 1
-+ done
-+ return 0
-+}
-+
- build() {
- local repo="$1" i indexupdate needbuild
-
-@@ -47,15 +55,18 @@ build() {
- continue
- fi
-
-+ indexupdate="$indexupdate $i"
-+
- # try link or copy the files if they are in the ports dir
- pkgs=$(abuild listpkg)
-- if cp -p -l $pkgs "$repodir/$repo"/ 2>/dev/null \
-- || cp -p $pkgs "$repodir/$repo"/ 2>/dev/null; then
-+ if all_exist $pkgs; then
- echo ">>> Copying " $pkgs
-+ cp -p -l $pkgs "$repodir/$repo"/ 2>/dev/null \
-+ || cp -p $pkgs "$repodir/$repo"/ \
-+ || needbuild="$needbuild $i"
- else
- needbuild="$needbuild $i"
- fi
-- indexupdate="$indexupdate $i"
- done
-
- # build the postponed packages if any
diff --git a/core/e2fsprogs/APKBUILD b/core/e2fsprogs/APKBUILD
index 0996aeca..466f1a0a 100644
--- a/core/e2fsprogs/APKBUILD
+++ b/core/e2fsprogs/APKBUILD
@@ -5,7 +5,7 @@ pkgrel=0
pkgdesc="Standard Ext2/3/4 filesystem utilities"
url="http://e2fsprogs.sourceforge.net"
license="GPL LGPL MIT"
-depends="uclibc libuuid libcom_err libblkid"
+depends=
subpackages="$pkgname-dev $pkgname-doc libuuid libcom_err libblkid"
source="http://downloads.sourceforge.net/sourceforge/e2fsprogs/e2fsprogs-$pkgver.tar.gz"
@@ -23,19 +23,19 @@ build () {
}
libuuid() {
- depends="uclibc"
+ depends=
mkdir -p "$subpkgdir"/lib
mv "$pkgdir"/lib/libuuid* "$subpkgdir"/lib/
}
libcom_err() {
- depends="uclibc"
+ depends=
mkdir -p "$subpkgdir"/lib
mv "$pkgdir"/lib/libcom_err* "$subpkgdir"/lib/
}
libblkid() {
- depends="uclibc libuuid"
+ depends=
mkdir -p "$subpkgdir"/lib
mv "$pkgdir"/lib/libblkid* "$subpkgdir"/lib/
}