summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2009-06-13 21:44:30 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2009-06-13 21:44:30 +0000
commit116f3720e87a3bd9a5d2596c7d5dddb5aa889465 (patch)
tree1cb550fda4030c7e68acf9215f16352a666613eb
parent8131b1b9350bac3c016eafb4aca500cb20753398 (diff)
downloadaports-116f3720e87a3bd9a5d2596c7d5dddb5aa889465.tar.bz2
aports-116f3720e87a3bd9a5d2596c7d5dddb5aa889465.tar.xz
x11/orage: new aport
A simple calendar application with reminders for Xfce http://www.xfce.org/projects/orage/
-rw-r--r--x11/orage/APKBUILD30
l---------x11/orage/orage.post-deinstall1
-rw-r--r--x11/orage/orage.post-install4
3 files changed, 35 insertions, 0 deletions
diff --git a/x11/orage/APKBUILD b/x11/orage/APKBUILD
new file mode 100644
index 00000000..b310c80c
--- /dev/null
+++ b/x11/orage/APKBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=orage
+pkgver=4.6.1
+pkgrel=0
+pkgdesc="A simple calendar application with reminders for Xfce"
+url="http://www.xfce.org/projects/orage/"
+license="GPL-2"
+subpackages="$pkgname-doc"
+depends="hicolor-icon-theme"
+makedepends="pkgconfig xfce4-panel-dev libnotify-dev intltool gettext-dev
+ libiconv-dev libsm-dev expat-dev e2fsprogs-dev"
+install="orage.post-install orage.post-deinstall"
+source="http://www.xfce.org/archive/xfce-$pkgver/src/$pkgname-$pkgver.tar.bz2
+ $install"
+
+build ()
+{
+ cd "$srcdir"/$pkgname-$pkgver
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --libexecdir=/usr/lib \
+ --localstatedir=/var \
+ --disable-static || return 1
+ make || return 1
+ make DESTDIR="$pkgdir" install || return 1
+}
+
+md5sums="24fa43dd86ec5af5a4766620fd972cf2 orage-4.6.1.tar.bz2
+db51db79681eadc47be4932355a77c25 orage.post-install
+db51db79681eadc47be4932355a77c25 orage.post-deinstall"
diff --git a/x11/orage/orage.post-deinstall b/x11/orage/orage.post-deinstall
new file mode 120000
index 00000000..eef6db26
--- /dev/null
+++ b/x11/orage/orage.post-deinstall
@@ -0,0 +1 @@
+orage.post-install \ No newline at end of file
diff --git a/x11/orage/orage.post-install b/x11/orage/orage.post-install
new file mode 100644
index 00000000..c523d78d
--- /dev/null
+++ b/x11/orage/orage.post-install
@@ -0,0 +1,4 @@
+#!/bin/sh
+
+gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
+