summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2009-06-14 13:12:03 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2009-06-14 13:12:03 +0000
commita0a01da73324b15a55ec196bed363dbe6e4fe714 (patch)
treece69b77d9eafa921cff58631a5f452064d163aa7
parentac572ecc42a4536dc2dec5ac75af23b4e608cc04 (diff)
downloadaports-a0a01da73324b15a55ec196bed363dbe6e4fe714.tar.bz2
aports-a0a01da73324b15a55ec196bed363dbe6e4fe714.tar.xz
x11/icon-naming-utils: new aport
Maps the new names of icons for Tango to the legacy names used by the GNOME and KDE desktops. http://tango.freedesktop.org/
-rw-r--r--x11/icon-naming-utils/APKBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/x11/icon-naming-utils/APKBUILD b/x11/icon-naming-utils/APKBUILD
new file mode 100644
index 00000000..b5164dd0
--- /dev/null
+++ b/x11/icon-naming-utils/APKBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=icon-naming-utils
+pkgver=0.8.90
+pkgrel=0
+pkgdesc="Maps the new names of icons for Tango to the legacy names used by the GNOME and KDE desktops."
+url="http://tango.freedesktop.org/"
+license="GPL"
+depends="perl-xml-simple"
+makedepends=""
+source="http://tango.freedesktop.org/releases/$pkgname-$pkgver.tar.bz2"
+
+build ()
+{
+ cd "$srcdir"/$pkgname-$pkgver
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --libexecdir=/usr/lib/icon-naming-utils \
+ --localstatedir=/var || return 1
+ make || return 1
+ make DESTDIR="$pkgdir" install || return 1
+ mv "$pkgdir"/usr/share/pkgconfig "$pkgdir"/usr/lib/pkgconfig || return 1
+ chmod +x "$pkgdir"/usr/lib/icon-naming-utils/icon-name-mapping
+}
+
+md5sums="dd8108b56130b9eedc4042df634efa66 icon-naming-utils-0.8.90.tar.bz2"