summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2009-06-14 10:14:52 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2009-06-14 10:14:52 +0000
commitb71587bde56479be4435dac08486a85737d0defa (patch)
tree672eed1bded6534357e84c7a3d8955548c645a7e
parent7cd98822ddab17a248387acce4695963cb7a2b6e (diff)
downloadaports-b71587bde56479be4435dac08486a85737d0defa.tar.bz2
aports-b71587bde56479be4435dac08486a85737d0defa.tar.xz
extra/glib: upgrade to 2.20.3
In the usr/lib/pkgconfig/*.pc file there are linker opts that needs libiconv and gettext libs so we add those as dependencies for the glib-dev package.
-rw-r--r--extra/glib/APKBUILD11
1 files changed, 6 insertions, 5 deletions
diff --git a/extra/glib/APKBUILD b/extra/glib/APKBUILD
index caa05e01..f67d7801 100644
--- a/extra/glib/APKBUILD
+++ b/extra/glib/APKBUILD
@@ -1,20 +1,22 @@
# Maintainer: Carlo Landmeter <clandmeter at gmail.com>
pkgname=glib
-pkgver=2.20.0
+pkgver=2.20.3
pkgrel=0
pkgdesc="Common C routines used by Gtk+ and other libs"
url="http://www.gtk.org"
license='GPL'
-depends="gettext libiconv"
+depends=
makedepends="gettext-dev libiconv-dev pkgconfig"
source="http://ftp.gnome.org/pub/gnome/sources/glib/${pkgver%.*}/glib-$pkgver.tar.bz2"
subpackages="$pkgname-doc $pkgname-dev"
+depends_dev="perl gettext libiconv"
+
build() {
cd "$srcdir/$pkgname-$pkgver"
./configure --prefix=/usr \
- --mandir=/usr/share/man
+ --mandir=/usr/share/man
make || return 1
make DESTDIR="$pkgdir/" install
}
@@ -22,8 +24,7 @@ build() {
# move the stuff in /usr/bin to the glib-dev package
dev() {
default_dev
- depends="$depends perl"
mv "$pkgdir"/usr/bin "$subpkgdir"/usr/
}
-md5sums="05188e560dbd8bddd568e24ce10dd003 glib-2.20.0.tar.bz2"
+md5sums="1173688c58b4b62809c83bb07a2cf71a glib-2.20.3.tar.bz2"