summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2009-06-12 20:39:16 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2009-06-12 20:39:16 +0000
commitd00a64e0be6315e5c81262bea22b3ed43b35958e (patch)
treea2f8a8f762b5830181ec6b82af624a7fcdee55bd
parent203998a99ac029bc10cf1d99872924bcef79d334 (diff)
downloadaports-d00a64e0be6315e5c81262bea22b3ed43b35958e.tar.bz2
aports-d00a64e0be6315e5c81262bea22b3ed43b35958e.tar.xz
core/mkinitfs: upgrade to 1.6
-rw-r--r--core/mkinitfs/APKBUILD11
-rw-r--r--core/mkinitfs/init.patch39
2 files changed, 4 insertions, 46 deletions
diff --git a/core/mkinitfs/APKBUILD b/core/mkinitfs/APKBUILD
index bc79fc14..72215705 100644
--- a/core/mkinitfs/APKBUILD
+++ b/core/mkinitfs/APKBUILD
@@ -1,13 +1,11 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=mkinitfs
-pkgver=1.5
-pkgrel=1
+pkgver=1.6
+pkgrel=0
pkgdesc="Tool to generate initramfs images for Alpine"
url=http://git.alpinelinux.org/cgit/mkinitfs
depends="busybox"
-source="http://git.alpinelinux.org/cgit/$pkgname/snapshot/$pkgname-$pkgver.tar.bz2
- init.patch
- "
+source="http://git.alpinelinux.org/cgit/$pkgname/snapshot/$pkgname-$pkgver.tar.bz2"
license="GPL-2"
build() {
@@ -16,5 +14,4 @@ build() {
make
make install DESTDIR="$pkgdir" || return 1
}
-md5sums="0a7eefb454fc96763983048ee60a1bcd mkinitfs-1.5.tar.bz2
-deb3fa8e83c877e72e6b3b420cef3864 init.patch"
+md5sums="7e0c22452f2a43854ef3cb86df2e17fa mkinitfs-1.6.tar.bz2"
diff --git a/core/mkinitfs/init.patch b/core/mkinitfs/init.patch
deleted file mode 100644
index 6f2c367e..00000000
--- a/core/mkinitfs/init.patch
+++ /dev/null
@@ -1,39 +0,0 @@
-commit db606b4b4861076524232f52002411dc900a03ad
-Author: Natanael Copa <ncopa@alpinelinux.org>
-Date: Thu Jun 4 14:56:28 2009 +0000
-
- init: unpack uclibc when dealing with encrypted apkovls
-
- openssl needs libdl which is not there by default.
-
-diff --git a/initramfs-init.in b/initramfs-init.in
-index f8827a0..ae82e8a 100755
---- a/initramfs-init.in
-+++ b/initramfs-init.in
-@@ -66,6 +66,14 @@ retry_mount() {
- return 1
- }
-
-+unpack_apk() {
-+ local i
-+ for i in $ALPINE_MNT/*/*/$1-[0-9]*.apk $ALPINE_MNT/*/$1-[0-9]*.apk; do
-+ [ -f "$i" ] && tar --numeric-owner -C / -zxf $i && return 0
-+ done
-+ return 1
-+}
-+
- unpack_apkovl() {
- local ovl="$1"
- local dest="$2"
-@@ -76,9 +84,8 @@ unpack_apkovl() {
- return $?
- fi
-
-- for i in $ALPINE_MNT/*/*/openssl-[0-9]*.apk $ALPINE_MNT/*/openssl-[0-9]*.apk; do
-- [ -f "$i" ] && tar --numeric-owner -C / -zxf $i && break
-- done
-+ unpack_apk uclibc
-+ unpack_apk openssl
-
- if ! openssl list-cipher-commands | grep "^$suffix$" > /dev/null; then
- errstr="Cipher $suffix is not supported"