summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2009-06-15 11:40:26 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2009-06-15 11:40:26 +0000
commit6ef21708d4d33c9c04b12fc7a733564ac5079903 (patch)
tree505199fa841fd26f4dd16bebc8b72c740430de77
parent1db6e899072d31a2704533903cfe8f6fab1c98ec (diff)
downloadaports-6ef21708d4d33c9c04b12fc7a733564ac5079903.tar.bz2
aports-6ef21708d4d33c9c04b12fc7a733564ac5079903.tar.xz
core/busybox: use ash fix from upstream
from here: http://busybox.net/downloads/fixes-1.14.1/
-rw-r--r--core/busybox/APKBUILD6
-rw-r--r--core/busybox/ash.patch29
-rw-r--r--core/busybox/busybox-1.14.1-ash.patch13
3 files changed, 16 insertions, 32 deletions
diff --git a/core/busybox/APKBUILD b/core/busybox/APKBUILD
index 688b0028..e086c727 100644
--- a/core/busybox/APKBUILD
+++ b/core/busybox/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=busybox
pkgver=1.14.1
-pkgrel=1
+pkgrel=2
pkgdesc="Size optimized toolbox of many common UNIX utilities"
url=http://busybox.net
license=GPL-2
@@ -14,8 +14,8 @@ source="http://busybox.net/downloads/$pkgname-$pkgver.tar.bz2
busybox-1.14.1-httpd.patch
busybox-1.14.1-modprobe.patch
busybox-1.14.1-telnetd.patch
+ busybox-1.14.1-ash.patch
bb-tar-numeric-owner.patch
- ash.patch
$install
busyboxconfig"
@@ -52,8 +52,8 @@ b49e33a98d7be2a52d772f3600c4aa78 busybox-1.14.1-ftpd.patch
9bdb6b91d7dd21253b3725c84e21347e busybox-1.14.1-httpd.patch
11877bde19afe1f6e1f55d9b5c9ee900 busybox-1.14.1-modprobe.patch
9020600467cdb1a1df7df41a1ba0c6e9 busybox-1.14.1-telnetd.patch
+fa809c927ac3793452fdf521c84e5803 busybox-1.14.1-ash.patch
0b5b2d7db201f90cd08f4a3164ee29a1 bb-tar-numeric-owner.patch
-fa4e7c44c423a3a42d23836d65f6e416 ash.patch
56b78c358797cd15fb64719a48939267 busybox.post-install
56b78c358797cd15fb64719a48939267 busybox.post-upgrade
6d9cd13b546d9c6063d36c0d3d963887 busyboxconfig"
diff --git a/core/busybox/ash.patch b/core/busybox/ash.patch
deleted file mode 100644
index 9c78c10f..00000000
--- a/core/busybox/ash.patch
+++ /dev/null
@@ -1,29 +0,0 @@
-commit daeeceff057dd3317f1e69aebde01dd9d489d18a
-Author: Natanael Copa <natanael.copa@gmail.com>
-Date: Fri Jun 12 17:11:51 2009 +0200
-
- Revert "ash: make dot command search current directory first, as bash does."
-
- This reverts commit 8ad78e1ec7b2e873953f9f476fb63b5893526c39.
-
-diff --git a/shell/ash.c b/shell/ash.c
-index 3452351..b62c2cd 100644
---- a/shell/ash.c
-+++ b/shell/ash.c
-@@ -11904,16 +11904,7 @@ find_dot_file(char *name)
- if (strchr(name, '/'))
- return name;
-
-- /* IIRC standards do not say whether . is to be searched.
-- * And it is even smaller this way, making it unconditional for now:
-- */
-- if (1) { /* ENABLE_ASH_BASH_COMPAT */
-- fullname = name;
-- goto try_cur_dir;
-- }
--
- while ((fullname = padvance(&path, name)) != NULL) {
-- try_cur_dir:
- if ((stat(fullname, &statb) == 0) && S_ISREG(statb.st_mode)) {
- /*
- * Don't bother freeing here, since it will
diff --git a/core/busybox/busybox-1.14.1-ash.patch b/core/busybox/busybox-1.14.1-ash.patch
new file mode 100644
index 00000000..eee05423
--- /dev/null
+++ b/core/busybox/busybox-1.14.1-ash.patch
@@ -0,0 +1,13 @@
+diff -urpN busybox-1.14.1/shell/ash.c busybox-1.14.1-ash/shell/ash.c
+--- busybox-1.14.1/shell/ash.c 2009-05-27 18:00:23.000000000 +0200
++++ busybox-1.14.1-ash/shell/ash.c 2009-06-14 19:44:24.000000000 +0200
+@@ -11909,7 +11909,8 @@ find_dot_file(char *name)
+ */
+ return fullname;
+ }
+- stunalloc(fullname);
++ if (fullname != name)
++ stunalloc(fullname);
+ }
+
+ /* not found in the PATH */