summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2009-06-18 06:44:53 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2009-06-18 06:44:53 +0000
commitb1efc5d9c2cd71c1db00d5849b283c05b0a1fb2e (patch)
tree01ae49a6f10c43f007c1891c704fb019e50030b4
parent1ceb14def2f0790c678bd101e9914c9bd8b0a014 (diff)
downloadaports-b1efc5d9c2cd71c1db00d5849b283c05b0a1fb2e.tar.bz2
aports-b1efc5d9c2cd71c1db00d5849b283c05b0a1fb2e.tar.xz
testing/hylafax: fix compilation when CC=ccache. fix depends
-rw-r--r--testing/hylafax/APKBUILD5
1 files changed, 3 insertions, 2 deletions
diff --git a/testing/hylafax/APKBUILD b/testing/hylafax/APKBUILD
index b318497e..42450d46 100644
--- a/testing/hylafax/APKBUILD
+++ b/testing/hylafax/APKBUILD
@@ -7,7 +7,7 @@ pkgdesc="Sends and receives faxes"
url="http://www.hylafax.org/"
license="custom"
#depends on gcc for libgcc_s.so, it's scripts are hardcoded to bash
-depends="uclibc uclibc++ zlib tiff ghostscript bash gcc"
+depends="ghostscript bash"
makedepends="zlib-dev tiff-dev uclibc++-dev"
install="hylafax.post-install"
subpackages="$pkgname-doc"
@@ -22,7 +22,8 @@ build() {
sed -i -e 's:"iostream.h":<iostream>\n using namespace std;:g' \
configure
-
+ # the configure script does not handle ccache or distcc
+ export CC=gcc
./configure --nointeractive --disable-pam \
--with-CXX=/usr/bin/g++-uc \
--with-DIR_BIN=/usr/bin \