summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2009-06-17 14:36:59 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2009-06-17 14:36:59 +0000
commite2f5aa4697bac9fecbf418cdd7857b20ee03a249 (patch)
tree944dcab4d05603f5b014aaa42ca0728f5b2fc4a6
parentf8f2344cfb8055d8b0b92fd494e334a0757258f2 (diff)
downloadaports-e2f5aa4697bac9fecbf418cdd7857b20ee03a249.tar.bz2
aports-e2f5aa4697bac9fecbf418cdd7857b20ee03a249.tar.xz
extra/fetchmail: set default poll period to 300 seconds
-rw-r--r--extra/fetchmail/APKBUILD6
-rwxr-xr-xextra/fetchmail/fetchmail.initd2
2 files changed, 4 insertions, 4 deletions
diff --git a/extra/fetchmail/APKBUILD b/extra/fetchmail/APKBUILD
index bef00014..09255663 100644
--- a/extra/fetchmail/APKBUILD
+++ b/extra/fetchmail/APKBUILD
@@ -2,11 +2,11 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=fetchmail
pkgver=6.3.9
-pkgrel=2
+pkgrel=3
pkgdesc="A remote-mail retrieval and forwarding utility"
url="http://fetchmail.berlios.de/"
license="GPL"
-depends="openssl uclibc"
+depends=
makedepends="openssl-dev python"
install="fetchmail.pre-install fetchmail.post-install"
subpackages="$pkgname-doc fetchmailconf"
@@ -41,4 +41,4 @@ fetchmailconf() {
md5sums="72c20ad2b9629f1a109668b05a84d823 fetchmail-6.3.9.tar.bz2
5a2fc8e8b3115fe2b9bf23503fb8f0a4 fetchmail.pre-install
4b451d102e92926b6b6c1774f4260310 fetchmail.post-install
-9a64c2b77d1a03a1eb8648a32d46b2c5 fetchmail.initd"
+22e9ac1d8385db05da15e01fd5c831e4 fetchmail.initd"
diff --git a/extra/fetchmail/fetchmail.initd b/extra/fetchmail/fetchmail.initd
index 4646fa4c..a1ed1ec8 100755
--- a/extra/fetchmail/fetchmail.initd
+++ b/extra/fetchmail/fetchmail.initd
@@ -20,7 +20,7 @@ start() {
ebegin "Starting fetchmail"
start-stop-daemon --start --quiet \
--chuid fetchmail --exec /usr/bin/fetchmail \
- -- -d ${polling_period} -f /etc/fetchmailrc \
+ -- -d ${polling_period:-300} -f /etc/fetchmailrc \
--pidfile ${pidfile} -i /var/lib/fetchmail/.fetchids
eend ${?}
}