summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2009-04-10 14:10:57 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2009-04-10 14:10:57 +0000
commit2a42d9d6eea91f6cb7458b1620d784dd83cdc188 (patch)
treecd0a73538d8333152e706101327a3d48bec59fcd
parent8f65ab9a12b89e9a504c136cca17d03771aca346 (diff)
downloadaports-2a42d9d6eea91f6cb7458b1620d784dd83cdc188.tar.bz2
aports-2a42d9d6eea91f6cb7458b1620d784dd83cdc188.tar.xz
extra/v86d: new aport
userspace helper for uvesafb that runs x86 code in an emulated environment http://dev.gentoo.org/~spock/projects/uvesafb/
-rw-r--r--extra/v86d/APKBUILD20
-rw-r--r--extra/v86d/modprobe.uvesafb10
2 files changed, 30 insertions, 0 deletions
diff --git a/extra/v86d/APKBUILD b/extra/v86d/APKBUILD
new file mode 100644
index 00000000..6a0b80c9
--- /dev/null
+++ b/extra/v86d/APKBUILD
@@ -0,0 +1,20 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=v86d
+pkgver=0.1.9
+pkgdesc="userspace helper for uvesafb that runs x86 code in an emulated environment"
+url="http://dev.gentoo.org/~spock/projects/uvesafb/"
+license="GPL2"
+depends="uclibc"
+source="http://dev.gentoo.org/~spock/projects/uvesafb/archive/$pkgname-$pkgver.tar.bz2
+ modprobe.uvesafb"
+
+build ()
+{
+ cd "$srcdir"/v86d-$pkgver
+ ./configure --with-x86emu
+ make || return 1
+ make DESTDIR="$pkgdir" install || return 1
+ install -D -m644 "$srcdir"/modprobe.uvesafb "$pkgdir"/etc/modprobe.d/uvesafb || return 1
+}
+md5sums="ebbbc8e7013c9544b6ba6981add43831 v86d-0.1.9.tar.bz2
+2d7cc8dc6a41916a13869212d0191147 modprobe.uvesafb"
diff --git a/extra/v86d/modprobe.uvesafb b/extra/v86d/modprobe.uvesafb
new file mode 100644
index 00000000..5e46e108
--- /dev/null
+++ b/extra/v86d/modprobe.uvesafb
@@ -0,0 +1,10 @@
+#
+# This file sets the parameters for uvesafb module.
+# The following format should be used:
+# options uvesafb mode=<xres>x<yres>[-<bpp>][@<refresh>] scroll=<ywrap|ypan|redraw> ...
+#
+# For more details see:
+# http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-2.6.git;a=blob;f=Documentation/fb/uvesafb.txt
+#
+
+options uvesafb mode_option=1024x768-32 scroll=ywrap