summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2009-04-13 13:13:14 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2009-04-13 13:13:14 +0000
commit358ac80866a2f0d632f5081db8940ae1b4387069 (patch)
tree828331a5ee72671ad65e578e6b066a4f44208688
parent95da6ee5ed1ce4bf512ebe77d0f008ae6a04b11b (diff)
downloadaports-358ac80866a2f0d632f5081db8940ae1b4387069.tar.bz2
aports-358ac80866a2f0d632f5081db8940ae1b4387069.tar.xz
extra/alsa-lib: disable useless C++ check
-rw-r--r--extra/alsa-lib/APKBUILD7
-rw-r--r--extra/alsa-lib/nocxx.patch15
2 files changed, 20 insertions, 2 deletions
diff --git a/extra/alsa-lib/APKBUILD b/extra/alsa-lib/APKBUILD
index bc30803a..7bb0b7be 100644
--- a/extra/alsa-lib/APKBUILD
+++ b/extra/alsa-lib/APKBUILD
@@ -7,13 +7,16 @@ url="http://www.alsa-project.org"
license="GPL"
depends="uclibc"
subpackages="$pkgname-dev"
-source="ftp://ftp.alsa-project.org/pub/lib/$pkgname-$pkgver.tar.bz2"
+source="ftp://ftp.alsa-project.org/pub/lib/$pkgname-$pkgver.tar.bz2
+ nocxx.patch"
build ()
{
cd "$srcdir/$pkgname-$pkgver"
+ patch configure < ../nocxx.patch || return 1
./configure --prefix=/usr --disable-python
make || return 1
make -j1 DESTDIR="$pkgdir" install
}
-md5sums="73db3666c211e5fb023bb77450cf430d alsa-lib-1.0.19.tar.bz2"
+md5sums="73db3666c211e5fb023bb77450cf430d alsa-lib-1.0.19.tar.bz2
+28513788ba4d556ccd538867dc6205ab nocxx.patch"
diff --git a/extra/alsa-lib/nocxx.patch b/extra/alsa-lib/nocxx.patch
new file mode 100644
index 00000000..beb1ab90
--- /dev/null
+++ b/extra/alsa-lib/nocxx.patch
@@ -0,0 +1,15 @@
+--- a/configure 2004-12-07 21:34:23.205172545 +0000
++++ b/configure 2004-12-07 21:37:17.726654782 +0000
+@@ -5148,10 +5148,8 @@
+ :
+ else
+ { { echo "$as_me:$LINENO: error: C++ preprocessor \"$CXXCPP\" fails sanity check
+-See \`config.log' for more details." >&5
+-echo "$as_me: error: C++ preprocessor \"$CXXCPP\" fails sanity check
+-See \`config.log' for more details." >&2;}
+- { (exit 1); exit 1; }; }
++See \`config.log' for more details." >&5;}
++ { echo "C++ sucks, ignoring ..." >&5; }; }
+ fi
+
+ ac_ext=cc