summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2009-04-13 13:53:37 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2009-04-13 13:53:37 +0000
commit95e9090b24c911d8a87ec615e4b7871456543991 (patch)
treebc24c9601c5a34eb1097d4a00c115548405e660c
parent2c65a103286e76e39b6519fe4a2a4b0e25e90909 (diff)
downloadaports-95e9090b24c911d8a87ec615e4b7871456543991.tar.bz2
aports-95e9090b24c911d8a87ec615e4b7871456543991.tar.xz
extra/dovecot: upgrade to 1.1.13
-rw-r--r--extra/dovecot/APKBUILD19
-rw-r--r--extra/dovecot/dovecot-1.1.11-4736327a8740.patch20
-rw-r--r--extra/dovecot/dovecot-1.1.11-bdc5391e52df.patch49
-rw-r--r--extra/dovecot/dovecot-1.1.11-c08c602ca0dc.patch26
4 files changed, 4 insertions, 110 deletions
diff --git a/extra/dovecot/APKBUILD b/extra/dovecot/APKBUILD
index 17d9faec..8b6ba6a7 100644
--- a/extra/dovecot/APKBUILD
+++ b/extra/dovecot/APKBUILD
@@ -1,31 +1,23 @@
# Contributor: Michael Mason <ms13sp@gmail.com>
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=dovecot
-pkgver=1.1.11
-pkgrel=1
+pkgver=1.1.13
+pkgrel=0
pkgdesc="IMAP and POP3 server"
url="http://www.dovecot.org/"
license="LGPL-2.1"
depends="uclibc libcap zlib openssl"
-makedepends="libcap-dev zlib-dev openssl-dev"
+makedepends="libcap-dev zlib-dev openssl-dev bzip2-dev"
install="dovecot.pre-install"
subpackages="$pkgname-doc $pkgname-dev"
source="http://www.dovecot.org/releases/1.1/$pkgname-$pkgver.tar.gz
dovecot.initd
- dovecot-1.1.11-4736327a8740.patch
- dovecot-1.1.11-bdc5391e52df.patch
- dovecot-1.1.11-c08c602ca0dc.patch
$install
"
build() {
cd "$srcdir/$pkgname-$pkgver"
- for i in ../*.patch; do
- msg "Applying $i.."
- patch -p1 < $i || return 1
- done
-
./configure --prefix=/usr \
--sysconfdir=/etc \
--mandir=/usr/share/man \
@@ -40,9 +32,6 @@ build() {
install -m755 -D "$srcdir"/$pkgname.initd "$pkgdir"/etc/init.d/$pkgname
}
-md5sums="c973eb41aca79fb16630a16f0d84f765 dovecot-1.1.11.tar.gz
+md5sums="8f3e10d0161429b15546a8ad6e8b4d25 dovecot-1.1.13.tar.gz
573e14589a6f8424d55753a2794ab99a dovecot.initd
-7e1cd399255fbacff197c0ba79b0c2c2 dovecot-1.1.11-4736327a8740.patch
-f95cc06111ba3b83399a28cb1459fca0 dovecot-1.1.11-bdc5391e52df.patch
-d15abfa0c41426b99423d140d35b2fbd dovecot-1.1.11-c08c602ca0dc.patch
f0f8893411f5e482e14f40a81a177b19 dovecot.pre-install"
diff --git a/extra/dovecot/dovecot-1.1.11-4736327a8740.patch b/extra/dovecot/dovecot-1.1.11-4736327a8740.patch
deleted file mode 100644
index 7f0418e6..00000000
--- a/extra/dovecot/dovecot-1.1.11-4736327a8740.patch
+++ /dev/null
@@ -1,20 +0,0 @@
-
-# HG changeset patch
-# User Timo Sirainen <tss@iki.fi>
-# Date 1233868321 18000
-# Node ID 4736327a8740579e7c89a8b386de9af0266b07fa
-# Parent 7d175e4ea57d21162abbf43a61c5305cfe1995b3
-Maildir: Fix to earlier >26 keywords handling change.
-
---- a/src/lib-storage/index/maildir/maildir-sync-index.c Wed Feb 04 17:44:01 2009 -0500
-+++ b/src/lib-storage/index/maildir/maildir-sync-index.c Thu Feb 05 16:12:01 2009 -0500
-@@ -336,7 +336,7 @@ maildir_sync_mail_keywords(struct maildi
- ones. we can get these lists easily by removing common elements
- from old and new keywords. */
- new_indexes = array_get_modifiable(&ctx->keywords, &new_count);
-- for (i = 0; i < old_count && j < new_count; ) {
-+ for (i = j = 0; i < old_count && j < new_count; ) {
- diff = (int)old_indexes[i] - (int)new_indexes[j];
- if (diff == 0) {
- array_delete(&ctx->keywords, j, 1);
-
diff --git a/extra/dovecot/dovecot-1.1.11-bdc5391e52df.patch b/extra/dovecot/dovecot-1.1.11-bdc5391e52df.patch
deleted file mode 100644
index ac1dc259..00000000
--- a/extra/dovecot/dovecot-1.1.11-bdc5391e52df.patch
+++ /dev/null
@@ -1,49 +0,0 @@
-
-# HG changeset patch
-# User Timo Sirainen <tss@iki.fi>
-# Date 1234226629 18000
-# Node ID bdc5391e52dfe4590e9e291eba2603ed87caef57
-# Parent 4ddf36b9ee8182f10d8d69af6577b677cda282a0
-master: Don't crash if auth process dies too early.
-
---- a/src/master/auth-process.c Thu Feb 05 18:29:06 2009 -0500
-+++ b/src/master/auth-process.c Mon Feb 09 19:43:49 2009 -0500
-@@ -353,7 +353,7 @@ static void auth_process_destroy(struct
-
- if (!p->initialized && io_loop_is_running(ioloop) && !p->external) {
- /* log the process exit and kill ourself */
-- child_processes_deinit();
-+ child_processes_flush();
- log_deinit();
- i_fatal("Auth process died too early - shutting down");
- }
---- a/src/master/child-process.c Thu Feb 05 18:29:06 2009 -0500
-+++ b/src/master/child-process.c Mon Feb 09 19:43:49 2009 -0500
-@@ -219,10 +219,15 @@ void child_processes_init(void)
- lib_signals_set_handler(SIGCHLD, TRUE, sigchld_handler, NULL);
- }
-
--void child_processes_deinit(void)
-+void child_processes_flush(void)
- {
- /* make sure we log if child processes died unexpectedly */
- sigchld_handler(SIGCHLD, NULL);
-+}
-+
-+void child_processes_deinit(void)
-+{
-+ child_processes_flush();
- lib_signals_unset_handler(SIGCHLD, sigchld_handler, NULL);
- hash_destroy(&processes);
- }
---- a/src/master/child-process.h Thu Feb 05 18:29:06 2009 -0500
-+++ b/src/master/child-process.h Mon Feb 09 19:43:49 2009 -0500
-@@ -40,6 +40,7 @@ void child_process_set_destroy_callback(
- child_process_destroy_callback_t *cb);
-
- void child_processes_init(void);
-+void child_processes_flush(void);
- void child_processes_deinit(void);
-
- #endif
-
diff --git a/extra/dovecot/dovecot-1.1.11-c08c602ca0dc.patch b/extra/dovecot/dovecot-1.1.11-c08c602ca0dc.patch
deleted file mode 100644
index 17ce2705..00000000
--- a/extra/dovecot/dovecot-1.1.11-c08c602ca0dc.patch
+++ /dev/null
@@ -1,26 +0,0 @@
-
-# HG changeset patch
-# User Timo Sirainen <tss@iki.fi>
-# Date 1234481874 18000
-# Node ID c08c602ca0dcbc137a4ca965b3722953cabfa4fc
-# Parent 4044df5a4d12fef4086d7e604444467eb105f348
-"Maildir filename has wrong W value" error was missing new/cur directory in the middle.
-
---- a/src/lib-storage/index/maildir/maildir-mail.c Tue Feb 10 12:19:05 2009 -0500
-+++ b/src/lib-storage/index/maildir/maildir-mail.c Thu Feb 12 18:37:54 2009 -0500
-@@ -485,8 +485,12 @@ static void maildir_mail_set_cache_corru
- _mail->uid, &flags);
- if (maildir_filename_get_size(fname, MAILDIR_EXTRA_VIRTUAL_SIZE,
- &size)) {
-- i_error("Maildir filename has wrong W value: %s/%s",
-- mbox->path, fname);
-+ const char *subdir =
-+ (flags & MAILDIR_UIDLIST_REC_FLAG_NEW_DIR) != 0 ?
-+ "new" : "cur";
-+ mail_storage_set_critical(_mail->box->storage,
-+ "Maildir filename has wrong W value: %s/%s/%s",
-+ mbox->path, subdir, fname);
- } else if (maildir_uidlist_lookup_ext(mbox->uidlist, _mail->uid,
- MAILDIR_UIDLIST_REC_EXT_VSIZE) != NULL) {
- maildir_uidlist_set_ext(mbox->uidlist, _mail->uid,
-