summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2009-04-10 18:36:11 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2009-04-10 18:36:11 +0000
commitbf546be7d386e4e06dd15ed193b774e0606822ab (patch)
treeeadf0ae90880fb7593c6eb4aa8d2b04137e99211
parent775e621e87260e24f0eb7a42cff893d89dc61128 (diff)
downloadaports-bf546be7d386e4e06dd15ed193b774e0606822ab.tar.bz2
aports-bf546be7d386e4e06dd15ed193b774e0606822ab.tar.xz
x11/xsetroot: new aport
X.Org xsetroot application
-rw-r--r--x11/xsetroot/APKBUILD20
1 files changed, 20 insertions, 0 deletions
diff --git a/x11/xsetroot/APKBUILD b/x11/xsetroot/APKBUILD
new file mode 100644
index 00000000..4bb940d2
--- /dev/null
+++ b/x11/xsetroot/APKBUILD
@@ -0,0 +1,20 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=xsetroot
+pkgver=1.0.2
+pkgrel=0
+pkgdesc="X.Org xsetroot application"
+url="http://xorg.freedesktop.org/"
+license="custom"
+subpackages="$pkgname-doc"
+depends="libx11 libxmu uclibc"
+makedepends="pkgconfig libx11-dev libxmu-dev xbitmaps"
+source="http://xorg.freedesktop.org/releases/individual/app/$pkgname-$pkgver.tar.bz2"
+
+build ()
+{
+ cd "$srcdir"/$pkgname-$pkgver
+ ./configure --prefix=/usr --mandir=/usr/share/man || return 1
+ make || return 1
+ make DESTDIR="$pkgdir" install || return 1
+}
+md5sums="9af7db9f3052aef0b11636720b3101dd xsetroot-1.0.2.tar.bz2"