summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichael Mason <ms13sp@gmail.com>2009-03-25 13:49:35 +0000
committerMichael Mason <ms13sp@gmail.com>2009-03-25 13:49:35 +0000
commit30894889bbdd0d724bf39903f9299d16fb1349fd (patch)
tree811c9d4ef224e5c5180cd674a49310afd303ae32
parent5d31e328b3347529908395056009e0af778466ed (diff)
parent7ac86c6f324e387f9691cede4999bf6be00d9895 (diff)
downloadaports-30894889bbdd0d724bf39903f9299d16fb1349fd.tar.bz2
aports-30894889bbdd0d724bf39903f9299d16fb1349fd.tar.xz
Merge branch 'master' of git://dev.alpinelinux.org/aports
-rw-r--r--core/alpine-conf/APKBUILD6
-rw-r--r--core/iptables/APKBUILD8
-rw-r--r--core/iptables/iptables-1.4.2-as-needed.patch54
-rw-r--r--core/linux-grsec-sources/APKBUILD11
-rw-r--r--core/linux-grsec/APKBUILD4
-rw-r--r--core/xtables-addons/APKBUILD8
-rw-r--r--extra/pingu/APKBUILD6
-rw-r--r--testing/dahdi-linux/APKBUILD4
-rw-r--r--x11/bdftopcf/APKBUILD22
9 files changed, 47 insertions, 76 deletions
diff --git a/core/alpine-conf/APKBUILD b/core/alpine-conf/APKBUILD
index 34725cab..0f836eb7 100644
--- a/core/alpine-conf/APKBUILD
+++ b/core/alpine-conf/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=alpine-conf
pkgver=2.0_alpha4
-pkgrel=0
+pkgrel=1
pkgdesc="Alpine configuration management scripts"
url=http://git.alpinelinux.org/cgit/$pkgname
source=http://git.alpinelinux.org/cgit/$pkgname/snapshot/$pkgname-$pkgver.tar.bz2
@@ -10,6 +10,10 @@ license="GPL-2"
build() {
cd "$srcdir/$pkgname-$pkgver"
make PREFIX= || return 1
+
+ # workaround. fixed in git so this needs to be removed next release
+ sed -i -e 's:/usr/share/lbu/libalpine.sh:/lib/libalpine.sh:' lbu
+
make install PREFIX= DESTDIR="$pkgdir"
for i in commit exclude include status update; do
ln -s lbu "$pkgdir"/sbin/lbu_$i
diff --git a/core/iptables/APKBUILD b/core/iptables/APKBUILD
index 485ca7a9..0d409bda 100644
--- a/core/iptables/APKBUILD
+++ b/core/iptables/APKBUILD
@@ -2,18 +2,18 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=iptables
-pkgver=1.4.2
+pkgver=1.4.3.1
pkgrel=0
pkgdesc="Linux kernel firewall, NAT and packet mangling tools"
url="http://www.iptables.org/"
license=GPL-2
source="http://iptables.org/projects/iptables/files/$pkgname-$pkgver.tar.bz2
- iptables-1.4.2-as-needed.patch
iptables-1.4.2-no-ldconfig.patch
iptables-1.4.2-include-in.patch
iptables.initd
iptables.confd
"
+
makedepends="linux-headers"
subpackages="ip6tables $pkgname-doc $pkgname-dev"
@@ -21,6 +21,7 @@ build() {
local i
cd "$srcdir/$pkgname-$pkgver"
for i in ../*.patch; do
+ msg "Applying $i..."
patch -p1 -i $i || return 1
done
@@ -60,8 +61,7 @@ ip6tables() {
"$subpkgdir"/etc/init.d/ip6tables
}
-md5sums="a138d1c2e74321e0e4e228a9fb301c9a iptables-1.4.2.tar.bz2
-9279ad4cfa650c828bc3fff5368ad526 iptables-1.4.2-as-needed.patch
+md5sums="9c67f796f69e1e016cc19e2c19357711 iptables-1.4.3.1.tar.bz2
7b9c52caf34663186c32ea44b80c9a03 iptables-1.4.2-no-ldconfig.patch
ec3e80a1b0ea3e13e4e60824b7ebd1b9 iptables-1.4.2-include-in.patch
2202ac150a5dfe32a8363b0ad565ee1d iptables.initd
diff --git a/core/iptables/iptables-1.4.2-as-needed.patch b/core/iptables/iptables-1.4.2-as-needed.patch
deleted file mode 100644
index 3782393f..00000000
--- a/core/iptables/iptables-1.4.2-as-needed.patch
+++ /dev/null
@@ -1,54 +0,0 @@
-http://bugs.gentoo.org/244431
-
-patch by Arfrever Frehtes Taifersar Arahesis
-
---- a/Makefile.in
-+++ b/Makefile.in
-@@ -87,7 +87,7 @@
- "$(DESTDIR)$(pkgconfigdir)" "$(DESTDIR)$(includedir)"
- libLTLIBRARIES_INSTALL = $(INSTALL)
- LTLIBRARIES = $(lib_LTLIBRARIES)
--libxtables_la_LIBADD =
-+libxtables_la_DEPENDENCIES =
- am_libxtables_la_OBJECTS = xtables.lo
- libxtables_la_OBJECTS = $(am_libxtables_la_OBJECTS)
- binPROGRAMS_INSTALL = $(INSTALL_PROGRAM)
-@@ -353,11 +353,12 @@
- lib_LTLIBRARIES = libxtables.la
- libxtables_la_SOURCES = xtables.c
- libxtables_la_LDFLAGS = -version 0:0:0
-+libxtables_la_LIBADD = -ldl
-
- # iptables, dynamic
- iptables_SOURCES = iptables-standalone.c iptables.c
- iptables_LDFLAGS = -rdynamic
--iptables_LDADD = -ldl -lm libiptc/libiptc.a extensions/libext4.a libxtables.la
-+iptables_LDADD = libiptc/libiptc.a extensions/libext4.a libxtables.la -ldl -lm
- iptables_multi_SOURCES = iptables-multi.c iptables-save.c \
- iptables-restore.c iptables-xml.c \
- iptables-standalone.c iptables.c
-@@ -375,13 +376,13 @@
- # iptables-multi, semi-static
- iptables_static_SOURCES = ${iptables_multi_SOURCES} xtables.c
- iptables_static_CFLAGS = ${iptables_multi_CFLAGS} -DNO_SHARED_LIBS=1
--iptables_static_LDADD = -lm libiptc/libiptc.a extensions/libext4.a
-+iptables_static_LDADD = libiptc/libiptc.a extensions/libext4.a -lm
- iptables_xml_SOURCES = iptables-xml.c
-
- # ip6tables, dynamic
- ip6tables_SOURCES = ip6tables-standalone.c ip6tables.c
- ip6tables_LDFLAGS = -rdynamic
--ip6tables_LDADD = -ldl -lm libiptc/libiptc.a extensions/libext6.a libxtables.la
-+ip6tables_LDADD = libiptc/libiptc.a extensions/libext6.a libxtables.la -ldl -lm
- ip6tables_multi_SOURCES = ip6tables-multi.c ip6tables-save.c \
- ip6tables-restore.c ip6tables-standalone.c \
- ip6tables.c
-@@ -399,7 +400,7 @@
- # iptables-multi, semi-static
- ip6tables_static_SOURCES = ${ip6tables_multi_SOURCES} xtables.c
- ip6tables_static_CFLAGS = ${ip6tables_multi_CFLAGS} -DNO_SHARED_LIBS=1
--ip6tables_static_LDADD = -lm libiptc/libiptc.a extensions/libext6.a
-+ip6tables_static_LDADD = libiptc/libiptc.a extensions/libext6.a -lm
- noinst_LIBRARIES := libiptc/libiptc.a
- man_MANS := iptables.8 iptables-restore.8 iptables-save.8 \
- iptables-xml.8 ip6tables.8 ip6tables-restore.8 \
diff --git a/core/linux-grsec-sources/APKBUILD b/core/linux-grsec-sources/APKBUILD
index 7c408914..e1a5901b 100644
--- a/core/linux-grsec-sources/APKBUILD
+++ b/core/linux-grsec-sources/APKBUILD
@@ -1,12 +1,11 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
_suff=grsec
pkgname=linux-$_suff-sources
-pkgver=2.6.28.7
+pkgver=2.6.28.9
pkgdesc="Linux kernel sources with grsecurity patch"
_kernver=2.6.28
-_grsecver=2.1.13-$_kernver.7-200902232153
-
-pkgrel=2
+_grsecver=2.1.13-$_kernver.8-200903191958
+pkgrel=0
options="!strip"
license=GPL-2
url=http://kernel.org
@@ -34,7 +33,7 @@ build() {
}
md5sums="d351e44709c9810b85e29b877f50968a linux-2.6.28.tar.bz2
-346c912ebaffcf84361859014009be50 patch-2.6.28.7.bz2
-02cfd67a85d5050c3b8340c2a67b5678 grsecurity-2.1.13-2.6.28.7-200902232153.patch
+27a43f76cf4b90db18df6d1c5e72789b patch-2.6.28.9.bz2
+e98fdd8e286579c61822ef264b56dee4 grsecurity-2.1.13-2.6.28.8-200903191958.patch
7673b4521283ad41434a18ca18b16ad8 0001-linux-2.6.28.5-ipgre-strict-binding.patch
8f405c738b150c532c46eaad5390cca2 0002-linux-2.6.28.5-ipgre-optimize-hash-lookup.patch"
diff --git a/core/linux-grsec/APKBUILD b/core/linux-grsec/APKBUILD
index a1c9185b..5c690da8 100644
--- a/core/linux-grsec/APKBUILD
+++ b/core/linux-grsec/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=linux-grsec
-pkgver=2.6.28.7
-pkgrel=1
+pkgver=2.6.28.9
+pkgrel=0
pkgdesc="Linux kernel with grsecurity"
url=http://grsecurity.net
arch=i486
diff --git a/core/xtables-addons/APKBUILD b/core/xtables-addons/APKBUILD
index b9a75203..172b11c2 100644
--- a/core/xtables-addons/APKBUILD
+++ b/core/xtables-addons/APKBUILD
@@ -1,14 +1,14 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=xtables-addons
_kernflavor=grsec
-_kernver=2.6.28.7
-pkgver=1.12
+_kernver=2.6.28.9
+pkgver=1.13
pkgrel=0
pkgdesc="Xtables-addons is the successor to patch-o-matic(-ng)"
url="http://jengelh.medozas.de/projects/xtables/"
license="GPL"
depends="linux-grsec"
-makedepends="linux-grsec-dev linux-grsec-sources iptables-dev"
+makedepends="linux-grsec-dev linux-grsec-sources iptables-dev pkgconfig"
install=
subpackages="$pkgname-doc $pkgname-grsec:mod"
source="http://downloads.sourceforge.net/$pkgname/$pkgname-$pkgver.tar.bz2
@@ -36,5 +36,5 @@ build() {
make DESTDIR="$pkgdir" install
}
-md5sums="e1544d87bbae03a02874c6598daa111d xtables-addons-1.12.tar.bz2
+md5sums="7c9cd60a00c2d4b9bed76cf4cec22fa1 xtables-addons-1.13.tar.bz2
22bb434696be0960a6c758de17420e18 xtables-addons-1.12-readlink.patch"
diff --git a/extra/pingu/APKBUILD b/extra/pingu/APKBUILD
index 8089c156..fdd91972 100644
--- a/extra/pingu/APKBUILD
+++ b/extra/pingu/APKBUILD
@@ -1,8 +1,8 @@
# Contributor: Natanael Copa <ncopa@alpinelinux.org>
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=pingu
-pkgver=0.2
-pkgrel=1
+pkgver=0.3
+pkgrel=0
pkgdesc="Small daemon that pings hosts and executes a script when status change"
url="http://git.alpinelinux.org/cgit/pingu"
license="GPL"
@@ -19,5 +19,5 @@ build() {
install -m755 -D "$srcdir"/$pkgname.initd "$pkgdir"/etc/init.d/$pkgname
}
-md5sums="5f7b72e4eb0af88a5d568b383513591f pingu-0.2.tar.bz2
+md5sums="59f9c927a80c71d85f2363e314a25197 pingu-0.3.tar.bz2
d2162d9c02a66691bb6360f4f2d9d701 pingu.initd"
diff --git a/testing/dahdi-linux/APKBUILD b/testing/dahdi-linux/APKBUILD
index ca3597dd..dea3090f 100644
--- a/testing/dahdi-linux/APKBUILD
+++ b/testing/dahdi-linux/APKBUILD
@@ -2,9 +2,9 @@
# Maintainer: Timo Teras <timo.teras@iki.fi>
pkgname=dahdi-linux
_kernflavor=grsec
-_kernver=2.6.28.7
+_kernver=2.6.28.9
pkgver=2.1.0.4
-pkgrel=2
+pkgrel=3
pkgdesc="Digium Asterisk Hardware Device Interface drivers"
url="http://www.asterisk.org"
license="GPL"
diff --git a/x11/bdftopcf/APKBUILD b/x11/bdftopcf/APKBUILD
new file mode 100644
index 00000000..b74b39a5
--- /dev/null
+++ b/x11/bdftopcf/APKBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=bdftopcf
+pkgver=1.0.1
+pkgrel=0
+pkgdesc="X.Org font utility"
+url="http://xorg.freedesktop.org/"
+license="custom"
+depends="libxfont uclibc"
+makedepends="libxfont-dev"
+install=
+subpackages="$pkgname-doc"
+source="http://xorg.freedesktop.org//releases/individual/app/bdftopcf-1.0.1.tar.bz2"
+
+build() {
+ cd "$srcdir"/$pkgname-$pkgver
+ ./configure --prefix=/usr \
+ --mandir=/usr/share/man \
+ --with-mapdir=/usr/share/fonts/util || return 1
+ make || return 1
+ make DESTDIR="$pkgdir" install || return 1
+}
+md5sums="9685fab33d39954ab8a0d22e0969d5a4 bdftopcf-1.0.1.tar.bz2"