summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2009-04-13 13:32:10 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2009-04-13 13:32:10 +0000
commit57a50acc03ed6207d04410d40c94a4d413687a01 (patch)
tree392e2ea6aed228504c3f0d77025a0bda0483eb80
parent358ac80866a2f0d632f5081db8940ae1b4387069 (diff)
downloadaports-57a50acc03ed6207d04410d40c94a4d413687a01.tar.bz2
aports-57a50acc03ed6207d04410d40c94a4d413687a01.tar.xz
extra/sfic: recompiled against new tdb provided by samba
-rw-r--r--extra/sfic/APKBUILD12
-rw-r--r--extra/sfic/sfic-0.1.7-signal.patch10
2 files changed, 18 insertions, 4 deletions
diff --git a/extra/sfic/APKBUILD b/extra/sfic/APKBUILD
index 75342aad..3f781b4d 100644
--- a/extra/sfic/APKBUILD
+++ b/extra/sfic/APKBUILD
@@ -1,19 +1,22 @@
pkgdesc="Small and Simple File Integrity Checker"
pkgname=sfic
pkgver=0.1.7
-pkgrel=0
+pkgrel=1
depends=uclibc
license=GPL
-makedepends="autoconf automake tdb-dev"
+makedepends="autoconf automake samba-dev"
depends="tdb uclibc"
arch=i486
url=http://sfic.sourceforge.net
-source="http://downloads.sourceforge.net/$pkgname/$pkgname-$pkgver.tar.gz"
+source="http://downloads.sourceforge.net/$pkgname/$pkgname-$pkgver.tar.gz
+ $pkgname-0.1.7-signal.patch"
subpackages="$pkgname-doc"
build() {
cd $srcdir/$pkgname-$pkgver
+ patch -p1 < ../$pkgname-0.1.7-signal.patch || return 1
+
aclocal
autoconf
automake --add-missing || return 1
@@ -22,4 +25,5 @@ build() {
make install DESTDIR="$pkgdir"
}
-md5sums="6197f7a1e8b0fc4887d4573f67b7bb81 sfic-0.1.7.tar.gz"
+md5sums="6197f7a1e8b0fc4887d4573f67b7bb81 sfic-0.1.7.tar.gz
+e0c284f8b4e355b3ea52927fb02e163a sfic-0.1.7-signal.patch"
diff --git a/extra/sfic/sfic-0.1.7-signal.patch b/extra/sfic/sfic-0.1.7-signal.patch
new file mode 100644
index 00000000..54538aac
--- /dev/null
+++ b/extra/sfic/sfic-0.1.7-signal.patch
@@ -0,0 +1,10 @@
+--- sfic-0.1.7.orig/src/sfic.c 2009-04-13 13:25:49.000000000 +0000
++++ sfic-0.1.7/src/sfic.c 2009-04-13 13:26:14.000000000 +0000
+@@ -37,6 +37,7 @@
+ #include <dirent.h>
+ #include <stdarg.h>
+
++#include <signal.h>
+ #include <tdb.h>
+
+ #include "heap.h"