summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2009-04-16 07:13:28 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2009-04-16 07:13:28 +0000
commitba1b34599cb2ffd39bff46c722251311a57ffd44 (patch)
tree9e2ecc36bfe50c9f284e1ad6933abea22fe334a1
parentd15b852ede90e3ff8cdbf08f096db07a720b7224 (diff)
downloadaports-ba1b34599cb2ffd39bff46c722251311a57ffd44.tar.bz2
aports-ba1b34599cb2ffd39bff46c722251311a57ffd44.tar.xz
core/busybox: add patches from upstream. enable tar long options
tar long options is needed for --numeric-owner which is needed for bug #23 I enabled rpm2cpio while I was here.
-rw-r--r--core/busybox/APKBUILD10
-rw-r--r--core/busybox/busybox-1.13.3-tail.patch12
-rw-r--r--core/busybox/busybox-1.13.3-tar.patch37
-rw-r--r--core/busybox/busybox-1.13.3-volumeid.patch18
-rw-r--r--core/busybox/busyboxconfig6
5 files changed, 78 insertions, 5 deletions
diff --git a/core/busybox/APKBUILD b/core/busybox/APKBUILD
index 7c3ff2e6..02a75407 100644
--- a/core/busybox/APKBUILD
+++ b/core/busybox/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=busybox
pkgver=1.13.3
-pkgrel=4
+pkgrel=5
pkgdesc="Size optimized toolbox of many common UNIX utilities"
url=http://busybox.net
license=GPL-2
@@ -14,6 +14,9 @@ source="http://busybox.net/downloads/$pkgname-$pkgver.tar.bz2
busybox-1.13.2-depmod2.patch
busybox-1.13.3-ash.patch
busybox-1.13.3-hush.patch
+ busybox-1.13.3-tail.patch
+ busybox-1.13.3-tar.patch
+ busybox-1.13.3-volumeid.patch
bb-tar-numeric-owner.patch
$install
busyboxconfig"
@@ -47,7 +50,10 @@ a743ec04f378b8456a725c7270b0be8b busybox-1.13.2-modprobe-errormsg.patch
3c43008545e069749d2d653532e1feb3 busybox-1.13.2-depmod2.patch
ed7537bc7193ab35f4e4ac6ce26d8270 busybox-1.13.3-ash.patch
4a5fe634708150f65b6d9b51dba20a51 busybox-1.13.3-hush.patch
+c7d958974dde8fb7b1258b41820beeba busybox-1.13.3-tail.patch
+b0e4aeed6efc6f6870e8665da0bb223e busybox-1.13.3-tar.patch
+48cdc820269be1d964affed61a02c89b busybox-1.13.3-volumeid.patch
0b5b2d7db201f90cd08f4a3164ee29a1 bb-tar-numeric-owner.patch
56b78c358797cd15fb64719a48939267 busybox.post-install
56b78c358797cd15fb64719a48939267 busybox.post-upgrade
-fa6b9e2021102a53c43875ef0704d6f3 busyboxconfig"
+4ac046c50919440b971e120e2224505d busyboxconfig"
diff --git a/core/busybox/busybox-1.13.3-tail.patch b/core/busybox/busybox-1.13.3-tail.patch
new file mode 100644
index 00000000..bd3abc0e
--- /dev/null
+++ b/core/busybox/busybox-1.13.3-tail.patch
@@ -0,0 +1,12 @@
+diff -urpN busybox-1.13.3/coreutils/tail.c busybox-1.13.3-tail/coreutils/tail.c
+--- busybox-1.13.3/coreutils/tail.c 2009-02-26 12:47:02.000000000 +0100
++++ busybox-1.13.3-tail/coreutils/tail.c 2009-03-27 03:34:57.000000000 +0100
+@@ -104,7 +104,7 @@ int tail_main(int argc, char **argv)
+ if (argv[1] && (argv[1][0] == '+' || argv[1][0] == '-')
+ && isdigit(argv[1][1])
+ ) {
+- count = eat_num(&argv[1][1]);
++ count = eat_num(argv[1]);
+ argv++;
+ argc--;
+ }
diff --git a/core/busybox/busybox-1.13.3-tar.patch b/core/busybox/busybox-1.13.3-tar.patch
new file mode 100644
index 00000000..c1598425
--- /dev/null
+++ b/core/busybox/busybox-1.13.3-tar.patch
@@ -0,0 +1,37 @@
+diff -urpN busybox-1.13.3/archival/libunarchive/get_header_tar.c busybox-1.13.3-tar/archival/libunarchive/get_header_tar.c
+--- busybox-1.13.3/archival/libunarchive/get_header_tar.c 2009-02-26 12:46:40.000000000 +0100
++++ busybox-1.13.3-tar/archival/libunarchive/get_header_tar.c 2009-04-01 01:15:26.000000000 +0200
+@@ -91,7 +91,7 @@ char FAST_FUNC get_header_tar(archive_ha
+
+ again_after_align:
+
+-#if ENABLE_DESKTOP
++#if ENABLE_DESKTOP || ENABLE_FEATURE_TAR_AUTODETECT
+ /* to prevent misdetection of bz2 sig */
+ *(uint32_t*)(&tar) = 0;
+ i = full_read(archive_handle->src_fd, &tar, 512);
+@@ -142,7 +142,7 @@ char FAST_FUNC get_header_tar(archive_ha
+ #if ENABLE_FEATURE_TAR_AUTODETECT
+ char FAST_FUNC (*get_header_ptr)(archive_handle_t *);
+
+- USE_DESKTOP(autodetect:)
++ autodetect:
+ /* tar gz/bz autodetect: check for gz/bz2 magic.
+ * If we see the magic, and it is the very first block,
+ * we can switch to get_header_tar_gz/bz2/lzma().
+diff -urpN busybox-1.13.3/archival/tar.c busybox-1.13.3-tar/archival/tar.c
+--- busybox-1.13.3/archival/tar.c 2009-02-26 12:56:00.000000000 +0100
++++ busybox-1.13.3-tar/archival/tar.c 2009-04-01 01:15:39.000000000 +0200
+@@ -934,8 +934,10 @@ int tar_main(int argc UNUSED_PARAM, char
+ tar_handle->src_fd = fileno(tar_stream);
+ tar_handle->seek = seek_by_read;
+ } else {
+- if (ENABLE_FEATURE_TAR_AUTODETECT && flags == O_RDONLY) {
+- get_header_ptr = get_header_tar;
++ if (ENABLE_FEATURE_TAR_AUTODETECT
++ && get_header_ptr == get_header_tar
++ && flags == O_RDONLY
++ ) {
+ tar_handle->src_fd = open_zipped(tar_filename);
+ if (tar_handle->src_fd < 0)
+ bb_perror_msg_and_die("can't open '%s'", tar_filename);
diff --git a/core/busybox/busybox-1.13.3-volumeid.patch b/core/busybox/busybox-1.13.3-volumeid.patch
new file mode 100644
index 00000000..ff4c0258
--- /dev/null
+++ b/core/busybox/busybox-1.13.3-volumeid.patch
@@ -0,0 +1,18 @@
+diff -urpN busybox-1.13.3/util-linux/volume_id/get_devname.c busybox-1.13.3-volumeid/util-linux/volume_id/get_devname.c
+--- busybox-1.13.3/util-linux/volume_id/get_devname.c 2009-02-26 12:47:41.000000000 +0100
++++ busybox-1.13.3-volumeid/util-linux/volume_id/get_devname.c 2009-03-31 21:46:37.000000000 +0200
+@@ -223,13 +223,11 @@ void display_uuid_cache(void)
+ char *get_devname_from_label(const char *spec)
+ {
+ struct uuidCache_s *uc;
+- int spec_len = strlen(spec);
+
+ uuidcache_init();
+ uc = uuidCache;
+ while (uc) {
+-// FIXME: empty label ("LABEL=") matches anything??!
+- if (uc->label[0] && strncmp(spec, uc->label, spec_len) == 0) {
++ if (uc->label[0] && strcmp(spec, uc->label) == 0) {
+ return xstrdup(uc->device);
+ }
+ uc = uc->next;
diff --git a/core/busybox/busyboxconfig b/core/busybox/busyboxconfig
index dbd392f8..bbcc05b6 100644
--- a/core/busybox/busyboxconfig
+++ b/core/busybox/busyboxconfig
@@ -1,7 +1,7 @@
#
# Automatically generated make config: don't edit
# Busybox version: 1.13.3
-# Fri Mar 20 21:23:00 2009
+# Thu Apr 16 06:50:12 2009
#
CONFIG_HAVE_DOT_CONFIG=y
@@ -115,7 +115,7 @@ CONFIG_FEATURE_CPIO_O=y
# CONFIG_FEATURE_DPKG_DEB_EXTRACT_ONLY is not set
CONFIG_GUNZIP=y
CONFIG_GZIP=y
-# CONFIG_RPM2CPIO is not set
+CONFIG_RPM2CPIO=y
# CONFIG_RPM is not set
CONFIG_TAR=y
CONFIG_FEATURE_TAR_CREATE=y
@@ -124,7 +124,7 @@ CONFIG_FEATURE_TAR_FROM=y
CONFIG_FEATURE_TAR_OLDGNU_COMPATIBILITY=y
CONFIG_FEATURE_TAR_OLDSUN_COMPATIBILITY=y
CONFIG_FEATURE_TAR_GNU_EXTENSIONS=y
-# CONFIG_FEATURE_TAR_LONG_OPTIONS is not set
+CONFIG_FEATURE_TAR_LONG_OPTIONS=y
CONFIG_FEATURE_TAR_UNAME_GNAME=y
CONFIG_UNCOMPRESS=y
CONFIG_UNLZMA=y