summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2009-04-14 11:43:12 +0000
committerCarlo Landmeter <clandmeter@gmail.com>2009-04-14 11:43:12 +0000
commitf4290246065cc5bdfa9eedad2ad1ebfa9140908c (patch)
treecda0bd92e847114e4e81cae49a6b22cd92dbfe2c
parenta07d3df748a32c8f87161df1679a042f2f366a87 (diff)
downloadaports-f4290246065cc5bdfa9eedad2ad1ebfa9140908c.tar.bz2
aports-f4290246065cc5bdfa9eedad2ad1ebfa9140908c.tar.xz
extra/clamav: version bump 0.95.1
-rw-r--r--extra/clamav/APKBUILD12
-rw-r--r--extra/clamav/clamav-0.94.2-nls.patch71
-rw-r--r--extra/clamav/clamav-0.95.1-nls.patch11
3 files changed, 17 insertions, 77 deletions
diff --git a/extra/clamav/APKBUILD b/extra/clamav/APKBUILD
index e86b6628..7972c549 100644
--- a/extra/clamav/APKBUILD
+++ b/extra/clamav/APKBUILD
@@ -1,8 +1,8 @@
# Contributor: Carlo Landmeter <clandmeter at gmail>
# Maintainer: Carlo Landmeter <clandmeter at gmail>
pkgname=clamav
-pkgver=0.94.2
-pkgrel=2
+pkgver=0.95.1
+pkgrel=0
pkgdesc="An anti-virus toolkit for UNIX"
url="http://www.clamav.net/"
license="GPL"
@@ -15,13 +15,13 @@ source="http://downloads.sourceforge.net/$pkgname/$pkgname-$pkgver.tar.gz
clamd.confd
freshclam.initd
freshclam.confd
- clamav-0.94.2-nls.patch
+ clamav-0.95.1-nls.patch
$install"
build() {
cd "$srcdir/$pkgname-$pkgver"
- patch -p0 -i "$srcdir/clamav-0.94.2-nls.patch" || return 1
+ patch -p0 -i "$srcdir/clamav-0.95.1-nls.patch" || return 1
./configure --prefix=/usr \
--sysconfdir=/etc \
@@ -38,11 +38,11 @@ build() {
mkdir -p "$pkgdir"/var/run/clamav "$pkgdir"/var/log/clamav
}
-md5sums="1181e6d62341b84708f126cc353f7ebf clamav-0.94.2.tar.gz
+md5sums="c802d4b372e455849cfcb0d776fc72d8 clamav-0.95.1.tar.gz
04f32738c037c96c3fd2c4fa7781fc7a clamd.initd
e84205681f64c07af9ec5b6a3dd8bc38 clamd.confd
fe3cfca9e1355183117936bea6fc6783 freshclam.initd
e84205681f64c07af9ec5b6a3dd8bc38 freshclam.confd
-328a0c3449a6b516e443d7db5a0d4d01 clamav-0.94.2-nls.patch
+0d08fd29656bd4b018ecf8ce9706ac55 clamav-0.95.1-nls.patch
275e05587e2da782781829a1862d57b1 clamav.pre-install
ec4d600097a15e64dfb714e7739a1804 clamav.post-install"
diff --git a/extra/clamav/clamav-0.94.2-nls.patch b/extra/clamav/clamav-0.94.2-nls.patch
deleted file mode 100644
index 7e02a29d..00000000
--- a/extra/clamav/clamav-0.94.2-nls.patch
+++ /dev/null
@@ -1,71 +0,0 @@
-Patch to disable nls (gettext) support for clamd. Taken from gentoo:
-http://sources.gentoo.org/viewcvs.py/gentoo-x86/app-antivirus/clamav/files/clamav-0.94-nls.patch?view=log
-
---- clamav-milter/clamav-milter.c Fri Nov 21 22:24:41 2008
-+++ clamav-milter/clamav-milter.c Mon Feb 2 09:30:14 2009
-@@ -113,6 +113,7 @@
-
- #ifdef C_LINUX
- #include <sys/sendfile.h> /* FIXME: use sendfile on BSD not Linux */
-+#ifdef ENABLE_NLS
- #include <libintl.h>
- #include <locale.h>
-
-@@ -125,7 +126,8 @@
- #define _(s) s
- #define N_(s) s
-
--#endif
-+#endif /* ENABLE_NLS */
-+#endif /* C_LINUX */
-
- #ifdef USE_SYSLOG
- #include <syslog.h>
-@@ -774,7 +776,7 @@
- else
- progname = "clamav-milter";
-
--#ifdef C_LINUX
-+#ifdef ENABLE_NLS
- setlocale(LC_ALL, "");
- bindtextdomain(progname, DATADIR"/clamav-milter/locale");
- textdomain(progname);
---- configure.in Wed Nov 26 12:15:08 2008
-+++ configure.in Mon Feb 2 09:30:14 2009
-@@ -609,6 +609,14 @@
- fi
- fi
-
-+AC_ARG_ENABLE([nls],
-+ AC_HELP_STRING([--disable-nls], [disable NLS support]),
-+ [want_nls=$enableval], [want_nls=yes]
-+)
-+if test $want_nls = yes; then
-+ CPPFLAGS="$CPPFLAGS -DENABLE_NLS"
-+fi
-+
- AC_ARG_ENABLE([ipv6],
- [ --disable-ipv6 disable IPv6 support],
- want_ipv6=$enableval, want_ipv6="yes")
---- shared/getopt.c Fri Nov 21 22:24:42 2008
-+++ shared/getopt.c Mon Feb 2 09:30:14 2009
-@@ -82,7 +82,7 @@
-
- #ifndef _
- /* This is for other GNU distributions with internationalized messages. */
--# if defined HAVE_LIBINTL_H || defined _LIBC
-+# if (defined(HAVE_LIBINTL_H) || defined(_LIBC)) && defined(ENABLE_NLS)
- # include <libintl.h>
- # ifndef _
- # define _(msgid) gettext (msgid)
---- shared/output.c Tue Nov 25 20:11:00 2008
-+++ shared/output.c Mon Feb 2 09:30:14 2009
-@@ -61,7 +61,7 @@
- pthread_mutex_t logg_mutex = PTHREAD_MUTEX_INITIALIZER;
- #endif
-
--#ifdef C_LINUX
-+#if defined(C_LINUX) && defined(ENABLE_NLS)
- #include <libintl.h>
- #include <locale.h>
-
diff --git a/extra/clamav/clamav-0.95.1-nls.patch b/extra/clamav/clamav-0.95.1-nls.patch
new file mode 100644
index 00000000..82ae88f5
--- /dev/null
+++ b/extra/clamav/clamav-0.95.1-nls.patch
@@ -0,0 +1,11 @@
+--- shared/output.c-orig 2009-04-04 10:17:42 +0000
++++ shared/output.c 2009-04-04 10:18:30 +0000
+@@ -67,7 +67,7 @@
+ pthread_mutex_t logg_mutex = PTHREAD_MUTEX_INITIALIZER;
+ #endif
+
+-#ifdef C_LINUX
++#if defined(C_LINUX) && defined(HAVE_LIBINTL_H)
+ #include <libintl.h>
+ #include <locale.h>
+