summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2009-05-04 11:45:40 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2009-05-04 11:45:40 +0000
commit4aefc8bf70e95d4cc2d9b6220283adef52457cf8 (patch)
tree468afea4fb0d0c4556d946dcf8795b855e0ba594
parent33dd383b5a1857bb49e9f31dbe32b82d0182f92e (diff)
downloadaports-4aefc8bf70e95d4cc2d9b6220283adef52457cf8.tar.bz2
aports-4aefc8bf70e95d4cc2d9b6220283adef52457cf8.tar.xz
extra/valgrind: fix some pax issues and turn off ssp
-rw-r--r--extra/valgrind/APKBUILD25
1 files changed, 22 insertions, 3 deletions
diff --git a/extra/valgrind/APKBUILD b/extra/valgrind/APKBUILD
index 7ac021de..dcba2983 100644
--- a/extra/valgrind/APKBUILD
+++ b/extra/valgrind/APKBUILD
@@ -1,13 +1,19 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=valgrind
pkgver=3.4.1
-pkgrel=0
+pkgrel=1
pkgdesc="A tool to help find memory-management problems in programs"
url="http://valgrind.org/"
license="GPL"
depends="uclibc"
# it seems like busybox sed works but the configure script requires GNU sed
-makedepends="sed"
+makedepends="sed paxctl pax-utils"
+# from README_PACKAGERS:
+# Don't strip the debug info off lib/valgrind/$platform/vgpreload*.so
+# in the installation tree. Either Valgrind won't work at all, or it
+# will still work if you do, but will generate less helpful error
+# messages.
+options="!strip"
subpackages="$pkgname-dev $pkgname-doc"
source="http://$pkgname.org/downloads/$pkgname-$pkgver.tar.bz2
$pkgname-3.4.0-uclibc.patch
@@ -22,14 +28,27 @@ build() {
done
# make sure our CFLAGS are respected
- sed -e 's:^CFLAGS="-Wno-long-long":CFLAGS="$CFLAGS -Wno-long-long":' \
+ sed -e 's:^CFLAGS="-Wno-long-long":CFLAGS="$CFLAGS -Wno-long-long -fno-stack-protector":' \
-i configure.in
+
./configure --prefix=/usr \
--without-mpicc \
--mandir=/usr/share/man || return 1
make || return 1
make DESTDIR="$pkgdir" install || return 1
+
+ # we have options=!strip above so we strip the /usr/bin/* manually
+ strip "$pkgdir"/usr/bin/valgrind \
+ "$pkgdir"/usr/bin/no_op_client_for_valgrind \
+ "$pkgdir"/usr/bin/valgrind-listener \
+ "$pkgdir"/usr/bin/cg_merge
+
+ # pax causes some issues
+ # http://marc.info/?l=gentoo-hardened&m=119512627126298&w=2
+ scanelf "$pkgdir"/usr/lib/valgrind/x86-linux \
+ | awk '$1 == "ET_EXEC" {print $2}' | xargs paxctl -c -m
+
}
md5sums="b5f039dd2271aaf9ae570ab4116f87c7 valgrind-3.4.1.tar.bz2