summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2009-08-08 21:21:05 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2009-08-08 21:21:05 +0000
commit40857ea123cfdfbe49d5555e1b617920f3fa08ca (patch)
tree22d8498d0976de671650ec560787e4914d37ce21
parentc6c87569d97ee9d047ba74746a809ca88919a3ff (diff)
downloadaports-40857ea123cfdfbe49d5555e1b617920f3fa08ca.tar.bz2
aports-40857ea123cfdfbe49d5555e1b617920f3fa08ca.tar.xz
x11/xorg-server: remove conflicting patch
-rw-r--r--x11/xorg-server/APKBUILD7
-rw-r--r--x11/xorg-server/server-1.6-branch.patch69
2 files changed, 2 insertions, 74 deletions
diff --git a/x11/xorg-server/APKBUILD b/x11/xorg-server/APKBUILD
index 1e8231ce..d4e424fd 100644
--- a/x11/xorg-server/APKBUILD
+++ b/x11/xorg-server/APKBUILD
@@ -57,7 +57,6 @@ makedepends="
# diffutils xf86-input-evdev"
source="http://xorg.freedesktop.org/releases/individual/xserver/$pkgname-$pkgver.tar.bz2
- server-1.6-branch.patch
xorg-redhat-die-ugly-pattern-die-die-die.patch
"
@@ -124,19 +123,17 @@ build () {
xfbdev() {
pkgdesc="X.org server for framebuffer"
- depends="libxfont libxau pixman libxdmcp openssl uclibc"
+ depends=
mkdir -p "$subpkgdir"/usr/bin
mv "$pkgdir"/usr/bin/Xfbdev "$subpkgdir"/usr/bin/
}
xephyr() {
pkgdesc="kdrive based X Server which targets a window on a host X Server as its framebuffer"
- depends="pixman openssl libx11 libxext libxfont libxau libxdmcp libxv
- uclibc"
+ depends=
mkdir -p "$subpkgdir"/usr/bin
mv "$pkgdir"/usr/bin/Xephyr "$subpkgdir"/usr/bin/
}
md5sums="0af168abeefa6579cab20387f75c0c7a xorg-server-1.6.3.tar.bz2
-811b6f4cda60ac5f94fd790415efb073 server-1.6-branch.patch
222de594206d1148a90eddfda4f7a11a xorg-redhat-die-ugly-pattern-die-die-die.patch"
diff --git a/x11/xorg-server/server-1.6-branch.patch b/x11/xorg-server/server-1.6-branch.patch
deleted file mode 100644
index 37cdfda3..00000000
--- a/x11/xorg-server/server-1.6-branch.patch
+++ /dev/null
@@ -1,69 +0,0 @@
-From 396d3a7762abd0dd84042833b75f2ebf9d100bb0 Mon Sep 17 00:00:00 2001
-From: Alan Coopersmith <alan.coopersmith@sun.com>
-Date: Wed, 08 Jul 2009 18:26:46 +0000
-Subject: Fix build of drivers with 1.6.2 when not using --install-libxf86config
-
-c859b736d1d23c5dc2f53958b1e76660e6d45018 removed duplicate entries for
-these from the Makefile, but removed a different set than was done in
-master branch, causing xf86Parser.h to not be installed, which in turn
-breaks the build of drivers like -ati, -intel & -nv that use xf86Modes.h,
-which includes xf86Parser.h
-
-Signed-off-by: Alan Coopersmith <alan.coopersmith@sun.com>
-Signed-off-by: Keith Packard <keithp@keithp.com>
----
-diff --git a/hw/xfree86/parser/Makefile.am b/hw/xfree86/parser/Makefile.am
-index 6ed1814..a2774a4 100644
---- a/hw/xfree86/parser/Makefile.am
-+++ b/hw/xfree86/parser/Makefile.am
-@@ -1,8 +1,5 @@
- if INSTALL_LIBXF86CONFIG
- lib_LIBRARIES = libxf86config.a
--LIBHEADERS = \
-- xf86Optrec.h \
-- xf86Parser.h
- else
- noinst_LIBRARIES = libxf86config.a
- endif
-@@ -30,9 +27,8 @@ AM_CFLAGS = $(DIX_CFLAGS) $(XORG_CFLAGS)
- EXTRA_DIST = \
- Configint.h \
- configProcs.h \
-- xf86Optrec.h \
-- xf86Parser.h \
- xf86tokens.h
-
- sdk_HEADERS = \
-- $(LIBHEADERS)
-+ xf86Optrec.h \
-+ xf86Parser.h
---
-cgit v0.8.2
-From 606f6dba16d42e3546a82a386d5a01087467b511 Mon Sep 17 00:00:00 2001
-From: Adam Jackson <ajax@redhat.com>
-Date: Tue, 14 Apr 2009 14:54:25 +0000
-Subject: xdmcp: Don't crash on X -query with more than 255 IP addresses. (#20675)
-
-You could be more clever than this, but the wire protocol says this
-really is an array of not more than 255 ARRAY8, so it's not just a
-matter of changing the types.
-
-(cherry picked from commit 0eb19f9437b7d8c19592e49eedb028771d300d80)
----
-diff --git a/os/xdmcp.c b/os/xdmcp.c
-index 736cd3e..746f598 100644
---- a/os/xdmcp.c
-+++ b/os/xdmcp.c
-@@ -491,7 +491,9 @@ XdmcpRegisterConnection (
- return;
- }
- }
-- newAddress = (CARD8 *) xalloc (addrlen * sizeof (CARD8));
-+ if (ConnectionAddresses.length + 1 == 256)
-+ return;
-+ newAddress = xalloc (addrlen * sizeof (CARD8));
- if (!newAddress)
- return;
- if (!XdmcpReallocARRAY16 (&ConnectionTypes, ConnectionTypes.length + 1))
---
-cgit v0.8.2