summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichael Mason <ms13sp@gmail.com>2009-08-12 15:30:11 +0000
committerMichael Mason <ms13sp@gmail.com>2009-08-12 15:30:11 +0000
commit2d3b01439a5ea74aace932209389083c0d75e0b3 (patch)
tree161945e428ea00e7d99b35e2d06fd233f3a0dcd4
parentaf3ae7782bd324af565f30f5fa058177d2bca932 (diff)
parentbe9bc29b4ec785ab1da8c53557802de550de2639 (diff)
downloadaports-2d3b01439a5ea74aace932209389083c0d75e0b3.tar.bz2
aports-2d3b01439a5ea74aace932209389083c0d75e0b3.tar.xz
Merge branch 'master' of git://git.alpinelinux.org/aports
-rw-r--r--main/acf-clamav/APKBUILD4
-rw-r--r--main/acf-postfix/APKBUILD4
-rw-r--r--main/gcc/APKBUILD4
-rw-r--r--main/gcc/gcc-spec-env.patch41
4 files changed, 48 insertions, 5 deletions
diff --git a/main/acf-clamav/APKBUILD b/main/acf-clamav/APKBUILD
index 511844df..d6ea8556 100644
--- a/main/acf-clamav/APKBUILD
+++ b/main/acf-clamav/APKBUILD
@@ -1,6 +1,6 @@
# Contributor: Michael Mason <ms13sp@gmail.com>
pkgname=acf-clamav
-pkgver=0.2.0
+pkgver=0.2.1
pkgrel=0
pkgdesc="A web-based system administration interface for clamav"
url="http://git.alpinelinux.org/cgit/acf-clamav"
@@ -18,4 +18,4 @@ build() {
}
-md5sums="a3da6fc06f95a947819e308f8092e77b acf-clamav-0.2.0.tar.bz2"
+md5sums="2e8286fedbd18029d4d55efdc5df6e25 acf-clamav-0.2.1.tar.bz2"
diff --git a/main/acf-postfix/APKBUILD b/main/acf-postfix/APKBUILD
index b525015e..f291ffd2 100644
--- a/main/acf-postfix/APKBUILD
+++ b/main/acf-postfix/APKBUILD
@@ -1,6 +1,6 @@
# Contributor: Michael Mason <ms13sp@gmail.com>
pkgname=acf-postfix
-pkgver=0.2.0
+pkgver=0.2.2
pkgrel=0
pkgdesc="A web-based system administration interface for postfix"
url="http://git.alpinelinux.org/cgit/acf-postfix"
@@ -18,4 +18,4 @@ build() {
}
-md5sums="7ac128ba01fcf58ed517cffad5caf8fe acf-postfix-0.2.0.tar.bz2"
+md5sums="f91c57c9da2b4671d03414c5385c7ad8 acf-postfix-0.2.2.tar.bz2"
diff --git a/main/gcc/APKBUILD b/main/gcc/APKBUILD
index 0dd1f35b..fff88ea0 100644
--- a/main/gcc/APKBUILD
+++ b/main/gcc/APKBUILD
@@ -3,7 +3,7 @@ pkgname=gcc
pkgver=4.4.1
_specsver=0.1.4
_espfver=0.3.1
-pkgrel=1
+pkgrel=2
pkgdesc="The GNU Compiler Collection"
url="http://gcc.gnu.org"
license="GPL LGPL"
@@ -14,6 +14,7 @@ source="ftp://gcc.gnu.org/pub/gcc/releases/gcc-$pkgver/gcc-core-$pkgver.tar.bz2
ftp://gcc.gnu.org/pub/gcc/releases/gcc-$pkgver/gcc-g++-$pkgver.tar.bz2
http://weaver.gentooenterprise.com/hardened/patches/gcc-$pkgver-espf-$_espfver.tar.bz2
http://weaver.gentooenterprise.com/hardened/patches/gcc-$pkgver-specs-$_specsver.tar.bz2
+ gcc-spec-env.patch
gcc4-stack-protector-uclibc-no_tls.patch
pt_gnu_eh_frame.patch
uclibc-getipinfo.patch
@@ -120,6 +121,7 @@ md5sums="d19693308aa6b2052e14c071111df59f gcc-core-4.4.1.tar.bz2
d449047b5761348ceec23739f5553e0b gcc-g++-4.4.1.tar.bz2
43d0bbd676bbb2acd67ddabd0ea1bc2b gcc-4.4.1-espf-0.3.1.tar.bz2
da8d9165e828bbb9809ef86f1c72886f gcc-4.4.1-specs-0.1.4.tar.bz2
+c4045bfa85d8be780affd465be9d8ca8 gcc-spec-env.patch
15e77082db0e1a131af98debd3016290 gcc4-stack-protector-uclibc-no_tls.patch
2db1e3482c5dd59dab70f701afa2ca80 pt_gnu_eh_frame.patch
6cc2385c5bbd6d0da6eaedd53c8bf547 uclibc-getipinfo.patch"
diff --git a/main/gcc/gcc-spec-env.patch b/main/gcc/gcc-spec-env.patch
new file mode 100644
index 00000000..9d5e666a
--- /dev/null
+++ b/main/gcc/gcc-spec-env.patch
@@ -0,0 +1,41 @@
+ Add support for external spec file via the GCC_SPECS env var. This
+ allows us to easily control pie/ssp defaults with gcc-config profiles.
+
+ Original patch by Rob Holland. Extended to support multiple
+ entries separated by ':' by Kevin F. Quinn
+
+--- gcc-4/gcc/gcc.c
++++ gcc-4/gcc/gcc.c
+@@ -6482,6 +6482,32 @@
+
+ /* Process any user specified specs in the order given on the command
+ line. */
++#if !(defined (__MSDOS__) || defined (OS2) || defined (VMS) || defined (WIN32))
++ /* Add specs listed in GCC_SPECS. Note; in the process of separating
++ * each spec listed, the string is overwritten at token boundaries
++ * (':') with '\0', an effect of strtok_r().
++ */
++ GET_ENVIRONMENT (specs_file, "GCC_SPECS");
++ if (specs_file && (strlen(specs_file) > 0))
++ {
++ char *spec, *saveptr;
++ for (spec=strtok_r(specs_file,":",&saveptr);
++ spec!=NULL;
++ spec=strtok_r(NULL,":",&saveptr))
++ {
++ struct user_specs *user = (struct user_specs *)
++ xmalloc (sizeof (struct user_specs));
++
++ user->next = (struct user_specs *) 0;
++ user->filename = spec;
++ if (user_specs_tail)
++ user_specs_tail->next = user;
++ else
++ user_specs_head = user;
++ user_specs_tail = user;
++ }
++ }
++#endif
+ for (uptr = user_specs_head; uptr; uptr = uptr->next)
+ {
+ char *filename = find_a_file (&startfile_prefixes, uptr->filename,