summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichael Mason <ms13sp@gmail.com>2009-08-05 21:14:26 +0000
committerMichael Mason <ms13sp@gmail.com>2009-08-05 21:14:26 +0000
commit4a96ec6eb104872db6ca8ce6240fccf272ea1181 (patch)
treedf6978f5e9f1f29a44d3b6d62d9014d5a95d856f
parentcc5c8f743b449e61fc7512d98c257d29b691c902 (diff)
parent14cf7d88ed87264d0679ef9f2a20d2984fd288d1 (diff)
downloadaports-4a96ec6eb104872db6ca8ce6240fccf272ea1181.tar.bz2
aports-4a96ec6eb104872db6ca8ce6240fccf272ea1181.tar.xz
Merge branch 'master' of git://git.alpinelinux.org/aports
-rw-r--r--main/acf-weblog/APKBUILD6
-rw-r--r--main/apk-tools/0001-db-fix-checksum-storing-to-db.patch73
-rw-r--r--main/apk-tools/0001-info-fix-a-exists-to-work-if-the-name-is-non-existan.patch26
-rw-r--r--main/apk-tools/0001-io-fix-corruption-of-big-files-on-mmap-write.patch76
-rw-r--r--main/apk-tools/APKBUILD7
-rw-r--r--main/mkinitfs/APKBUILD4
6 files changed, 36 insertions, 156 deletions
diff --git a/main/acf-weblog/APKBUILD b/main/acf-weblog/APKBUILD
index 15847a3f..aa56db98 100644
--- a/main/acf-weblog/APKBUILD
+++ b/main/acf-weblog/APKBUILD
@@ -1,8 +1,8 @@
# Contributor: Ted Trask <ttrask01@yahoo.com>
# Maintainer: Ted Trask <ttrask01@yahoo.com>
pkgname=acf-weblog
-pkgver=0.2.0
-pkgrel=1
+pkgver=0.3.0
+pkgrel=0
pkgdesc="ACF for web proxy (squid and dansguardian) logfiles"
url="http://git.alpinelinux.org/cgit/acf-weblog"
license="GPL-2"
@@ -17,4 +17,4 @@ build() {
make DESTDIR="$pkgdir" install
}
-md5sums="c3981ef8eca4684480d3df9474fc338b acf-weblog-0.2.0.tar.bz2"
+md5sums="d3f9d74ccd91e11feeaa2679ef355281 acf-weblog-0.3.0.tar.bz2"
diff --git a/main/apk-tools/0001-db-fix-checksum-storing-to-db.patch b/main/apk-tools/0001-db-fix-checksum-storing-to-db.patch
deleted file mode 100644
index c54fe73b..00000000
--- a/main/apk-tools/0001-db-fix-checksum-storing-to-db.patch
+++ /dev/null
@@ -1,73 +0,0 @@
-From c1fe6d08f3ba77bf13b098216fc5e5bcd4ba23f7 Mon Sep 17 00:00:00 2001
-From: Timo Teras <timo.teras@iki.fi>
-Date: Thu, 30 Jul 2009 11:55:59 +0300
-Subject: [PATCH] db: fix checksum storing to db
-
-also take precautions in audit code if the db is missing the
-checksum.
----
- src/audit.c | 7 +++----
- src/database.c | 8 ++++++--
- 2 files changed, 9 insertions(+), 6 deletions(-)
-
-diff --git a/src/audit.c b/src/audit.c
-index 31965df..76bd492 100644
---- a/src/audit.c
-+++ b/src/audit.c
-@@ -69,10 +69,9 @@ static int audit_directory(apk_hash_item item, void *ctx)
- } else {
- dbf = apk_db_file_query(db, bdir, APK_BLOB_STR(de->d_name));
- if (dbf != NULL) {
-- if (apk_file_get_info(tmp, dbf->csum.type, &fi) < 0)
-- continue;
--
-- if (apk_checksum_compare(&fi.csum, &dbf->csum) == 0)
-+ if (dbf->csum.type != APK_CHECKSUM_NONE &&
-+ apk_file_get_info(tmp, dbf->csum.type, &fi) == 0 &&
-+ apk_checksum_compare(&fi.csum, &dbf->csum) == 0)
- continue;
-
- reason = 'U';
-diff --git a/src/database.c b/src/database.c
-index 968d55e..16ae94b 100644
---- a/src/database.c
-+++ b/src/database.c
-@@ -1458,6 +1458,7 @@ static int apk_db_install_archive_entry(void *_ctx,
- diri->dir->name, file->name);
- r = apk_archive_entry_extract(ae, is, alt_name,
- extract_cb, ctx);
-+ memcpy(&file->csum, &ae->csum, sizeof(file->csum));
- } else {
- if (apk_verbosity >= 3)
- apk_message("%s", ae->name);
-@@ -1502,7 +1503,8 @@ static void apk_db_purge_pkg(struct apk_database *db, struct apk_package *pkg,
- hash = apk_blob_hash_seed(key.filename, diri->dir->hash);
- if (!(diri->dir->flags & APK_DBDIRF_PROTECTED) ||
- (apk_flags & APK_PURGE) ||
-- (apk_file_get_info(name, file->csum.type, &fi) == 0 &&
-+ (file->csum.type != APK_CHECKSUM_NONE &&
-+ apk_file_get_info(name, file->csum.type, &fi) == 0 &&
- apk_checksum_compare(&file->csum, &fi.csum) == 0))
- unlink(name);
- if (apk_verbosity >= 3)
-@@ -1565,6 +1567,7 @@ static void apk_db_migrate_files(struct apk_database *db,
- if ((diri->dir->flags & APK_DBDIRF_PROTECTED) &&
- (r == 0) &&
- (ofile == NULL ||
-+ ofile->csum.type == APK_CHECKSUM_NONE ||
- apk_checksum_compare(&ofile->csum, &fi.csum) != 0)) {
- /* Protected directory, with file without
- * db entry, or local modifications.
-@@ -1575,7 +1578,8 @@ static void apk_db_migrate_files(struct apk_database *db,
- ofile->csum.type != file->csum.type)
- apk_file_get_info(name, file->csum.type, &fi);
- if ((apk_flags & APK_CLEAN_PROTECTED) ||
-- apk_checksum_compare(&file->csum, &fi.csum) == 0)
-+ (file->csum.type != APK_CHECKSUM_NONE &&
-+ apk_checksum_compare(&file->csum, &fi.csum) == 0))
- unlink(tmpname);
- } else {
- /* Overwrite the old file */
---
-1.6.3.3
-
diff --git a/main/apk-tools/0001-info-fix-a-exists-to-work-if-the-name-is-non-existan.patch b/main/apk-tools/0001-info-fix-a-exists-to-work-if-the-name-is-non-existan.patch
new file mode 100644
index 00000000..f0f918a5
--- /dev/null
+++ b/main/apk-tools/0001-info-fix-a-exists-to-work-if-the-name-is-non-existan.patch
@@ -0,0 +1,26 @@
+From 2cfca5b6ed658433419f9b581b3ba30f34c973c4 Mon Sep 17 00:00:00 2001
+From: Timo Teras <timo.teras@iki.fi>
+Date: Wed, 5 Aug 2009 19:10:54 +0300
+Subject: [PATCH] info: fix a --exists to work if the name is non-existant
+
+---
+ src/info.c | 3 +++
+ 1 files changed, 3 insertions(+), 0 deletions(-)
+
+diff --git a/src/info.c b/src/info.c
+index a222b8c..073dc80 100644
+--- a/src/info.c
++++ b/src/info.c
+@@ -94,6 +94,9 @@ static int info_exists(struct info_ctx *ctx, struct apk_database *db,
+ continue;
+
+ name = dep.name;
++ if (name->pkgs == NULL)
++ continue;
++
+ for (j = 0; j < name->pkgs->num; j++) {
+ pkg = name->pkgs->item[j];
+ if (apk_pkg_get_state(pkg) == APK_PKG_INSTALLED)
+--
+1.6.3.3
+
diff --git a/main/apk-tools/0001-io-fix-corruption-of-big-files-on-mmap-write.patch b/main/apk-tools/0001-io-fix-corruption-of-big-files-on-mmap-write.patch
deleted file mode 100644
index 4261ce52..00000000
--- a/main/apk-tools/0001-io-fix-corruption-of-big-files-on-mmap-write.patch
+++ /dev/null
@@ -1,76 +0,0 @@
-From 67108bf07a67811ea91fc965f3f1592a4a70044e Mon Sep 17 00:00:00 2001
-From: Timo Teras <timo.teras@iki.fi>
-Date: Fri, 31 Jul 2009 10:50:15 +0300
-Subject: [PATCH] io: fix corruption of big files on mmap write
-
-remember to increment destination pointer; and munmap the proper
-base address.
----
- src/io.c | 27 +++++++++++++--------------
- 1 files changed, 13 insertions(+), 14 deletions(-)
-
-diff --git a/src/io.c b/src/io.c
-index 18e89d3..3929ba1 100644
---- a/src/io.c
-+++ b/src/io.c
-@@ -114,21 +114,19 @@ size_t apk_istream_splice(void *stream, int fd, size_t size,
- {
- static void *splice_buffer = NULL;
- struct apk_istream *is = (struct apk_istream *) stream;
-- unsigned char *buf = MAP_FAILED;
-- size_t bufsz, done = 0, r, togo, mmapped = 0;
-+ unsigned char *buf, *mmapbase = MAP_FAILED;
-+ size_t bufsz, done = 0, r, togo;
-
- bufsz = size;
- if (size > 128 * 1024) {
- if (ftruncate(fd, size) == 0)
-- buf = mmap(NULL, size, PROT_READ | PROT_WRITE,
-- MAP_SHARED, fd, 0);
-- if (buf != MAP_FAILED) {
-- mmapped = 1;
-- if (bufsz > 2*1024*1024)
-- bufsz = 2*1024*1024;
-- }
-+ mmapbase = mmap(NULL, size, PROT_READ | PROT_WRITE,
-+ MAP_SHARED, fd, 0);
-+ if (bufsz > 2*1024*1024)
-+ bufsz = 2*1024*1024;
-+ buf = mmapbase;
- }
-- if (!mmapped) {
-+ if (mmapbase == MAP_FAILED) {
- if (splice_buffer == NULL)
- splice_buffer = malloc(256*1024);
- buf = splice_buffer;
-@@ -149,13 +147,14 @@ size_t apk_istream_splice(void *stream, int fd, size_t size,
- if (r < 0)
- goto err;
-
-- if (!mmapped) {
-+ if (mmapbase == MAP_FAILED) {
- if (write(fd, buf, r) != r) {
- if (r < 0)
- r = -errno;
- goto err;
- }
-- }
-+ } else
-+ buf += r;
-
- done += r;
- if (r != togo)
-@@ -163,8 +162,8 @@ size_t apk_istream_splice(void *stream, int fd, size_t size,
- }
- r = done;
- err:
-- if (mmapped)
-- munmap(buf, size);
-+ if (mmapbase != MAP_FAILED)
-+ munmap(mmapbase, size);
- return r;
- }
-
---
-1.6.3.3
-
diff --git a/main/apk-tools/APKBUILD b/main/apk-tools/APKBUILD
index 2f0b37e3..215e7d04 100644
--- a/main/apk-tools/APKBUILD
+++ b/main/apk-tools/APKBUILD
@@ -1,12 +1,13 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=apk-tools
pkgver=2.0_rc1
-pkgrel=0
+pkgrel=1
pkgdesc="Alpine Package Keeper - package manager for alpine"
subpackages="$pkgname-static"
depends=
makedepends="zlib-dev openssl-dev pkgconfig"
source="http://git.alpinelinux.org/cgit/$pkgname/snapshot/$pkgname-$pkgver.tar.bz2
+ 0001-info-fix-a-exists-to-work-if-the-name-is-non-existan.patch
"
@@ -16,6 +17,7 @@ license=GPL-2
build() {
cd "$srcdir/$pkgname-$pkgver"
sed -i -e 's:-Werror::' Make.rules
+ patch -p1 -i ../0001-info-fix-a-exists-to-work-if-the-name-is-non-existan.patch || return 1
make || return 1
make static || return 1
@@ -35,4 +37,5 @@ static() {
"$subpkgdir"/sbin/apk.static
}
-md5sums="f790182792a41841e6932ae0b6737a43 apk-tools-2.0_rc1.tar.bz2"
+md5sums="f790182792a41841e6932ae0b6737a43 apk-tools-2.0_rc1.tar.bz2
+87dd230bf89f429db06dcad96be235c0 0001-info-fix-a-exists-to-work-if-the-name-is-non-existan.patch"
diff --git a/main/mkinitfs/APKBUILD b/main/mkinitfs/APKBUILD
index 6cd2f734..8f13f65f 100644
--- a/main/mkinitfs/APKBUILD
+++ b/main/mkinitfs/APKBUILD
@@ -1,6 +1,6 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=mkinitfs
-pkgver=1.9
+pkgver=2.0_rc1
pkgrel=0
pkgdesc="Tool to generate initramfs images for Alpine"
url=http://git.alpinelinux.org/cgit/mkinitfs
@@ -13,4 +13,4 @@ build() {
make
make install DESTDIR="$pkgdir" || return 1
}
-md5sums="73d4b39bb7d7ad61c609d1fb295897a3 mkinitfs-1.9.tar.bz2"
+md5sums="4c8ae5a6cdeae50ddb36a8e3d3268eb2 mkinitfs-2.0_rc1.tar.bz2"