summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichael Mason <ms13sp@gmail.com>2009-08-14 22:57:19 +0000
committerMichael Mason <ms13sp@gmail.com>2009-08-14 22:57:19 +0000
commit8bae20460e6983832a37ecd505a1900eaf04f9e6 (patch)
treea6f944f56704935012ac4b34faf2aa1e5a5c9ef9
parent4d39245069988f101d5c2d3a74d4eeccfdeef6b1 (diff)
parente64df37ddfc025e7437485894b812dcffc3b087d (diff)
downloadaports-8bae20460e6983832a37ecd505a1900eaf04f9e6.tar.bz2
aports-8bae20460e6983832a37ecd505a1900eaf04f9e6.tar.xz
Merge branch 'master' of git://git.alpinelinux.org/aports
-rw-r--r--main/abuild/APKBUILD4
-rw-r--r--main/acf-apk-tools/APKBUILD4
-rw-r--r--main/apk-tools/APKBUILD4
-rw-r--r--main/dahdi-linux-grsec/APKBUILD2
-rw-r--r--main/iscsitarget-grsec/APKBUILD2
-rw-r--r--main/linux-grsec/APKBUILD6
-rw-r--r--main/linux-grsec/grsecurity-2.1.14-2.6.30.4-200908132040.patch (renamed from main/linux-grsec/grsecurity-2.1.14-2.6.30.4-200908122115.patch)11
-rw-r--r--main/xtables-addons-grsec/APKBUILD2
8 files changed, 22 insertions, 13 deletions
diff --git a/main/abuild/APKBUILD b/main/abuild/APKBUILD
index ed7d565b..a17597b1 100644
--- a/main/abuild/APKBUILD
+++ b/main/abuild/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgdesc="Script to build Alpine Packages"
pkgname=abuild
-pkgver=2.0_rc5
+pkgver=2.0_rc6
pkgrel=0
url=http://git.alpinelinux.org/cgit/abuild/
source="http://git.alpinelinux.org/cgit/abuild/snapshot/abuild-$pkgver.tar.bz2
@@ -17,4 +17,4 @@ build() {
install -m 644 abuild.conf "$pkgdir"/etc/abuild.conf
}
-md5sums="076ae05f85ab9d90519f38f8747e1c4e abuild-2.0_rc5.tar.bz2"
+md5sums="6e3332501deab8d0b71a66822aebb77a abuild-2.0_rc6.tar.bz2"
diff --git a/main/acf-apk-tools/APKBUILD b/main/acf-apk-tools/APKBUILD
index fed19c23..830d3242 100644
--- a/main/acf-apk-tools/APKBUILD
+++ b/main/acf-apk-tools/APKBUILD
@@ -1,11 +1,11 @@
# Contributor: Mika Havela <mika.havela@gmail.com>
pkgname=acf-apk-tools
pkgver=0.3.1
-pkgrel=0
+pkgrel=1
pkgdesc="ACF module for apk"
url="http://git.alpinelinux.org/cgit/acf-apk-tools"
license="GPL-2"
-depends="acf-core lua luaposix"
+depends="acf-core lua luaposix apk-tools"
source="http://git.alpinelinux.org/cgit/$pkgname/snapshot/$pkgname-$pkgver.tar.bz2"
build() {
diff --git a/main/apk-tools/APKBUILD b/main/apk-tools/APKBUILD
index ae79f7d1..ea77fa68 100644
--- a/main/apk-tools/APKBUILD
+++ b/main/apk-tools/APKBUILD
@@ -1,6 +1,6 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=apk-tools
-pkgver=2.0_rc2
+pkgver=2.0_rc3
pkgrel=0
pkgdesc="Alpine Package Keeper - package manager for alpine"
subpackages="$pkgname-static"
@@ -35,4 +35,4 @@ static() {
"$subpkgdir"/sbin/apk.static
}
-md5sums="373aab12797f9fc9e80d5365cd794c9d apk-tools-2.0_rc2.tar.bz2"
+md5sums="64cc6fac209ad85b1dade7f796d8f842 apk-tools-2.0_rc3.tar.bz2"
diff --git a/main/dahdi-linux-grsec/APKBUILD b/main/dahdi-linux-grsec/APKBUILD
index cb2e3a73..50077f8f 100644
--- a/main/dahdi-linux-grsec/APKBUILD
+++ b/main/dahdi-linux-grsec/APKBUILD
@@ -14,7 +14,7 @@ _realname=dahdi-linux
pkgname=${_realname}-${_flavor}
pkgver=2.2.0
-pkgrel=6
+pkgrel=7
pkgdesc="Digium Asterisk Hardware Device Interface drivers"
url="http://www.asterisk.org"
license="GPL"
diff --git a/main/iscsitarget-grsec/APKBUILD b/main/iscsitarget-grsec/APKBUILD
index 8a1dec1c..19ee8afb 100644
--- a/main/iscsitarget-grsec/APKBUILD
+++ b/main/iscsitarget-grsec/APKBUILD
@@ -15,7 +15,7 @@ if [ -f ../iscsitarget/APKBUILD ]; then
fi
pkgname=${_realname}-${_flavor}
pkgver=${pkgver:-0.4.17}
-pkgrel=6
+pkgrel=7
pkgdesc="$_flavor kernel modules for iscsitarget"
url="http://iscsitarget.sourceforge.net/"
license="GPL-2"
diff --git a/main/linux-grsec/APKBUILD b/main/linux-grsec/APKBUILD
index 6d88c138..44122ce9 100644
--- a/main/linux-grsec/APKBUILD
+++ b/main/linux-grsec/APKBUILD
@@ -4,7 +4,7 @@ _flavor=grsec
pkgname=linux-${_flavor}
pkgver=2.6.30.4
_kernver=2.6.30
-pkgrel=4
+pkgrel=5
pkgdesc="Linux kernel with grsecurity"
url=http://grsecurity.net
depends="mkinitfs"
@@ -13,7 +13,7 @@ _config=${config:-kernelconfig}
install="$pkgname.post-install $pkgname.post-upgrade"
source="ftp://ftp.kernel.org/pub/linux/kernel/v2.6/linux-$_kernver.tar.bz2
ftp://ftp.kernel.org/pub/linux/kernel/v2.6/patch-$pkgver.bz2
- grsecurity-2.1.14-2.6.30.4-200908122115.patch
+ grsecurity-2.1.14-2.6.30.4-200908132040.patch
linux-nbma-mroute-v4-2.6.30.diff
net-next-2.6.git-5ef12d98a19254ee5dc851bd83e214b43ec1f725.patch
$_config
@@ -113,7 +113,7 @@ dev() {
md5sums="7a80058a6382e5108cdb5554d1609615 linux-2.6.30.tar.bz2
d0fc44b54ba5953140b3f2aa9a1f2580 patch-2.6.30.4.bz2
-8b90a9def6800972fd09685bb73c5945 grsecurity-2.1.14-2.6.30.4-200908122115.patch
+624831f0d2b2caeb2b4756a5b6290c7d grsecurity-2.1.14-2.6.30.4-200908132040.patch
7420c0b1095335990313656b114e1379 linux-nbma-mroute-v4-2.6.30.diff
ca05fd252783b82e01610e775cf56498 net-next-2.6.git-5ef12d98a19254ee5dc851bd83e214b43ec1f725.patch
60adb085be0ab268c0f27279ae2b2bab kernelconfig
diff --git a/main/linux-grsec/grsecurity-2.1.14-2.6.30.4-200908122115.patch b/main/linux-grsec/grsecurity-2.1.14-2.6.30.4-200908132040.patch
index 6f697a13..71f75d54 100644
--- a/main/linux-grsec/grsecurity-2.1.14-2.6.30.4-200908122115.patch
+++ b/main/linux-grsec/grsecurity-2.1.14-2.6.30.4-200908132040.patch
@@ -43653,7 +43653,7 @@ diff -urNp linux-2.6.30.4/net/sctp/socket.c linux-2.6.30.4/net/sctp/socket.c
if (pp->fastreuse && sk->sk_reuse &&
diff -urNp linux-2.6.30.4/net/socket.c linux-2.6.30.4/net/socket.c
--- linux-2.6.30.4/net/socket.c 2009-07-24 17:47:51.000000000 -0400
-+++ linux-2.6.30.4/net/socket.c 2009-07-30 11:29:24.032618401 -0400
++++ linux-2.6.30.4/net/socket.c 2009-08-13 20:40:32.961482335 -0400
@@ -86,6 +86,7 @@
#include <linux/audit.h>
#include <linux/wireless.h>
@@ -43702,6 +43702,15 @@ diff -urNp linux-2.6.30.4/net/socket.c linux-2.6.30.4/net/socket.c
static struct file_system_type sock_fs_type = {
.name = "sockfs",
+@@ -736,7 +752,7 @@ static ssize_t sock_sendpage(struct file
+ if (more)
+ flags |= MSG_MORE;
+
+- return sock->ops->sendpage(sock, page, offset, size, flags);
++ return kernel_sendpage(sock, page, offset, size, flags);
+ }
+
+ static ssize_t sock_splice_read(struct file *file, loff_t *ppos,
@@ -1283,6 +1299,16 @@ SYSCALL_DEFINE3(socket, int, family, int
if (SOCK_NONBLOCK != O_NONBLOCK && (flags & SOCK_NONBLOCK))
flags = (flags & ~SOCK_NONBLOCK) | O_NONBLOCK;
diff --git a/main/xtables-addons-grsec/APKBUILD b/main/xtables-addons-grsec/APKBUILD
index ed1c0907..f73f1e16 100644
--- a/main/xtables-addons-grsec/APKBUILD
+++ b/main/xtables-addons-grsec/APKBUILD
@@ -16,7 +16,7 @@ fi
pkgname=${_realname}-${_flavor}
pkgver=${pkgver:-1.17}
-pkgrel=3
+pkgrel=5
pkgdesc="Iptables extensions kernel modules"
url="http://xtables-addons.sourceforge.net/"
license="GPL"