summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2009-09-02 11:02:24 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2009-09-02 11:02:24 +0000
commit1ffa728e33f190c047b2addf0125d767d12116a1 (patch)
tree9bfacb29ce30a871474363ad50310e853e5e2bb2
parent37b50f0696fc92153bbe0286be1aa1f55ac8bbb2 (diff)
downloadaports-1ffa728e33f190c047b2addf0125d767d12116a1.tar.bz2
aports-1ffa728e33f190c047b2addf0125d767d12116a1.tar.xz
main/libdnet: new aport
A simplified, portable interface to several low-level networking routines http://code.google.com/p/libdnet/ needed by arpon
-rw-r--r--main/libdnet/APKBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/main/libdnet/APKBUILD b/main/libdnet/APKBUILD
new file mode 100644
index 00000000..8544bb90
--- /dev/null
+++ b/main/libdnet/APKBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=libdnet
+pkgver=1.12
+pkgdesc="A simplified, portable interface to several low-level networking routines"
+url="http://code.google.com/p/libdnet/"
+license="BSD"
+subpackages="$pkgname-dev $pkgname-doc"
+depends=""
+makedepends="autoconf automake libtool"
+install=
+source="http://$pkgname.googlecode.com/files/$pkgname-$pkgver.tgz"
+
+build ()
+{
+ cd "$srcdir"/$pkgname-$pkgver
+ # the libtool script does not add .so extention to we generate
+ # new libtool
+ aclocal -I config && autoconf && automake && libtoolize || return 1
+
+ ./configure --prefix=/usr \
+ --mandir=/usr/share/man \
+ --without-python
+
+ make || return 1
+ make DESTDIR="$pkgdir" install || return 1
+}
+md5sums="9253ef6de1b5e28e9c9a62b882e44cc9 libdnet-1.12.tgz"