summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2009-08-31 14:52:24 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2009-08-31 14:52:24 +0000
commita3f0ff4f276fa14faa6279856c48088be38a2d83 (patch)
treec40d9f2daeb19a5883e0aed3e283c894974545c5
parenta9383e9f5bdfcdf218295d4686645ffb14eb5aa4 (diff)
parent13ae9f727c9fc34cb809b7c622f4dd6d83239425 (diff)
downloadaports-a3f0ff4f276fa14faa6279856c48088be38a2d83.tar.bz2
aports-a3f0ff4f276fa14faa6279856c48088be38a2d83.tar.xz
Merge commit 'remotes/larena/master'
-rw-r--r--main/perl-error/APKBUILD26
-rw-r--r--main/perl-io-multiplex/APKBUILD26
-rw-r--r--main/perl/APKBUILD7
-rw-r--r--main/postgrey/APKBUILD30
-rw-r--r--main/postgrey/postgrey.conf55
-rw-r--r--main/postgrey/postgrey.init101
-rwxr-xr-xmain/postgrey/postgrey.pre-install2
7 files changed, 243 insertions, 4 deletions
diff --git a/main/perl-error/APKBUILD b/main/perl-error/APKBUILD
new file mode 100644
index 00000000..f0926e0b
--- /dev/null
+++ b/main/perl-error/APKBUILD
@@ -0,0 +1,26 @@
+# Contributor: Leonardo Arena <rnalrd@gmail.com>
+# Maintainer: Leonardo Arena <rnalrd@gmail.com>
+pkgname=perl-error
+_realname=Error
+pkgver=0.17015
+pkgrel=0
+pkgdesc="Perl module error/exception handling in an OO-ish way"
+url="http://search.cpan.org/~shlomif/Error-$pkgver/"
+license="GPL PerlArtistic"
+depends="perl"
+makedepends="perl-dev"
+install=
+subpackages="$pkgname-doc"
+source="http://search.cpan.org/CPAN/authors/id/S/SH/SHLOMIF/$_realname-$pkgver.tar.gz"
+
+build() {
+ cd "$srcdir/$_realname-$pkgver"
+
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor || return 1
+ make || return 1
+ make DESTDIR="$pkgdir" install
+ # creates file collision among perl modules
+ find "$pkgdir" -name perllocal.pod -delete
+}
+
+md5sums="203bc410ae5040e7b647a52aa0fabafe Error-0.17015.tar.gz"
diff --git a/main/perl-io-multiplex/APKBUILD b/main/perl-io-multiplex/APKBUILD
new file mode 100644
index 00000000..9fd2aab1
--- /dev/null
+++ b/main/perl-io-multiplex/APKBUILD
@@ -0,0 +1,26 @@
+# Contributor: Leonardo Arena <rnalrd@gmail.com>
+# Maintainer: Leonardo Arena <rnalrd@gmail.com>
+pkgname=perl-io-multiplex
+_realname=IO-Multiplex
+pkgver=1.10
+pkgrel=0
+pkgdesc="Perl module to manage IO on many file handles"
+url="http://search.cpan.org/~bbb/IO-Multiplex-1.10/"
+license="unknown"
+depends="perl"
+makedepends="perl-dev"
+install=
+subpackages="$pkgname-doc"
+source="http://search.cpan.org/CPAN/authors/id/B/BB/BBB/$_realname-$pkgver.tar.gz"
+
+build() {
+ cd "$srcdir/$_realname-$pkgver"
+
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor || return 1
+ make || return 1
+ make DESTDIR="$pkgdir" install
+ # creates file collision among perl modules
+ find "$pkgdir" -name perllocal.pod -delete
+}
+
+md5sums="ce230ee0a4afbff59da66f0c42e0340b IO-Multiplex-1.10.tar.gz"
diff --git a/main/perl/APKBUILD b/main/perl/APKBUILD
index fec034e5..016a526a 100644
--- a/main/perl/APKBUILD
+++ b/main/perl/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=perl
-pkgver=5.10.0
-pkgrel=1
+pkgver=5.10.1
+pkgrel=0
pkgdesc="Larry Wall's Practical Extraction and Report Language"
url=http://www.perl.org
license="Artistic GPL-2"
@@ -51,5 +51,4 @@ miniperl() {
cp "$srcdir/perl-$pkgver"/miniperl "$subpkgdir/usr/bin"
}
-md5sums="872c3b9f1238c06766733f42087aea24 perl-5.10.0.tar.gz"
-md5sums="d2c39b002ebfd2c3c5dba589365c5a71 perl-5.10.0.tar.gz"
+md5sums="b9b2fdb957f50ada62d73f43ee75d044 perl-5.10.1.tar.gz"
diff --git a/main/postgrey/APKBUILD b/main/postgrey/APKBUILD
new file mode 100644
index 00000000..b7ce04f1
--- /dev/null
+++ b/main/postgrey/APKBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Leonardo Arena <rnalrg@gmail.com>
+pkgname=postgrey
+pkgver=1.32
+pkgrel=0
+pkgdesc="Postfix Greylisting Policy Server"
+url="http://postgrey.schweikert.ch/"
+license="GPL-2"
+depends="perl-net-server perl-io-multiplex perl-db postfix"
+makedepends=""
+install="$pkgname.pre-install"
+subpackages="$pkgname-doc"
+source="http://postgrey.schweikert.ch/pub/$pkgname-$pkgver.tar.gz"
+
+build() {
+ cd "$srcdir"/$pkgname-$pkgver
+ mkdir -p -m0770 $pkgdir/var/spool/postfix/postgrey
+ chown postgrey.postgrey $pkgdir/var/spool/postfix/postgrey
+ install -m755 -D postgrey $pkgdir/usr/sbin/postgrey
+ install -m755 -D policy-test $pkgdir/usr/bin/policy-test
+ install -m755 -D contrib/postgreyreport $pkgdir/usr/bin/postgreyreport
+ install -m644 -D postgrey_whitelist_recipients $pkgdir/etc/postfix/postgrey_whitelist_recipients
+ install -m644 -D postgrey_whitelist_clients $pkgdir/etc/postfix/postgrey_whitelist_clients
+ install -m644 -D README $pkgdir/usr/share/doc/$pkgname/README
+ install -m644 -D Changes $pkgdir/usr/share/doc/$pkgname/Changes
+ install -m644 -D COPYING $pkgdir/usr/share/doc/$pkgname/COPYING
+ install -m755 -D ../../postgrey.init $pkgdir/etc/init.d/postgrey
+ install -m644 -D ../../postgrey.conf $pkgdir/etc/conf.d/postgrey
+}
+
+md5sums="524a4e165bf997996f3bccade394712f postgrey-1.32.tar.gz"
diff --git a/main/postgrey/postgrey.conf b/main/postgrey/postgrey.conf
new file mode 100644
index 00000000..0baa871a
--- /dev/null
+++ b/main/postgrey/postgrey.conf
@@ -0,0 +1,55 @@
+# Config file for /etc/init.d/postgrey
+
+# LISTEN TYPE
+# Set to 'inet' if you want to use a TCP socket.
+# Set to 'unix' if you want to use an UNIX socket.
+POSTGREY_TYPE="inet"
+
+# HOST
+# What IP should postgrey bind to?
+# Leave unchanged unless you know what you are doing.
+# (ignored if POSTGREY_TYPE is set to 'unix')
+POSTGREY_HOST="127.0.0.1"
+
+# PORT
+# What TCP port should postgrey listen on?
+# (ignored if POSTGREY_TYPE is set to 'unix')
+POSTGREY_PORT="10030"
+
+# SOCKET
+# Unix socket to listen on, if POSTGREY_TYPE is set to 'unix'.
+# Leave unchanged unless you know what you are doing.
+# (ignored if POSTGREY_TYPE is set to 'inet')
+POSTGREY_SOCKET="/var/spool/postfix/private/postgrey"
+
+# PID
+# Postgrey pid file.
+# Do not change, if you don't know what this is!
+POSTGREY_PID="/var/run/postgrey.pid"
+
+# DELAY
+# How long to delay mail that is greylisted in seconds.
+POSTGREY_DELAY=60
+
+# TEXT
+# The response we'll send back with delayed mail.
+POSTGREY_TEXT="Greylisted for %s seconds"
+
+# Additional Postgrey options
+#
+# -v, --verbose increase verbosity level
+# --max-age=N delete entries older than N days since the last time
+# that they have been seen (default: 30)
+# --retry-window=N allow only N days for the first retrial (default: 2)
+# append 'h' if you want to specify it in hours
+# --greylist-action=A if greylisted, return A to Postfix (default: DEFER_IF_PERMIT)
+# --lookup-by-subnet strip the last 8 bits from IP addresses (default)
+# --lookup-by-host do not strip the last 8 bits from IP addresses
+# --whitelist-clients=FILE default: /etc/postfix/postgrey_whitelist_clients
+# --whitelist-recipients=FILE default: /etc/postfix/postgrey_whitelist_recipients
+#
+# Note that the --whitelist-x options can be specified multiple times, and that
+# per default /etc/postfix/postgrey_whitelist_clients.local is also read, so
+# that you can put there local entries.
+#
+POSTGREY_OPTS=""
diff --git a/main/postgrey/postgrey.init b/main/postgrey/postgrey.init
new file mode 100644
index 00000000..d38538de
--- /dev/null
+++ b/main/postgrey/postgrey.init
@@ -0,0 +1,101 @@
+#!/sbin/runscript
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/www/viewcvs.gentoo.org/raw_cvs/gentoo-x86/mail-filter/postgrey/files/postgrey.rc.new,v 1.10 2008/05/21 18:45:44 dertobi123 Exp $
+
+conf="/etc/conf.d/postgrey"
+
+opts="${opts} reload"
+
+depend() {
+ need net
+ before postfix
+ provide postfix_greylist
+}
+
+conf_error() {
+ eerror "You need to setup ${conf} first"
+ return 1
+}
+
+checkconfig() {
+if [ -z "${POSTGREY_TYPE}" ]
+ then
+ einfo "You need to choose the server type you want"
+ einfo "by setting the POSTGREY_TYPE variable in ${conf}."
+ else
+ if [ "x${POSTGREY_TYPE}" = "xinet" ]
+ then
+ if [ -z "${POSTGREY_PORT}" ] || [ -z "${POSTGREY_HOST}" ]
+ then
+ einfo "The following entries are missing in ${conf}:"
+ [ -z "${POSTGREY_HOST}" ] && einfo " - POSTGREY_HOST"
+ [ -z "${POSTGREY_PORT}" ] && einfo " - POSTGREY_PORT"
+ conf_error
+ fi
+ POSTGREY_ADDR="${POSTGREY_TYPE}=${POSTGREY_HOST}:${POSTGREY_PORT}"
+ else
+ if [ -z "${POSTGREY_SOCKET}" ]
+ then
+ einfo "The following entries are missing in ${conf}:"
+ [ -z "${POSTGREY_SOCKET}" ] && einfo " - POSTGREY_SOCKET"
+ conf_error
+ fi
+ POSTGREY_ADDR="${POSTGREY_TYPE}=${POSTGREY_SOCKET}"
+ fi
+fi
+
+ if [ -z "${POSTGREY_PID}" ]
+ then
+ einfo "The following entries are missing in ${conf}:"
+ [ -z "${POSTGREY_PID}" ] && einfo " - POSTGREY_PID"
+ conf_error
+ fi
+}
+
+start() {
+ checkconfig || return 1
+ ebegin "Starting Postgrey"
+
+ # HACK -- start a subshell and corrects perms on the socket...
+ ( if [ "x${POSTGREY_TYPE}" = "xunix" ]; then
+ rm -f ${POSTGREY_SOCKET};
+ while ! test -S ${POSTGREY_SOCKET}; do sleep 1; done;
+ chmod a+rw,a-x ${POSTGREY_SOCKET}; fi ) &
+
+ if [ -z ${POSTGREY_DELAY} ] ; then
+ POSTGREY_DELAY_ARG=""
+ else
+ POSTGREY_DELAY_ARG="--delay=${POSTGREY_DELAY}"
+ fi
+
+ if [ -z "${POSTGREY_TEXT}" ] ; then
+ POSTGREY_TEXT_ARG=""
+ else
+ POSTGREY_TEXT_ARG="--greylist-text=${POSTGREY_TEXT}"
+ fi
+
+ start-stop-daemon --start --quiet --background \
+ --pidfile=${POSTGREY_PID} \
+ --name postgrey \
+ --exec /usr/sbin/postgrey -- \
+ --${POSTGREY_ADDR} \
+ --daemonize \
+ --pidfile=${POSTGREY_PID} \
+ ${POSTGREY_DELAY_ARG} \
+ ${POSTGREY_OPTS} \
+ "${POSTGREY_TEXT_ARG}"
+ eend ${?}
+}
+
+stop() {
+ ebegin "Stopping Postgrey"
+ start-stop-daemon --stop --quiet --pidfile ${POSTGREY_PID}
+ eend ${?}
+}
+
+reload() {
+ ebegin "Reloading Postgrey"
+ start-stop-daemon --stop --signal HUP --oknodo --pidfile ${POSTGREY_PID}
+ eend $?
+}
diff --git a/main/postgrey/postgrey.pre-install b/main/postgrey/postgrey.pre-install
new file mode 100755
index 00000000..e37a27f7
--- /dev/null
+++ b/main/postgrey/postgrey.pre-install
@@ -0,0 +1,2 @@
+#!/bin/sh
+adduser -h /var/spool/postfix/postgrey -g postgrey -s /bin/false -D postgrey &>/dev/null