summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2009-08-22 15:55:50 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2009-08-22 15:55:50 +0000
commitdf681663e7f6d9dc1b00d1b1383f56c154b556ba (patch)
treef39f5f25a08bef6cf3ec59e9e6204a20391276e5
parent5de10ff30d14ebef3b3db84b93bedc19cae3ea45 (diff)
downloadaports-df681663e7f6d9dc1b00d1b1383f56c154b556ba.tar.bz2
aports-df681663e7f6d9dc1b00d1b1383f56c154b556ba.tar.xz
main/lame: new aport
An MP3 encoder and graphical frame analyzer http://lame.sourceforge.net/
-rw-r--r--main/lame/APKBUILD40
-rw-r--r--main/lame/lame-3.98.2-ffmpeg-0.5.patch86
2 files changed, 126 insertions, 0 deletions
diff --git a/main/lame/APKBUILD b/main/lame/APKBUILD
new file mode 100644
index 00000000..d51994e5
--- /dev/null
+++ b/main/lame/APKBUILD
@@ -0,0 +1,40 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=lame
+pkgver=3.98.2
+pkgrel=0
+pkgdesc="An MP3 encoder and graphical frame analyzer"
+url="http://lame.sourceforge.net/"
+license="LGPL"
+subpackages="$pkgname-dev $pkgname-doc"
+depends=
+makedepends="nasm ncurses-dev autoconf automake libtool"
+source="http://downloads.sourceforge.net/sourceforge/$pkgname/$pkgname-398-2.tar.gz
+ lame-3.98.2-ffmpeg-0.5.patch"
+
+build ()
+{
+ cd "$srcdir"/$pkgname-398-2
+
+ # link fronted shared
+ sed -i -e 's/\(^LDFLAGS.*\)-static/\1/g' frontend/Makefile.am
+
+ # fix for parallel builds
+ mkdir -p libmp3lame/i386/.libs
+
+ # Fix for ffmpeg.
+ # https://bugs.gentoo.org/show_bug.cgi?id=265830
+ patch -p1 < ../lame-3.98.2-ffmpeg-0.5.patch || return 1
+
+ aclocal && automake || return 1
+
+ ./configure --prefix=/usr \
+ --enable-nasm \
+ --disable-mp3x \
+ --enable-shared
+
+ make || return 1
+ make DESTDIR="$pkgdir" install
+}
+
+md5sums="719dae0ee675d0c16e0e89952930ed35 lame-398-2.tar.gz
+e84a65409b0512045edd147524ba3ad4 lame-3.98.2-ffmpeg-0.5.patch"
diff --git a/main/lame/lame-3.98.2-ffmpeg-0.5.patch b/main/lame/lame-3.98.2-ffmpeg-0.5.patch
new file mode 100644
index 00000000..30528c7d
--- /dev/null
+++ b/main/lame/lame-3.98.2-ffmpeg-0.5.patch
@@ -0,0 +1,86 @@
+diff -NrU5 lame-398-2.orig/libmp3lame/lame.c lame-398-2/libmp3lame/lame.c
+--- lame-398-2.orig/libmp3lame/lame.c 2009-05-03 15:16:40.000000000 +0200
++++ lame-398-2/libmp3lame/lame.c 2009-05-03 15:24:49.000000000 +0200
+@@ -1600,10 +1600,17 @@
+ in_buffer[1] += n_in;
+
+ /* update mfbuf[] counters */
+ gfc->mf_size += n_out;
+ assert(gfc->mf_size <= MFSIZE);
++
++ /* lame_encode_flush may have set gfc->mf_sample_to_encode to 0
++ * so we have to reinitialize it here when that happened.
++ */
++ if (gfc->mf_samples_to_encode < 1) {
++ gfc->mf_samples_to_encode = ENCDELAY + POSTDELAY;
++ }
+ gfc->mf_samples_to_encode += n_out;
+
+
+ if (gfc->mf_size >= mf_needed) {
+ /* encode the frame. */
+@@ -1929,10 +1936,14 @@
+ int end_padding = POSTDELAY;
+ int pad_out_samples;
+ int frames_left;
+ int samples_to_encode = gfc->mf_samples_to_encode;
+
++ /* Was flush already called? */
++ if (gfc->mf_samples_to_encode < 1) {
++ return 0;
++ }
+ memset(buffer, 0, sizeof(buffer));
+ mp3count = 0;
+
+ if (gfp->in_samplerate != gfp->out_samplerate) {
+ /* delay due to resampling; needs to be fixed, if resampling code gets changed */
+@@ -1940,35 +1951,38 @@
+ }
+ pad_out_samples = gfp->framesize - (samples_to_encode % gfp->framesize);
+ end_padding += pad_out_samples;
+
+ frames_left = (samples_to_encode + pad_out_samples) / gfp->framesize;
+- while (frames_left > 0) {
++
++ /* send in a frame of 0 padding until all internal sample buffers are flushed */
++ while (frames_left > 0 && imp3 >= 0) {
+ int frame_num = gfp->frameNum;
+
+ mp3buffer_size_remaining = mp3buffer_size - mp3count;
+
+ /* if user specifed buffer size = 0, dont check size */
+ if (mp3buffer_size == 0)
+ mp3buffer_size_remaining = 0;
+
+- /* send in a frame of 0 padding until all internal sample buffers
+- * are flushed
+- */
+ imp3 = lame_encode_buffer(gfp, buffer[0], buffer[1], 32,
+ mp3buffer, mp3buffer_size_remaining);
+
+- if (frame_num != gfp->frameNum) {
+- --frames_left;
+- }
+- if (imp3 < 0) {
+- /* some type of fatal error */
+- return imp3;
+- }
+ mp3buffer += imp3;
+ mp3count += imp3;
++ frames_left -= (frame_num != gfp->frameNum) ? 1 : 0;
+ }
++ /* Set gfc->mf_samples_to_encode to 0, so we may detect
++ * and break loops calling it more than once in a row.
++ */
++ gfc->mf_samples_to_encode = 0;
++
++ if (imp3 < 0) {
++ /* some type of fatal error */
++ return imp3;
++ }
++
+ mp3buffer_size_remaining = mp3buffer_size - mp3count;
+ /* if user specifed buffer size = 0, dont check size */
+ if (mp3buffer_size == 0)
+ mp3buffer_size_remaining = 0;
+