summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLinux User <larena@df1844j.ita.wtbts.net>2009-06-06 17:39:26 +0000
committerLinux User <larena@df1844j.ita.wtbts.net>2009-06-06 17:39:26 +0000
commit79432d9beaa9c79da731316d957eb2c5b6016ed9 (patch)
treec383aca5b2e73bf2d94368cff39b09cb8f403c01
parent5b473951fda9961f156f07c0af0179e1d76a2d7c (diff)
downloadaports-79432d9beaa9c79da731316d957eb2c5b6016ed9.tar.bz2
aports-79432d9beaa9c79da731316d957eb2c5b6016ed9.tar.xz
testing/spamassassin: init script added
-rw-r--r--testing/spamassassin/APKBUILD2
-rw-r--r--testing/spamassassin/spamd.conf46
-rw-r--r--testing/spamassassin/spamd.init39
3 files changed, 87 insertions, 0 deletions
diff --git a/testing/spamassassin/APKBUILD b/testing/spamassassin/APKBUILD
index 0c11b29c..657d2ae1 100644
--- a/testing/spamassassin/APKBUILD
+++ b/testing/spamassassin/APKBUILD
@@ -19,6 +19,8 @@ build() {
PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor || return 1
make || return 1
make DESTDIR="$pkgdir" install
+ install -m755 -D ../../spamd.init $pkgdir/etc/init.d/spamd
+ install -m644 -D ../../spamd.conf $pkgdir/etc/conf.d/spamd.conf
# creates file collision among perl modules
rm $pkgdir/usr/lib/perl5/5.10.0/x86_64-linux/perllocal.pod
}
diff --git a/testing/spamassassin/spamd.conf b/testing/spamassassin/spamd.conf
new file mode 100644
index 00000000..b6fca036
--- /dev/null
+++ b/testing/spamassassin/spamd.conf
@@ -0,0 +1,46 @@
+# Config file for /etc/init.d/spamd
+
+
+# ***WARNING***
+# spamd was not designed to listed to an untrusted network. spamd
+# is vulnerable to DoS attacks (and eternal doom) if used to listen
+# to an untrusted network.
+#
+
+
+# Some options:
+#
+# -c to create a per user configuration file
+# -H [dir] to switch home dirs for helper apps, dir optional
+# -i [ip] to listen on the specified IP,
+# 127.0.0.1 if omitted,
+# 0.0.0.0 (ie. all) if given without value;
+# must be used in combination with -A to actually allow
+# connections from anybody but localhost
+# -m limit to set the number of children, default 5
+# -u user the user to run spamd as
+# -L if you want to run no net tests
+#
+# for more help look in man spamd
+#
+# Note: if you plan on using the -u flag to spamd you will need to
+# make sure the location of the PID file is writable by that user.
+# This can be done by making the directory /var/run/spamd and
+# changing the owner to the UID that runs spamd. You will then
+# need to edit $pidfile in /etc/init.d/spamd. This should fix the
+# problem with stop/restart in the init scripts.
+#
+# See http://bugs.gentoo.org/show_bug.cgi?id=70124 for a full
+# explanation.
+
+SPAMD_OPTS="-m 5 -c -H"
+
+# spamd stores its pid in this file. If you use the -u option to
+# run spamd under another user, you might need to adjust it.
+
+PIDFILE="/var/run/spamd.pid"
+
+# SPAMD_NICELEVEL lets you set the 'nice'ness of the running
+# spamd process
+
+# SPAMD_NICELEVEL=5
diff --git a/testing/spamassassin/spamd.init b/testing/spamassassin/spamd.init
new file mode 100644
index 00000000..89723889
--- /dev/null
+++ b/testing/spamassassin/spamd.init
@@ -0,0 +1,39 @@
+#!/sbin/runscript
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/www/viewcvs.gentoo.org/raw_cvs/gentoo-x86/mail-filter/spamassassin/files/3.0.0-spamd.init,v 1.8 2008/05/14 21:25:56 sbriesen Exp $
+
+# NB: Config is in /etc/conf.d/spamd
+
+# Provide a default location if they haven't in /etc/conf.d/spamd
+PIDFILE=${PIDFILE:-/var/run/spamd.pid}
+
+opts="reload"
+
+depend() {
+ need net
+ before mta
+ use logger
+}
+
+start() {
+ ebegin "Starting spamd"
+ start-stop-daemon --start --quiet \
+ --name spamd \
+ --nicelevel ${SPAMD_NICELEVEL:-0} \
+ --exec /usr/sbin/spamd -- -d -r ${PIDFILE} \
+ ${SPAMD_OPTS}
+ eend $? "Failed to start spamd"
+}
+
+stop() {
+ ebegin "Stopping spamd"
+ start-stop-daemon --stop --quiet --pidfile ${PIDFILE}
+ eend $? "Failed to stop spamd"
+}
+
+reload() {
+ ebegin "Reloading configuration"
+ kill -HUP $(< ${PIDFILE})
+ eend $?
+}