summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2009-09-13 10:21:55 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2009-09-13 10:21:55 +0000
commit83034c5eccfc66cade38c53faea2524b7d472da0 (patch)
tree8bc8fbf188f41e9369e364ca79e7de58d6846fca
parentc6a536a7c985a2e6da81c41190e6c565cf0c3e9d (diff)
downloadaports-83034c5eccfc66cade38c53faea2524b7d472da0.tar.bz2
aports-83034c5eccfc66cade38c53faea2524b7d472da0.tar.xz
main/uclibc: add dn_skipname() support
Needed by wine and others
-rw-r--r--main/uclibc/0001-Add-dn_skipname-from-OpenBSD.patch115
-rw-r--r--main/uclibc/APKBUILD4
2 files changed, 118 insertions, 1 deletions
diff --git a/main/uclibc/0001-Add-dn_skipname-from-OpenBSD.patch b/main/uclibc/0001-Add-dn_skipname-from-OpenBSD.patch
new file mode 100644
index 00000000..6dd7b17c
--- /dev/null
+++ b/main/uclibc/0001-Add-dn_skipname-from-OpenBSD.patch
@@ -0,0 +1,115 @@
+From ab443685d9f923afcdfb9fbb071a293b53aa3c40 Mon Sep 17 00:00:00 2001
+From: Natanael Copa <natanael.copa@gmail.com>
+Date: Sun, 13 Sep 2009 09:53:09 +0000
+Subject: [PATCH] Add dn_skipname() from OpenBSD
+
+dn_skipname() is needed by a few applications like yate, wine, kde and
+probably more.
+---
+ libresolv/resolv.c | 85 ++++++++++++++++++++++++++++++++++++++++++++++++++++
+ 1 files changed, 85 insertions(+), 0 deletions(-)
+
+diff --git a/libresolv/resolv.c b/libresolv/resolv.c
+index 38b10ff..c55046d 100644
+--- a/libresolv/resolv.c
++++ b/libresolv/resolv.c
+@@ -7,7 +7,9 @@
+ * Licensed under the LGPL v2.1, see the file COPYING.LIB in this tarball.
+ */
+
++#include <sys/types.h>
+ #include <features.h>
++#include <resolv.h>
+
+ void __stub1(void);
+ void __stub1(void)
+@@ -16,3 +18,86 @@ void __stub1(void)
+ }
+ link_warning (__stub1, "the `libresolv' library is a stub. Do you really need it?")
+
++/* taken from OpenBSD source */
++/*
++ * ++Copyright++ 1985, 1993
++ * -
++ * Copyright (c) 1985, 1993
++ * The Regents of the University of California. All rights reserved.
++ *
++ * Redistribution and use in source and binary forms, with or without
++ * modification, are permitted provided that the following conditions
++ * are met:
++ * 1. Redistributions of source code must retain the above copyright
++ * notice, this list of conditions and the following disclaimer.
++ * 2. Redistributions in binary form must reproduce the above copyright
++ * notice, this list of conditions and the following disclaimer in the
++ * documentation and/or other materials provided with the distribution.
++ * 3. Neither the name of the University nor the names of its contributors
++ * may be used to endorse or promote products derived from this software
++ * without specific prior written permission.
++ *
++ * THIS SOFTWARE IS PROVIDED BY THE REGENTS AND CONTRIBUTORS ``AS IS'' AND
++ * ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
++ * IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE
++ * ARE DISCLAIMED. IN NO EVENT SHALL THE REGENTS OR CONTRIBUTORS BE LIABLE
++ * FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL
++ * DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS
++ * OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION)
++ * HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT
++ * LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY
++ * OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF
++ * SUCH DAMAGE.
++ * -
++ * Portions Copyright (c) 1993 by Digital Equipment Corporation.
++ *
++ * Permission to use, copy, modify, and distribute this software for any
++ * purpose with or without fee is hereby granted, provided that the above
++ * copyright notice and this permission notice appear in all copies, and that
++ * the name of Digital Equipment Corporation not be used in advertising or
++ * publicity pertaining to distribution of the document or software without
++ * specific, written prior permission.
++ *
++ * THE SOFTWARE IS PROVIDED "AS IS" AND DIGITAL EQUIPMENT CORP. DISCLAIMS ALL
++ * WARRANTIES WITH REGARD TO THIS SOFTWARE, INCLUDING ALL IMPLIED WARRANTIES
++ * OF MERCHANTABILITY AND FITNESS. IN NO EVENT SHALL DIGITAL EQUIPMENT
++ * CORPORATION BE LIABLE FOR ANY SPECIAL, DIRECT, INDIRECT, OR CONSEQUENTIAL
++ * DAMAGES OR ANY DAMAGES WHATSOEVER RESULTING FROM LOSS OF USE, DATA OR
++ * PROFITS, WHETHER IN AN ACTION OF CONTRACT, NEGLIGENCE OR OTHER TORTIOUS
++ * ACTION, ARISING OUT OF OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THIS
++ * SOFTWARE.
++ * -
++ * --Copyright--
++ */
++
++/*
++ * Skip over a compressed domain name. Return the size or -1.
++ */
++int
++__dn_skipname(const u_char *comp_dn, const u_char *eom)
++{
++ const u_char *cp;
++ int n;
++
++ cp = comp_dn;
++ while (cp < eom && (n = *cp++)) {
++ /*
++ * check for indirection
++ */
++ switch (n & INDIR_MASK) {
++ case 0: /* normal case, n == len */
++ cp += n;
++ continue;
++ case INDIR_MASK: /* indirection */
++ cp++;
++ break;
++ default: /* illegal type */
++ return (-1);
++ }
++ break;
++ }
++ if (cp > eom)
++ return (-1);
++ return (cp - comp_dn);
++}
++
+--
+1.6.4.2
+
diff --git a/main/uclibc/APKBUILD b/main/uclibc/APKBUILD
index b4692019..ca217c06 100644
--- a/main/uclibc/APKBUILD
+++ b/main/uclibc/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=uclibc
pkgver=0.9.30.1
-pkgrel=17
+pkgrel=18
pkgdesc="C library for developing embedded Linux systems"
url=http://uclibc.org
license="LGPL-2"
@@ -13,6 +13,7 @@ depends_dev="linux-headers"
source="http://uclibc.org/downloads/$_mynamever.tar.bz2
$pkgname-0.9.30.1-resolv.patch
uclibc-0.9.30.1-pthread_getattr_np.patch
+ 0001-Add-dn_skipname-from-OpenBSD.patch
0001-ldd-segfault-fix.patch
0001-linuxthreads-fixes-from-Will-Newton-will.newton-AT-g.patch
0001-include-sys-mount.h-define-MNT_DETATCH-and-MNT_EXPIR.patch
@@ -65,6 +66,7 @@ build() {
md5sums="1a4b84e5536ad8170563ffa88c34679c uClibc-0.9.30.1.tar.bz2
ea91460617601b6e084ead66bc3948f5 uclibc-0.9.30.1-resolv.patch
cf80c0d44a41e02f389be427ee615d61 uclibc-0.9.30.1-pthread_getattr_np.patch
+c9e3df01e854db4b1118266acd9bcfbd 0001-Add-dn_skipname-from-OpenBSD.patch
4079b20c763727863bc53408e4988434 0001-ldd-segfault-fix.patch
bcd1c4c9c87f092fb4631559e6ec13ba 0001-linuxthreads-fixes-from-Will-Newton-will.newton-AT-g.patch
7ac347d2921e12c4acdfedc4eb4e5d9c 0001-include-sys-mount.h-define-MNT_DETATCH-and-MNT_EXPIR.patch