summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2009-07-15 06:47:44 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2009-07-15 06:47:44 +0000
commitb361eb86e5d6928df346b8ca4bcfac03e9b3cdae (patch)
tree7c7d720f2216741e8d457429177cfd6424982d52
parente161341358ccb5db48e3d6e0ad66c86efede2638 (diff)
parent12058bc904a1ae0793e0c6ebb173846bc001f6e3 (diff)
downloadaports-b361eb86e5d6928df346b8ca4bcfac03e9b3cdae.tar.bz2
aports-b361eb86e5d6928df346b8ca4bcfac03e9b3cdae.tar.xz
Merge commit 'mmason/master'
-rw-r--r--extra/hylafax/APKBUILD (renamed from testing/hylafax/APKBUILD)0
-rw-r--r--extra/hylafax/hylafax.post-install (renamed from testing/hylafax/hylafax.post-install)0
-rw-r--r--extra/iaxmodem/iaxmodem.confd7
-rw-r--r--extra/iaxmodem/iaxmodem.initd43
4 files changed, 50 insertions, 0 deletions
diff --git a/testing/hylafax/APKBUILD b/extra/hylafax/APKBUILD
index 42450d46..42450d46 100644
--- a/testing/hylafax/APKBUILD
+++ b/extra/hylafax/APKBUILD
diff --git a/testing/hylafax/hylafax.post-install b/extra/hylafax/hylafax.post-install
index 839f96f5..839f96f5 100644
--- a/testing/hylafax/hylafax.post-install
+++ b/extra/hylafax/hylafax.post-install
diff --git a/extra/iaxmodem/iaxmodem.confd b/extra/iaxmodem/iaxmodem.confd
new file mode 100644
index 00000000..082a920e
--- /dev/null
+++ b/extra/iaxmodem/iaxmodem.confd
@@ -0,0 +1,7 @@
+# Configfile for /etc/init.d/iaxmodem
+
+# Set the priority of the iaxmodem process
+# Value: (highest) -20..19 (lowest)
+#
+#IAXMODEM_NICE="-5"
+
diff --git a/extra/iaxmodem/iaxmodem.initd b/extra/iaxmodem/iaxmodem.initd
new file mode 100644
index 00000000..d6f2c947
--- /dev/null
+++ b/extra/iaxmodem/iaxmodem.initd
@@ -0,0 +1,43 @@
+#!/sbin/runscript
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/www/viewcvs.gentoo.org/raw_cvs/gentoo-x86/net-misc/iaxmodem/files/iaxmodem.initd,v 1.1 2008/10/14 23:53:39 sbriesen Exp $
+
+description="IAXmodem"
+description_reload="Reread configuration file and make the appropriate changes"
+extra_started_commands="reload"
+command="/usr/sbin/iaxmodem"
+pidfile="/var/run/iaxmodem.pid"
+name="iaxmodem"
+
+depend() {
+ use asterisk
+ need net
+}
+
+start() {
+ ebegin "Starting ${description}"
+ start-stop-daemon --start --quiet --pidfile "${pidfile}" \
+ --env TMPDIR="/tmp" --nice ${IAXMODEM_NICE:-0} --exec "${command}"
+ eend ${?}
+}
+
+stop() {
+ local childs=""
+ ebegin "Stopping ${description}"
+ # start-stop-daemon doesn't kill childs reliable, so we
+ # use a combination of pgrep + start-stop-daemon + kill
+ [ -s "${pidfile}" ] && childs=$(pgrep -P $(cat "${pidfile}"))
+ start-stop-daemon --stop --quiet --pidfile "${pidfile}" --retry TERM/10/KILL/5
+ if eend ${?}; then
+ # if there're still childs running, kill them!
+ [ -n "${childs}" ] && kill -KILL ${childs} 2>/dev/null
+ return 0
+ fi
+}
+
+reload() {
+ ebegin "Reloading ${description} configuration"
+ start-stop-daemon --stop --signal HUP --pidfile "${pidfile}"
+ eend ${?}
+}