summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2009-09-10 13:51:42 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2009-09-10 13:51:42 +0000
commitef3f84edbe709face0fef13166d23bf61943b8eb (patch)
tree25a9a75cd82397973b3fa9fca23e359c15812cd1
parenta62a4fae276a8a124facce56b18fa7ec50bc9266 (diff)
downloadaports-ef3f84edbe709face0fef13166d23bf61943b8eb.tar.bz2
aports-ef3f84edbe709face0fef13166d23bf61943b8eb.tar.xz
main/uclibc: define MNT_DETATCH in sys/mount.h
Needed for util-vserver
-rw-r--r--main/uclibc/0001-include-sys-mount.h-define-MNT_DETATCH-and-MNT_EXPIR.patch31
-rw-r--r--main/uclibc/APKBUILD4
2 files changed, 34 insertions, 1 deletions
diff --git a/main/uclibc/0001-include-sys-mount.h-define-MNT_DETATCH-and-MNT_EXPIR.patch b/main/uclibc/0001-include-sys-mount.h-define-MNT_DETATCH-and-MNT_EXPIR.patch
new file mode 100644
index 00000000..88c24904
--- /dev/null
+++ b/main/uclibc/0001-include-sys-mount.h-define-MNT_DETATCH-and-MNT_EXPIR.patch
@@ -0,0 +1,31 @@
+From 4e2ea87facfbf595920ebd78e10a57b5ab334526 Mon Sep 17 00:00:00 2001
+From: Natanael Copa <ncopa@alpinelinux.org>
+Date: Tue, 8 Sep 2009 12:40:24 +0000
+Subject: [PATCH] include/sys/mount.h: define MNT_DETATCH and MNT_EXPIRE
+
+This is how glibc does it.
+---
+ include/sys/mount.h | 6 +++++-
+ 1 files changed, 5 insertions(+), 1 deletions(-)
+
+diff --git a/include/sys/mount.h b/include/sys/mount.h
+index b305549..f17064d 100644
+--- a/include/sys/mount.h
++++ b/include/sys/mount.h
+@@ -96,8 +96,12 @@ enum
+ /* Possible value for FLAGS parameter of `umount2'. */
+ enum
+ {
+- MNT_FORCE = 1 /* Force unmounting. */
++ MNT_FORCE = 1, /* Force unmounting. */
+ #define MNT_FORCE MNT_FORCE
++ MNT_DETACH = 2, /* Just detach from the tree. */
++#define MNT_DETACH MNT_DETACH
++ MNT_EXPIRE = 4 /* Mark for expiry. */
++#define MNT_EXPIRE MNT_EXPIRE
+ };
+
+
+--
+1.6.4.2
+
diff --git a/main/uclibc/APKBUILD b/main/uclibc/APKBUILD
index 4210b3e6..b4692019 100644
--- a/main/uclibc/APKBUILD
+++ b/main/uclibc/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=uclibc
pkgver=0.9.30.1
-pkgrel=16
+pkgrel=17
pkgdesc="C library for developing embedded Linux systems"
url=http://uclibc.org
license="LGPL-2"
@@ -15,6 +15,7 @@ source="http://uclibc.org/downloads/$_mynamever.tar.bz2
uclibc-0.9.30.1-pthread_getattr_np.patch
0001-ldd-segfault-fix.patch
0001-linuxthreads-fixes-from-Will-Newton-will.newton-AT-g.patch
+ 0001-include-sys-mount.h-define-MNT_DETATCH-and-MNT_EXPIR.patch
fstatat-fix-32bit.patch
pthread-new-aliasing-fix.diff
uclibc-resolv-cname-fix.diff
@@ -66,6 +67,7 @@ ea91460617601b6e084ead66bc3948f5 uclibc-0.9.30.1-resolv.patch
cf80c0d44a41e02f389be427ee615d61 uclibc-0.9.30.1-pthread_getattr_np.patch
4079b20c763727863bc53408e4988434 0001-ldd-segfault-fix.patch
bcd1c4c9c87f092fb4631559e6ec13ba 0001-linuxthreads-fixes-from-Will-Newton-will.newton-AT-g.patch
+7ac347d2921e12c4acdfedc4eb4e5d9c 0001-include-sys-mount.h-define-MNT_DETATCH-and-MNT_EXPIR.patch
14d9fa172f67fee0257f0441b3b3bc13 fstatat-fix-32bit.patch
969187e1da84d0a0a5957b392a3d5a2b pthread-new-aliasing-fix.diff
bbb8475963e791f596c34c81ef5583d7 uclibc-resolv-cname-fix.diff