summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2010-04-20 11:19:50 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2010-04-20 11:53:04 +0000
commit402c2bb5e82a560fbaa2e50947d82520b8150014 (patch)
tree2918f70a7c85b421099f086976fefc00f87fd5ae
parent0096ba8a9670b53b45ca6398f589214167c17ffc (diff)
downloadaports-402c2bb5e82a560fbaa2e50947d82520b8150014.tar.bz2
aports-402c2bb5e82a560fbaa2e50947d82520b8150014.tar.xz
main/ez-ipupdate: buildfix for errno
-rw-r--r--main/ez-ipupdate/APKBUILD20
-rw-r--r--main/ez-ipupdate/errno.patch56
2 files changed, 72 insertions, 4 deletions
diff --git a/main/ez-ipupdate/APKBUILD b/main/ez-ipupdate/APKBUILD
index 33cb03ea..9da97305 100644
--- a/main/ez-ipupdate/APKBUILD
+++ b/main/ez-ipupdate/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Jeremy Thomerson <jeremy@thomersonfamily.com>
pkgname=ez-ipupdate
pkgver=3.0.10
-pkgrel=1
+pkgrel=0
pkgdesc="utility for updating your host name for many of the dynamic DNS services (ez-ip.net, dyndns.org, etc)"
url="http://ez-ipupdate.com/"
license="GPL"
@@ -13,16 +13,27 @@ subpackages=""
source="http://ez-ipupdate.com/dist/$pkgname-$pkgver.tar.gz
ez-ipupdate.confd
ez-ipupdate.initd
+ errno.patch
"
+_builddir="$srcdir"/$pkgname-$pkgver
+prepare() {
+ cd "$_builddir"
+ for A in ../*.patch ; do
+ patch -p1 < $A
+ done
+}
build() {
- cd "$srcdir"/$pkgname-$pkgver
-
+ cd "$_builddir"
./configure --prefix=/usr \
--sysconfdir=/etc \
--mandir=/usr/share/man \
--infodir=/usr/share/info
make || return 1
+}
+
+package() {
+ cd "$_builddir"
make DESTDIR="$pkgdir" install
install -m755 -D "$srcdir"/$pkgname.initd "$pkgdir"/etc/init.d/$pkgname
@@ -33,4 +44,5 @@ build() {
md5sums="6505c9d18ef6b5ce13fe2a668eb5724b ez-ipupdate-3.0.10.tar.gz
e6e06780b1896f2250132cc16cd10710 ez-ipupdate.confd
-6b9ce71b7b6b739794f003b2ebbf66ed ez-ipupdate.initd"
+6b9ce71b7b6b739794f003b2ebbf66ed ez-ipupdate.initd
+1fede0dcb5d9ca108855df0a9d213413 errno.patch"
diff --git a/main/ez-ipupdate/errno.patch b/main/ez-ipupdate/errno.patch
new file mode 100644
index 00000000..fea52580
--- /dev/null
+++ b/main/ez-ipupdate/errno.patch
@@ -0,0 +1,56 @@
+# --- T2-COPYRIGHT-NOTE-BEGIN ---
+# This copyright note is auto-generated by ./scripts/Create-CopyPatch.
+#
+# T2 SDE: package/.../ezipupdate/errno.patch
+# Copyright (C) 2004 - 2005 The T2 SDE Project
+# Copyright (C) 1998 - 2003 ROCK Linux Project
+#
+# More information can be found in the files COPYING and README.
+#
+# This patch file is dual-licensed. It is available under the license the
+# patched project is licensed under, as long as it is an OpenSource license
+# as defined at http://www.opensource.org/ (e.g. BSD, X11) or under the terms
+# of the GNU General Public License as published by the Free Software
+# Foundation; either version 2 of the License, or (at your option) any later
+# version.
+# --- T2-COPYRIGHT-NOTE-END ---
+
+--- ./conf_file.c.orig 2000-10-23 04:36:18.000000000 +0200
++++ ./conf_file.c 2003-05-28 08:42:42.000000000 +0200
+@@ -1,4 +1,4 @@
+-/* ============================================================================
++ /* ============================================================================
+ * Copyright (C) 1999 Angus Mackay. All rights reserved;
+ *
+ * This program is free software; you can redistribute it and/or modify
+@@ -37,13 +37,16 @@
+
+ #include <conf_file.h>
+
+-#if HAVE_STRERROR
++#if HAVE_ERRNO_H
++# include <errno.h>
++#elif HAVE_STRERROR
+ extern int errno;
+ # define error_string strerror(errno)
+-#elif HAVE_SYS_ERRLIST
+-extern const char *const sys_errlist[];
+-extern int errno;
+-# define error_string (sys_errlist[errno])
++#endif
++
++#if HAVE_SYS_ERRLIST
++//extern char *const strerror[];
++# define error_string (strerror[errno])
+ #else
+ # define error_string "error message not found"
+ #endif
+@@ -85,7 +88,7 @@ int parse_conf_file(char *fname, struct
+ {
+ if((in=fopen(fname, "r")) == NULL)
+ {
+- fprintf(stderr, "could not open config file \"%s\": %s\n", fname, error_string);
++ fprintf(stderr, "could not open config file \"%s\"\n", fname);
+ return(-1);
+ }
+ }