summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2010-02-17 13:39:01 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2010-02-17 13:39:01 +0000
commit5c7093de598d1562a4ed4ce06eb3d14a610d19d4 (patch)
tree50285cb20ddae55c679278bc5684d6a053da1277
parent76c80518e2b5efa303c3a4a91edf145acca4b7a5 (diff)
downloadaports-5c7093de598d1562a4ed4ce06eb3d14a610d19d4.tar.bz2
aports-5c7093de598d1562a4ed4ce06eb3d14a610d19d4.tar.xz
testing/wine: upgrade to 1.1.38
-rw-r--r--testing/wine/0001-Always-adjust-the-color_shifts-pointer-when-SelectBi.patch39
-rw-r--r--testing/wine/APKBUILD27
-rw-r--r--testing/wine/libpng14.patch76
3 files changed, 93 insertions, 49 deletions
diff --git a/testing/wine/0001-Always-adjust-the-color_shifts-pointer-when-SelectBi.patch b/testing/wine/0001-Always-adjust-the-color_shifts-pointer-when-SelectBi.patch
deleted file mode 100644
index 05ac3141..00000000
--- a/testing/wine/0001-Always-adjust-the-color_shifts-pointer-when-SelectBi.patch
+++ /dev/null
@@ -1,39 +0,0 @@
-From 0454ace14774654c3670a2a29613bed5039991c5 Mon Sep 17 00:00:00 2001
-From: Roderick Colenbrander <thunderbird2k@gmail.com>
-Date: Thu, 3 Sep 2009 13:51:44 +0200
-Subject: [PATCH] Always adjust the color_shifts pointer when SelectBitmap is called. This fixes a regression in Steam (bug 19916).
-
----
- dlls/winex11.drv/bitmap.c | 10 ++++++----
- 1 files changed, 6 insertions(+), 4 deletions(-)
-
-diff --git a/dlls/winex11.drv/bitmap.c b/dlls/winex11.drv/bitmap.c
-index 4d635aa..fee2dbc 100644
---- a/dlls/winex11.drv/bitmap.c
-+++ b/dlls/winex11.drv/bitmap.c
-@@ -110,10 +110,6 @@ HBITMAP CDECL X11DRV_SelectBitmap( X11DRV_PDEVICE *physDev, HBITMAP hbitmap )
- if (physDev->depth != physBitmap->pixmap_depth)
- {
- physDev->depth = physBitmap->pixmap_depth;
-- if(physDev->depth == 1)
-- physDev->color_shifts = NULL;
-- else
-- physDev->color_shifts = &physBitmap->pixmap_color_shifts;
- wine_tsx11_lock();
- XFreeGC( gdi_display, physDev->gc );
- physDev->gc = XCreateGC( gdi_display, physDev->drawable, 0, NULL );
-@@ -122,6 +118,12 @@ HBITMAP CDECL X11DRV_SelectBitmap( X11DRV_PDEVICE *physDev, HBITMAP hbitmap )
- XFlush( gdi_display );
- wine_tsx11_unlock();
- }
-+
-+ if(physDev->depth == 1)
-+ physDev->color_shifts = NULL;
-+ else
-+ physDev->color_shifts = &physBitmap->pixmap_color_shifts;
-+
- return hbitmap;
- }
-
---
-1.6.0.4
diff --git a/testing/wine/APKBUILD b/testing/wine/APKBUILD
index 82ecba1b..35ae3634 100644
--- a/testing/wine/APKBUILD
+++ b/testing/wine/APKBUILD
@@ -1,23 +1,30 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=wine
-pkgver=1.1.36
+pkgver=1.1.38
pkgrel=0
pkgdesc="A compatibility layer for running Windows programs"
url="http://www.winehq.com"
license="LGPL"
subpackages="$pkgname-dev $pkgname-doc"
makedepends="fontconfig-dev openldap-dev libxslt-dev libxxf86dga-dev
- libxcursor-dev libxrandr-dev libxdamage-dev mesa-dev flex bison"
+ libxcursor-dev libxrandr-dev libxdamage-dev mesa-dev flex bison
+ libpng-dev jpeg-dev freetype-dev"
# lcms
source="http://ibiblio.org/pub/linux/system/emulators/$pkgname/$pkgname-$pkgver.tar.bz2
- 0001-Always-adjust-the-color_shifts-pointer-when-SelectBi.patch"
+ libpng14.patch"
+
+_builddir="$srcdir"/$pkgname-$pkgver
+prepare() {
+ cd "$_builddir"
+ patch -p1 -i "$srcdir"/libpng14.patch
+}
build() {
- cd "$srcdir"/$pkgname-$pkgver
- patch -Np1 -i "$srcdir"/0001-Always-adjust-the-color_shifts-pointer-when-SelectBi.patch
- ./configure --prefix=/usr --sysconfdir=/etc --with-x
- make depend || return 1
- make || return 1
+ cd "$_builddir"
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --with-x
+ make depend && make
}
package() {
@@ -25,5 +32,5 @@ package() {
make prefix="$pkgdir"/usr install || return 1
mkdir -p "$pkgdir"/etc/wine
}
-md5sums="2afa7846175c7c2ce4c7482aa1d82f0f wine-1.1.36.tar.bz2
-63c4a6aee199039d35e6b57fa505e887 0001-Always-adjust-the-color_shifts-pointer-when-SelectBi.patch"
+md5sums="ef5947bcb9667b75b8de4a2ce16d0ec2 wine-1.1.38.tar.bz2
+51f78b18168d5abd78411e9e66458d55 libpng14.patch"
diff --git a/testing/wine/libpng14.patch b/testing/wine/libpng14.patch
new file mode 100644
index 00000000..14f6ddc0
--- /dev/null
+++ b/testing/wine/libpng14.patch
@@ -0,0 +1,76 @@
+diff --git a/programs/winemenubuilder/winemenubuilder.c b/programs/winemenubuilder/winemenubuilder.c
+index e14fe81..62165f6 100644
+--- a/programs/winemenubuilder/winemenubuilder.c
++++ b/programs/winemenubuilder/winemenubuilder.c
+@@ -188,8 +188,10 @@ static void *libpng_handle;
+ MAKE_FUNCPTR(png_create_info_struct);
+ MAKE_FUNCPTR(png_create_write_struct);
+ MAKE_FUNCPTR(png_destroy_write_struct);
++MAKE_FUNCPTR(png_get_error_ptr);
+ MAKE_FUNCPTR(png_init_io);
+ MAKE_FUNCPTR(png_set_bgr);
++MAKE_FUNCPTR(png_set_error_fn);
+ MAKE_FUNCPTR(png_set_text);
+ MAKE_FUNCPTR(png_set_IHDR);
+ MAKE_FUNCPTR(png_write_end);
+@@ -209,8 +211,10 @@ static void *load_libpng(void)
+ LOAD_FUNCPTR(png_create_info_struct);
+ LOAD_FUNCPTR(png_create_write_struct);
+ LOAD_FUNCPTR(png_destroy_write_struct);
++ LOAD_FUNCPTR(png_get_error_ptr);
+ LOAD_FUNCPTR(png_init_io);
+ LOAD_FUNCPTR(png_set_bgr);
++ LOAD_FUNCPTR(png_set_error_fn);
+ LOAD_FUNCPTR(png_set_IHDR);
+ LOAD_FUNCPTR(png_set_text);
+ LOAD_FUNCPTR(png_write_end);
+@@ -221,6 +225,23 @@ static void *load_libpng(void)
+ return libpng_handle;
+ }
+
++static void user_error_fn(png_structp png_ptr, png_const_charp error_message)
++{
++ jmp_buf *pjmpbuf;
++
++ /* This uses setjmp/longjmp just like the default. We can't use the
++ * default because there's no way to access the jmp buffer in the png_struct
++ * that works in 1.2 and 1.4 and allows us to dynamically load libpng. */
++ WINE_ERR("PNG error: %s\n", wine_dbgstr_an(error_message, -1));
++ pjmpbuf = ppng_get_error_ptr(png_ptr);
++ longjmp(*pjmpbuf, 1);
++}
++
++static void user_warning_fn(png_structp png_ptr, png_const_charp warning_message)
++{
++ WINE_WARN("PNG warning: %s\n", wine_dbgstr_an(warning_message, -1));
++}
++
+ static BOOL SaveIconResAsPNG(const BITMAPINFO *pIcon, const char *png_filename, LPCWSTR commentW)
+ {
+ static const char comment_key[] = "Created from";
+@@ -234,6 +255,7 @@ static BOOL SaveIconResAsPNG(const BITMAPINFO *pIcon, const char *png_filename,
+ int nWidth = pIcon->bmiHeader.biWidth;
+ int nHeight = pIcon->bmiHeader.biHeight;
+ int nBpp = pIcon->bmiHeader.biBitCount;
++ jmp_buf jmpbuf;
+
+ switch (nBpp)
+ {
+@@ -306,12 +328,12 @@ static BOOL SaveIconResAsPNG(const BITMAPINFO *pIcon, const char *png_filename,
+ !(info_ptr = ppng_create_info_struct(png_ptr)))
+ goto error;
+
+- if (setjmp(png_jmpbuf(png_ptr)))
++ if (setjmp(jmpbuf))
+ {
+ /* All future errors jump here */
+- WINE_ERR("png error\n");
+ goto error;
+ }
++ ppng_set_error_fn(png_ptr, &jmpbuf, user_error_fn, user_warning_fn);
+
+ ppng_init_io(png_ptr, fp);
+ ppng_set_IHDR(png_ptr, info_ptr, nWidth, nHeight, 8,
+--
+1.6.3.3
+