summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2010-04-06 13:55:05 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2010-04-06 13:55:05 +0000
commitb028d32b6c5b556f63c6d9532139f0b123c9f8fc (patch)
treead32b8efb7461cc920f8cf97ad841194a8738dfa
parent119b6beee6bb1170de7a17cb87182b4763c0c35c (diff)
downloadaports-b028d32b6c5b556f63c6d9532139f0b123c9f8fc.tar.bz2
aports-b028d32b6c5b556f63c6d9532139f0b123c9f8fc.tar.xz
main/icu: upgrade to 4.4
-rw-r--r--main/icu/APKBUILD13
1 files changed, 9 insertions, 4 deletions
diff --git a/main/icu/APKBUILD b/main/icu/APKBUILD
index c2150b3e..f37e7664 100644
--- a/main/icu/APKBUILD
+++ b/main/icu/APKBUILD
@@ -1,6 +1,6 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=icu
-pkgver=4.2.1
+pkgver=4.4
_ver=4_2_1
pkgrel=0
pkgdesc="International Components for Unicode library"
@@ -11,14 +11,19 @@ depends=""
makedepends="uclibc++-dev"
source="http://download.icu-project.org/files/icu4c/${pkgver}/${pkgname}4c-$_ver-src.tgz"
-build ()
-{
- cd "$srcdir"/icu/source
+_builddir="$srcdir"/icu/source
+
+build() {
+ cd "$_builddir"
export CXX=g++-uc
./configure --prefix=/usr \
--sysconfdir=/etc \
--mandir=/usr/share/man
make || return 1
+}
+
+package() {
+ cd "$_builddir"
make -j1 DESTDIR="$pkgdir" install || return 1
chmod +x "$pkgdir"/usr/bin/icu-config
install -Dm644 "$srcdir"/icu/license.html \